Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Problem Nexus 7009 establish peer-keepalive

Hi,

Friend i try to join two VDC by VPC but can not , according to the error there is not comunication beteween two VDC. I check the configuration and i think is good. maybe the problem could be the module  N7K-F248XP-25E  is possible to form vpc in this module ?

 

CORE6

vrf context keepalive
  description ++ to vPC keepalive link ++
vrf context management
  ip route 0.0.0.0/0 10.0.10.1
vpc domain 1
  peer-keepalive destination 192.168.1.1 source 192.168.1.2 vrf keepalive
  peer-gateway

interface Vlan1
  no ip redirects

interface Ethernet4/37
  vrf member keepalive
  ip address 192.168.1.2/24
  no shutdown

NK7-02-CORE6# show  vpc peer-keepalive 

vPC keep-alive status             : Suspended (Destination IP not reachable)
--Send status                   : Success 
--Last send at                  : 2014.10.09 08:20:09 454 ms
--Sent on interface             : Eth4/37
--Receive status                : Failed
--Last update from peer         : (554662) seconds, (510) msec

vPC Keep-alive parameters
--Destination                   : 192.168.1.1
--Keepalive interval            : 1000 msec
--Keepalive timeout             : 5 seconds
--Keepalive hold timeout        : 3 seconds
--Keepalive vrf                 : keepalive
--Keepalive udp port            : 3200
--Keepalive tos                 : 192

Mod  Ports  Module-Type                         Model              Status
---  -----  ----------------------------------- ------------------ ----------
1    0      Supervisor Module-2                 N7K-SUP2E          active *
2    0      Supervisor Module-2                 N7K-SUP2E          ha-standby
3    24     10 Gbps Ethernet Module             N7K-M224XP-23L     ok
4    48     1/10 Gbps Ethernet Module           N7K-F248XP-25E     ok

 

CORE5

vrf context keepalive
  description ++ to vPC keepalive link ++
vrf context management
  ip route 0.0.0.0/0 10.0.10.1
vpc domain 1
  peer-keepalive destination 192.168.1.2 source 192.168.1.1 vrf keepalive
  peer-gateway

interface Vlan1
  no ip redirects

interface Ethernet4/37
  vrf member keepalive
  ip address 192.168.1.1/24
  no shutdown

N7K-01-CORE5# show  vpc peer-keepalive 

vPC keep-alive status             : Suspended (Destination IP not reachable)
--Send status                   : Success 
--Last send at                  : 2014.10.09 09:14:38 872 ms
--Sent on interface             : Eth4/37
--Receive status                : Failed
--Last update from peer         : (130903) seconds, (238) msec

vPC Keep-alive parameters
--Destination                   : 192.168.1.2
--Keepalive interval            : 1000 msec
--Keepalive timeout             : 5 seconds
--Keepalive hold timeout        : 3 seconds
--Keepalive vrf                 : keepalive
--Keepalive udp port            : 3200
--Keepalive tos                 : 192

Best regard,

 

Marco.

1 ACCEPTED SOLUTION

Accepted Solutions

What's in the routing table

What's in the routing table for the vrf keepalive?

Can you ping 192.168.1.2 from 192.168.1.1 from within that vrf?

Don't forget to rate all helpful posts.

4 REPLIES

What's in the routing table

What's in the routing table for the vrf keepalive?

Can you ping 192.168.1.2 from 192.168.1.1 from within that vrf?

Don't forget to rate all helpful posts.

New Member

Hi,friend I can´t do ping

Hi,

friend I can´t do ping

Cisco Employee

You dont have any route in

You dont have any route in VRF keepalive that is used to route the VPC keepalive traffic. Check the config of VPC domain 1, its using vrf keepalive to ping. Please can you make sure you are using " default route " or some sort of routing to get the traffic through the VRF.

 

Where is the routing happening for VRF keepalive, are these back to back connected. Try using the route like in VRF management 

 

vrf context keepalive

ip route 0.0.0.0/0 10.0.10.1

 

HTH,

-amit singh

New Member

HiI resolve the problem.. the

Hi

I resolve the problem.. the conexion is back to back.. and config was right.. but i have to reload the nexus and the vpc start to work.

 

thank for all.

277
Views
0
Helpful
4
Replies