Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Routing and loadbalancing part 3

Hi All

Still cant get the basic loadbalancing functon to work for some reason .- even when i do the 'sho service-policy CLIENT-VIPS' detail its not incrementing.

Dont know why but its just not working -

Also should i be able to connect to the other vlan 122 from a vlan 121 on the client side - i cant see anything in the manual about enabling routing

So any ideas anyone as i cant seem to get this to work - heres the non admin context config -

access-list EVERYONE line 8 extended permit tcp any any
access-list INBOUND line 1 extended permit tcp host 10.14.253.4 any

rserver host TEST-1
  ip address xx.xx.122.200
  inservice
rserver host TEST-2
  ip address xx.xx.122.201
  inservice
rserver host TEST-3
  ip address xx.xx.122.3
  inservice

serverfarm host TESTFARM
  rserver TEST-1
    inservice
  rserver TEST-2
    inservice


class-map type management match-any REMOTE-ACCESS
  2 match protocol icmp any
  3 match protocol telnet any
  4 match protocol ssh any
  5 match protocol https any
  6 match protocol http any
  7 match protocol xml-https any
class-map match-all VIP-150
  2 match virtual-address xx.xx.121.150 any

policy-map type management first-match MGMT_TEST
  class REMOTE-ACCESS
    permit

policy-map type loadbalance first-match lb-logic
  class class-default
    serverfarm TESTFARM

policy-map multi-match CLIENT-VIPS
  class VIP-150
    loadbalance vip inservice
    loadbalance policy lb-logic

interface vlan 121
  description Clients
  ip address xx.xx.121.10 255.255.255.0
  access-group input EVERYONE
  service-policy input CLIENT-VIPS
  service-policy input MGMT_TEST
  no shutdown
interface vlan 122
  description Servers Vlan
  ip address xx.xx.122.10 255.255.255.0
  no shutdown

ip route 0.0.0.0 0.0.0.0 xx.xx.121.1

xx.xx.121.1 is the switch off which i have the client xx.xx.121.4

This is my admin context -


interface gigabitEthernet 1/1
  switchport trunk allowed vlan 121
  no shutdown
interface gigabitEthernet 1/2
  switchport access vlan 1000
  no shutdown
interface gigabitEthernet 1/3
  switchport trunk allowed vlan 122
  no shutdown
interface gigabitEthernet 1/4
  shutdown


access-list ALL line 8 extended permit ip any any


class-map type management match-any remote_access
  2 match protocol xml-https any
  3 match protocol icmp any
  4 match protocol telnet any
  5 match protocol ssh any
  6 match protocol http any
O  7 match protocol https any
  8 match protocol snmp any

policy-map type management first-match remote_mgmt_allow_policy
  class remote_access
    permit

interface vlan 121
  ip address xx.xx.121.171 255.255.255.0
  access-group input ALLly
  service-policy input remote_mgmt_allow_policy
  no shutdown
interface vlan 122
  ip address xx.xx.122.171 255.255.255.0
  access-group input ALL
  service-policy input remote_mgmt_allow_policy
  no shutdown
interface vlan 1000
  ip address xx.xx.253.20 255.255.255.0
  access-group input ALL
  service-policy input remote_mgmt_allow_policy
  no shutdown

context Testing-11
  description Testing Context
  allocate-interface vlan 121-122
  allocate-interface vlan 1000

All the interfaces are up - except vlan 1000 which is not used.

Couple of (probably obvious) questions -

1. Do i need to create the 122 Server vlan in the admin context - i have assumed you must so you can allocate them to the other contexts.

2. On the physical interfaces - if you use a vlan in one you cant use it in another- do they automatically trunk ?

Currently i can ping from my client pc to the context vlan on the same vlan = xx.xx.121.10

I am using the manual from the course but it was done on a virtual appliance so i didnt really see much of the admin contexts

Maurice thanks for your help so far and if you can see anything wrong let me know.

Steve

Everyone's tags (4)
2 REPLIES

Routing and loadbalancing part 3

New Member

Routing and loadbalancing part 3

Sorry Marcel ;-)

Using some free webservers have managed to get the load balancing working to two of the servers.

However the third one is not loadbalanced and i cant seem to route to it

Any idea how i can do this -

ie -

Have 2 servers in a server farm loadbalancing

and another you just route to

Thanks for your help

Steve

660
Views
0
Helpful
2
Replies