Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

12.3 and MICA Modem disconnects, OxDF00

We have been running 12.07 XK1 with portware 2.3.1.0 for YEARS. MICA hardware version 1.0 for one card and 2.1 for the other. Dial in access has been rock solid over the two T1's. I attempted to load 12.3 1, IP only with the accompanying portware for V.90 support. All clients can connect, trainups look good, verifying username and password looks good, RADIUS session is successful. After 163 seconds or so, according to any modem log I choose, the connection is disconnected with the above reason. I have tried to scout around for a config sample that might show that I am missing a new required command in the line area of the config or something. Or is that nasty version 1.0 my problem? I have attached our running config for your perusal. Any help would be greatly appreciated!

CTCARE3661#sh modem ver

Slot 5:MICA-6DM Firmware, Source - IOS

CP ver 2310 - 6/3/1998, CheckSum B4585A04.

SP ver 2310 - 6/3/1998.

MICA 0: HW Version 1.0, Serial Number 12705853.

MICA 1: HW Version 1.0, Serial Number 12706052.

MICA 2: HW Version 1.0, Serial Number 12706020.

MICA 3: HW Version 1.0, Serial Number 12710159.

MICA 4: Not Installed.

Slot 6:MICA-6DM Firmware, Source - IOS

CP ver 2310 - 6/3/1998, CheckSum B4585A04.

SP ver 2310 - 6/3/1998.

MICA 0: HW Version 2.1, Serial Number 21149382.

MICA 1: HW Version 2.1, Serial Number 21149732.

MICA 2: HW Version 2.1, Serial Number 21043285.

MICA 3: HW Version 2.1, Serial Number 21148054.

MICA 4: Not Installed.

CTCARE3661#sh run

Building configuration...

Current configuration:

!interface Serial2/0:23

no ip address

no ip directed-broadcast

no ip proxy-arp

encapsulation ppp

dialer idle-timeout 1800

isdn switch-type primary-4ess

isdn incoming-voice modem

no fair-queue

!

interface Serial2/1:23

no ip address

no ip directed-broadcast

no ip proxy-arp

encapsulation ppp

dialer idle-timeout 1800

isdn switch-type primary-5ess

isdn incoming-voice modem

no fair-queue

interface Group-Async1

ip unnumbered Loopback0

ip helper-address 33.0.151.99

ip helper-address 33.0.75.214

ip helper-address 33.0.226.227

no ip directed-broadcast

no ip proxy-arp

encapsulation ppp

ip tcp header-compression passive

dialer in-band

dialer idle-timeout 1800

async default routing

async dynamic address

async dynamic routing

async mode dedicated

peer default ip address pool default

no cdp enable

ppp authentication pap ms-chap

group-range 161 184

!

interface Group-Async2

ip unnumbered Loopback0

ip helper-address 33.0.151.99

ip helper-address 33.0.75.214

ip helper-address 33.0.226.227

no ip directed-broadcast

no ip proxy-arp

encapsulation ppp

ip tcp header-compression passive

dialer in-band

dialer idle-timeout 1800

async default routing

async dynamic address

async dynamic routing

async mode dedicated

peer default ip address pool default

no cdp enable

ppp authentication pap ms-chap

group-range 193 210

!

interface Group-Async3

ip unnumbered FastEthernet0/0

no ip directed-broadcast

encapsulation ppp

no ip route-cache

no ip mroute-cache

async default routing

async mode interactive

peer default ip address pool local

no cdp enable

ppp authentication chap ms-chap pap

group-range 211 216

!

radius-server host 33.0.226.227 auth-port 1645 acct-port 1646

radius-server host 33.0.151.99 auth-port 1645 acct-port 1646

radius-server timeout 3

radius-server key DELETED

banner motd ^C

*******************************************************

WARNING: You are entering a private domain space!

Make sure you are authorized to enter before proceeding.

Unauthorized entry is subject to prosecution

to the fullest extent allowed by law.

*******************************************************^C

!

line con 0

exec-timeout 30 0

password xxxxx

login authentication consoleport

transport input none

line 161 184

no exec

autoselect ppp

modem InOut

rotary 1

transport preferred telnet

transport input all

stopbits 1

flowcontrol hardware

line 193 210

no exec

autoselect ppp

modem Dialin

transport input all

stopbits 1

flowcontrol hardware

line 211 216

no exec

password xxxxx

autoselect ppp

modem DTR-active

modem autoconfigure type mica

rotary 1

transport preferred telnet

transport input telnet

stopbits 1

flowcontrol hardware

line aux 0

line vty 0 4

access-class 12 in

exec-timeout 30 0

login authentication dialtest

transport preferred none

escape-character BREAK

!

ntp clock-period 17180304

ntp server 164.67.62.194 prefer

end

CTCARE3661#sh ver

Cisco Internetwork Operating System Software

IOS (tm) 3600 Software (C3660-I-M), Version 12.0(7)XK1, EARLY DEPLOYMENT RELEASE

SOFTWARE (fc1)

TAC:Home:SW:IOS:Specials for info

Copyright (c) 1986-2000 by cisco Systems, Inc.

Compiled Thu 16-Mar-00 18:11 by phanguye

Image text-base: 0x60008900, data-base: 0x608BC000

ROM: System Bootstrap, Version 12.0(6r)T, RELEASE SOFTWARE (fc1)

ROM: 3600 Software (C3660-I-M), Version 12.0(7)XK1, EARLY DEPLOYMENT RELEASE SOF

TWARE (fc1)

Processor board ID JAB040484XS

R527x CPU at 225Mhz, Implementation 40, Rev 10.0, 2048KB L2 Cache

MICA-6DM Firmware: CP ver 2310 - 6/3/1998, SP ver 2310 - 6/3/1998.

Bridging software.

X.25 software, Version 3.0.0.

Primary Rate ISDN software, Version 1.1.

5 REPLIES
Silver

Re: 12.3 and MICA Modem disconnects, OxDF00

The latest 12.3 IOS will have builtin MICA portware 2.9.4.x.

Instead of "modem autoconfigure type mica " under the lines, please add appropriate modemcap: &F&D2S0=0S29=6S21=3S34=18000S40=10S10=50 for non-v92 application.

http://www.cisco.com/warp/public/471/recc_modemcaps.html

Will need to see more outputs for disconenct reasons:

http://www.cisco.com/warp/public/76/mica-states-drs.html

Thanks, Mak.

New Member

Re: 12.3 and MICA Modem disconnects, OxDF00

Mak,

The line statement you want me to change is for some dialout clients that are no longer in use. I can remove this entire piece of the configuration along with the Async Group3, especially if it is impacting modem functionality with 2.9.4.x. What about the modem InOut and Dialin statements in the other line configs. Do I replace these statements with the modemcap entries if they are for dialin only?

Kurt.

Silver

Re: 12.3 and MICA Modem disconnects, OxDF00

We need to apply a modemcap to all the line (modem)...the modemcap that will used for 2.9.4.0 with a non-v92 application.

router#conf term

router(config)#modemcap edit pw2940 misc &F&D2S0=0S29=6S21=3S34=18000S40=10S10=50

router(config)#line 161 184

router(config-line)#modem autoconfigure type pw2940

Likewise add for lines 192 thru 216,,,,NOTE:pw2940 is just a name given.

Thanks, Mak.

New Member

Re: 12.3 and MICA Modem disconnects, OxDF00

Mak,

I have followed your instructions exactly. The remote access sessions are not behaving. I note that the login script does not always run when I keep trying to log on, and at times, the client reports that a domain controller was not available to authenticate. Has something changed in 12 3 1 that might still need tweaking on my config. I run async mode dedicated. Again, RADIUS looks clean, the logs for 12 07 xk1 are identical to logs with 12 3 1. Also, what do you think about hardware revision 1 on my MICA modem card?

Sincerely,

Kurt.

Silver

Re: 12.3 and MICA Modem disconnects, OxDF00

Did you try by locking to a lower modulation (say v34)...29=5 in the modemcap? We need to see if users at lower modulation remain connected but drop intermittently with v90 modulation.

Maybe we are looking at a noise line, not good enough for v90.

Do we see any speedshifts / retrains?

debug modem / deb modem csm will indicate the same.

Sh mod op x/y for an abnormally disconnected call will be useful.

Thanks, Mak.

150
Views
0
Helpful
5
Replies
CreatePlease to create content