Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

1601 router with IGX frame relay port not working

Hi,

I have a problem with a 1601 router. I have several other routers (1760, 1751, 1601) connected with frame relay to a multipoint administered with an IGX switch. The typical port configuration in the IGX is this:

========================================

Port: 7.45 [ACTIVE ]

Interface: E1B Configured Clock: 256 Kbps

Clocking: None Measured Rx Clock: None

Port ID - Min Flags / Frames 1

Port Queue Depth 65535 OAM Pkt Threshold 3 pkts

ECN Queue Threshold 65535 T391 Link Intg Timer 10 sec

DE Threshold 100 % N391 Full Status Poll 6 cyl

Signalling Protocol Cisco LMI -E EFCI Mapping Enabled Yes

Asynchronous Status Yes CLLM Enabled/Tx Timer Yes/100 msec

T392 Polling Verif Timer 15 IDE to DE Mapping Yes

N392 Error Threshold 3 Channel Speed 64

N393 Monitored Events Count 4 Line Number 4

Communicate Priority No Channel Range 13-16

Upper/Lower RNR Thresh 75%/ 25%

Last Command: dspport 7.45

====================================

and the interface configuration in the remote router is this:

=====================================

interface Serial0

no ip address

encapsulation frame-relay

frame-relay traffic-shaping

frame-relay qos-autosense

!

interface Serial0.1 point-to-point

ip address 10.3.254.38 255.255.255.252

frame-relay interface-dlci 140

class fr128k

!

map-class frame-relay fr128k

frame-relay traffic-rate 128000 128000

no frame-relay adaptive-shaping

frame-relay cir 128000

frame-relay mincir 128000

====================================

this same configuration in another 1601 works, but it doesn't work on this one. What happens is, the physical interface goes up (and stays up) and the line protocol, subinterface and PVC appear to go up (the port in the IGX never shows active), but in the router they go down after a minute.

I changed the router to a 1760 with the same configuration and it worked (the port became active and the ip network over the pvc was up). So there is a problem with this specific router.

I have another 1601 working and has different software, but I can't copy the software of the one that works to this one because this one has less memory (2MB ram/4mb flash). I updated the default image of this router to another version that supports traffic shaping and fits (c1600-y-l.113-11d.bin), but no success.

This is the configuration of this router:

========================================

Router#sh run

Building configuration...

Current configuration:

!

version 11.3

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname Router

!

!

!

!

interface Ethernet0

no ip address

shutdown

!

interface Serial0

no ip address

encapsulation frame-relay

frame-relay traffic-shaping

!

interface Serial0.140 point-to-point

ip address 10.3.254.34 255.255.255.252

frame-relay interface-dlci 140

class fr128k

!

ip classless

!

!

map-class frame-relay fr128k

frame-relay traffic-rate 128000 128000

no frame-relay adaptive-shaping

frame-relay cir 128000

frame-relay mincir 128000

!

line con 0

line vty 0 4

login

!

end

Router#

========================================

and this log explains what I observed, I shut down the interface before showing it. I also turned on the LMI debugging.

========================================

Router#conf t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#int s0

Router(config-if)#no shut

Router(config-if)#^Z

Router#

00:33:05: %SYS-5-CONFIG_I: Configured from console by console

00:33:07: %LINK-3-UPDOWN: Interface Serial0, changed state to up

00:33:07: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0.140, changed state to up

00:33:07: Serial0(out): StEnq, myseq 1, yourseen 0, DTE up

00:33:07: datagramstart = 0x219D050, datagramsize = 14

00:33:07: FR encap = 0x00010308

00:33:07: 00 75 95 01 01 00 03 02 01 00

00:33:07:

00:33:07: Serial0(out): StEnq, myseq 1, yourseen 0, DTE up

00:33:07: datagramstart = 0x219CCB4, datagramsize = 13

00:33:07: FR encap = 0x00010308

00:33:07: 00 75 51 01 00 53 02 01 00

00:33:07:

00:33:07: Serial0(out): StEnq, myseq 1, yourseen 0, DTE up

00:33:07: datagramstart = 0x219D050, datagramsize = 13

00:33:07: FR encap = 0xFCF10309

00:33:07: 00 75 01 01 00 03 02 01 00

00:33:07:

00:33:17: Serial0(out): StEnq, myseq 2, yourseen 0, DTE up

00:33:17: datagramstart = 0x219D050, datagramsize = 13

00:33:17: FR encap = 0xFCF10309

00:33:17: 00 75 01 01 00 03 02 02 00

00:33:17:

00:33:17: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to up

00:33:17: %FR-5-DLCICHANGE: Interface Serial0 - DLCI 140 state changed to ACTIVE

00:33:27: Serial0(out): StEnq, myseq 3, yourseen 0, DTE up

00:33:27: datagramstart = 0x219D050, datagramsize = 13

00:33:27: FR encap = 0xFCF10309

00:33:27: 00 75 01 01 00 03 02 03 00

00:33:27:

00:33:37: Serial0(out): StEnq, myseq 4, yourseen 0, DTE up

00:33:37: datagramstart = 0x219D050, datagramsize = 13

00:33:37: FR encap = 0xFCF10309

00:33:37: 00 75 01 01 00 03 02 04 00

00:33:37:

00:33:47: %FR-5-DLCICHANGE: Interface Serial0 - DLCI 140 state changed to INACTIVE

00:33:47: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0.140, changed state to down

00:33:47: %FR-5-DLCICHANGE: Interface Serial0 - DLCI 140 state changed to DELETED

00:33:47: Serial0(out): StEnq, myseq 1, yourseen 0, DTE down

00:33:47: datagramstart = 0x219D050, datagramsize = 14

00:33:47: FR encap = 0x00010308

00:33:47: 00 75 95 01 01 00 03 02 01 00

00:33:47:

00:33:47: Serial0(out): StEnq, myseq 1, yourseen 0, DTE down

00:33:47: datagramstart = 0x219CCB4, datagramsize = 13

00:33:47: FR encap = 0x00010308

00:33:47: 00 75 51 01 00 53 02 01 00

00:33:47:

00:33:47: Serial0(out): StEnq, myseq 1, yourseen 0, DTE down

00:33:47: datagramstart = 0x219D050, datagramsize = 13

00:33:47: FR encap = 0xFCF10309

00:33:47: 00 75 01 01 00 03 02 01 00

00:33:47:

00:33:47: Serial0(out): StEnq, myseq 2, yourseen 0, DTE down

00:33:47: datagramstart = 0x219CCB4, datagramsize = 13

00:33:47: FR encap = 0xFCF10309

00:33:47: 00 75 01 01 00 03 02 02 00

00:33:47:

00:33:47: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down

00:33:57: Serial0(out): StEnq, myseq 3, yourseen 0, DTE down

00:33:57: datagramstart = 0x219CCB4, datagramsize = 13

00:33:57: FR encap = 0xFCF10309

00:33:57: 00 75 01 01 00 03 02 03 00

00:33:57:

00:34:07: Serial0(out): StEnq, myseq 4, yourseen 0, DTE down

00:34:07: datagramstart = 0x219CCB4, datagramsize = 13

00:34:07: FR encap = 0xFCF10309

00:34:07: 00 75 01 01 00 03 02 04 00

00:34:07:

00:34:17: Serial0(out): StEnq, myseq 5, yourseen 0, DTE down

00:34:17: datagramstart = 0x219CCB4, datagramsize = 13

00:34:17: FR encap = 0xFCF10309

00:34:17: 00 75 01 01 00 03 02 05 00

00:34:17:

Router#

Router#sh frame lmi

LMI Statistics for interface Serial0 (Frame Relay DTE) LMI TYPE = CISCO

Invalid Unnumbered info 0 Invalid Prot Disc 0

Invalid dummy Call Ref 0 Invalid Msg Type 0

Invalid Status Message 0 Invalid Lock Shift 0

Invalid Information ID 0 Invalid Report IE Len 0

Invalid Report Request 0 Invalid Keep IE Len 0

Num Status Enq. Sent 7 Num Status msgs Rcvd 0

Num Update Status Rcvd 0 Num Status Timeouts 7

Router#

00:34:27: Serial0(out): StEnq, myseq 6, yourseen 0, DTE down

00:34:27: datagramstart = 0x219CCB4, datagramsize = 13

00:34:27: FR encap = 0xFCF10309

00:34:27: 00 75 01 01 00 03 02 06 00

00:34:27:

Router#

========================================

I tried forcing the default LMI to cisco, which is what I use in the IGX. I haven't tried other LMI modes but I'd like to know why this isn't working.

Please help, thanks.

Daniel

2 REPLIES
New Member

Re: 1601 router with IGX frame relay port not working

Hi Daniel,

your IGX output showing an E1 port, but your router is using X.21 or V.35. So there must be a physical converter/adapter modifying E1 to X.21 or V.35.

Your IGX output is also showing, that you don't receive a clocking from the other side (router). There are several issues to ensure correct clocking by your CSU.

Your router does not receive any signal from the IGX.

LMI messages are just send out (nothing received).

So I guess it's a physical problem.

You may try to reduce your clock to 64 kb/s (on all sides). Please make also a show controller serial 0 on the router, so we are able to see the physical interface on the router.

Regards,

Andreas

New Member

Re: 1601 router with IGX frame relay port not working

Thanks.

There is a converter, I receive the private line with a newbridge DTU, and to that I connect the router with a V.35 cable. The private line is connected to the multipoint in two channels of the E1 which the IGX uses to create the logical port.

I brought the router with me to do tests and now I think the problem is the physical interface. I connected it to another router back to back with hdlc, and even with that simple configuration that has worked with every router I've used, I have no communication. All the serial signals are up, but something is wrong with the interface. This is the show controller of the interface when the router was in the remote site:

--------------------------------

Router#sh control s 0

QUICC Serial unit 0

idb at 0x2090930, driver data structure at 0x2091FF0

SCC Registers:

General [GSMR]=0x2:0x00000030, Protocol-specific [PSMR]=0x0

Events [SCCE]=0x0000, Mask [SCCM]=0x001F, Status [SCCS]=0x0006

Transmit on Demand [TODR]=0x0, Data Sync [DSR]=0x7E7E

Interrupt Registers:

Config [CICR]=0x00368461, Pending [CIPR]=0x00004004

Mask [CIMR]=0x88000012, In-srv [CISR]=0x00000000

SDMA Registers:

[SDSR]=0x00, [SDAR]=0x02056396, [SDCR]=0x0740

Command register [CR]=0x6C0

Port A [PADIR]=0x0000, [PAPAR]=0xCCC3

[PAODR]=0x0000, [PADAT]=0x35BE

Port B [PBDIR]=0x00F13E, [PBPAR]=0x0010CE

[PBODR]=0x000000, [PBDAT]=0x0348DD

Port C [PCDIR]=0x000A, [PCPAR]=0x0000

[PCSO]=0x0830, [PCDAT]=0x03C4, [PCINT]=0x0000

DTE V.35 serial cable attached.

SCC GENERAL PARAMETER RAM (at 0xFF00F00)

Rx BD Base [RBASE]=0x560, Fn Code [RFCR]=0x18

Tx BD Base [TBASE]=0x5A0, Fn Code [TFCR]=0x18

Max Rx Buff Len [MRBLR]=1528

Rx State [RSTATE]=0x18008240, BD Ptr [RBPTR]=0x590

Tx State [TSTATE]=0x18000348, BD Ptr [TBPTR]=0x5A0

SCC HDLC PARAMETER RAM (at 0xFF00F38)

CRC Preset [C_PRES]=0xFFFF, Mask [C_MASK]=0xF0B8

Errors: CRC [CRCEC]=0, Aborts [ABTSC]=0, Discards [DISFC]=0

Nonmatch Addr Cntr [NMARC]=0

Retry Count [RETRC]=0

Max Frame Length [MFLR]=1526

Rx Int Threshold [RFTHR]=0, Frame Cnt [RFCNT]=65282

User-defined Address 0000/0000/0000/0000

User-defined Address Mask 0x0000

buffer size 1524

BRGC1=101B0, BRGC2=0, BRGC3=0, BRGC4=0

modem_signal_addr FF01566

MASK: DSR=1, DTR=2,RTS=8.CTS=400,DCD=800

txbrgc=FF015FC, rxbrgc=FF015FC

BRG [DTE]: rx_sicr_clk=7, tx_sicr_clk=6

BRG [DCE]: rx_sicr_clk=7, tx_sicr_clk=3

CLK SRC: sync=4000, async=4000

RX ring with 8 entries at 0xFF00560, Buffer size 1524

Rxhead = 0xFF00580 (4), Rxp = 0x209201C (4)

00 pak=0x2097548 buf=0x2198430 status=9000 pak_size=0

01 pak=0x2097364 buf=0x2197D70 status=9000 pak_size=0

02 pak=0x20E5424 buf=0x21B276C status=9000 pak_size=0

03 pak=0x209772C buf=0x2198AF0 status=9000 pak_size=0

04 pak=0x20E5BB4 buf=0x21B426C status=9000 pak_size=0

05 pak=0x20E57EC buf=0x21B34EC status=9000 pak_size=0

06 pak=0x20E59D0 buf=0x21B3BAC status=9000 pak_size=0

07 pak=0x20E5608 buf=0x21B2E2C status=B000 pak_size=0

TX ring with 2 entries at 0xFF005A0, tx_count = 0

tx_head = 0xFF005A8 (1), head_txp = 0x209206C (1)

tx_tail = 0xFF005A8 (1), tail_txp = 0x209206C (1)

00 pak=0x0000000 buf=0x0000000 status=0000 pak_size=0

01 pak=0x0000000 buf=0x0000000 status=2000 pak_size=0

QUICC SCC specific errors:

1 input aborts on receiving flag sequence

0 throttles, 0 enables

0 overruns

0 transmitter underruns

0 transmitter CTS losts

Router#

----------------------------------

Can you see anything wrong in this output?

Thanks,

Daniel

94
Views
0
Helpful
2
Replies
CreatePlease to create content