Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

1605R stops responding

We are running a 1605r with 2 ethernet ports as a NAT router for a few clients. This had been working fine for over a year, then recently something strange seems to be happening:

The router will run perfectly for anywhere from 6-12 hours, then it becomes un-reachable via telnet. I can't ping it, and no traffic goes through it. If I reload the router, everything comes back up fine and runs for another 6-12 hours. I thought this was a memory issue, so I put a 16mb simm in it, and upgraded IOS to 12.2(10b), but still the same issues. I have been putting in "reload in xx:xx" statments a couple times a day so I don't have to drive to the location and physically reset the router every few hours. Here is my current config:

Current configuration : 971 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname xxxxxxxxxxxxx

!

logging rate-limit all 10000

enable secret 5 $1$HrHc$evWP03Oe.QgSC7XP6M6Pg.

!

ip subnet-zero

no ip source-route

ip name-server xx.xxx.xx.x

ip name-server xx.xxx.xx.xx

!

!

!

!

interface Ethernet0

ip address xx.xxx.xx.x 255.255.255.0

no ip proxy-arp

ip nat outside

!

interface Ethernet1

ip address xx.x.x.x 255.0.0.0

ip helper-address xx.xxx.xx.x

ip helper-address xx.xxx.xx.x

ip helper-address xx.xxx.xx.xx

no ip proxy-arp

ip nat inside

ip rip send version 1 2

ip rip receive version 1 2

!

router rip

network xx.x.x.x

network xx.x.x.x

!

ip nat inside source list 10 interface Ethernet0 overload

ip nat inside source static xx.x.x.x xx.xxx.xx.x

ip classless

ip route 0.0.0.0 0.0.0.0 xx.xxx.xx.x

no ip http server

!

access-list 10 permit any

!

line con 0

transport preferred none

line vty 0 4

password xxxxxxxxxx

login

!

end

any help would be greatly appreciated. This isn't a bandwidth load issue, because there is only about a max of 400k/sec going through this at peak times.

gregg

1 REPLY
Bronze

Re: 1605R stops responding

The behaviour you describe sounds identical to a memory leak, ie a software error when a process fails to return memory to the free memory pool, so the router eventually runs out of memory. You can check this by issuing the 'show mem' command at interval and seeing if the free memory is dropping consistantly.

If it is, and you are on a current maintenance level, then you will need to contact the TAC and get them to open a new bug.

83
Views
0
Helpful
1
Replies
CreatePlease to create content