Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

1700 series config

I am not able to set up or configure my router. I keep getting the following messages:

bootldr is not set

boot:can not load system

can not open flash

device does not contain a valid magic number.

I have gont through alot of documentation trying to get this going, but I have had no luck.

The unit stays in ROMmon so that tells me that the ios image is corrupt or flash needs to be formated, but I am unable to accomplish this.

I have done the xmodem recovery, but I can not enter the commands to get through the entire sequence...Any help would be greatly appreciated, I'm pulling my hair out and now I'm bald!!!

3 REPLIES
VIP Purple

Re: 1700 series config

Hello,

when you do the XMODEM recovery where does it stop ? You might want to try and increase the baud rate, in ROMMON> type ´confreg´ and when the system asks you to change the configuration, say yes. The setting for 115kbps is 7, as far as I remember.

Regards,

Georg

New Member

Re: 1700 series config

"Devise does contain a valid magic number " message we got when we were trying to solve catalyst 5505 switch IOS.

We tried to boot through PCMCA slot 0 using different version of switch IOS then we got the same message. then we tried with "cat5505" same series . then switch was booted with slot 0.

I will give some tips. you can try it.

1. Go to rom mon mode

> confreg ox2102

> reset or i

It should boot with ios, otherwise you will have to do disaster recover with the 1700 series same model ios.

i hope it may help you

New Member

Re: 1700 series config

Try the following from RONMON:

rommon 1>MONRC=BOOT=flash:,2;

rommon 2>sync

rommon 3>reset

If successful negate the boot system flash: command from your startup config.

issue a dir flash:

If it shows only one IOS there would be no need for the boot system flash command

If more than one is shown use the following comand in config mode:

boot system flash:ios-name-from-dir-flash

If this fails try Plan B

1. Try getting a copy of the 1700 IOS

2. Download and tftp server in the internet you can find one free in the internet easily

Connect a PC with a tftp server to the F or E0 in the router then go to rommon and try the following:

rommon 1 > set

PS1=rommon ! >

IP_ADDRESS=1.1.1.2

IP_SUBNET_MASK=255.255.255.252

DEFAULT_GATEWAY=1.1.1.1 <--PC IP address

TFTP_SERVER=1.1.1.1

TFTP_FILE=downloaded_ios

Then type tftpdnld

Once is done, verify that the file is in flash

then

issue the following command:

boot downloaded image

If successful download the bootloader image and tftp download it to bootflash

make sure that your configuration if it has the boot system variable pointing to the right file

example:

boot system flash:another-ios

it should be:

boot system flash:downloaded-ios-image-name

Hope it helps

103
Views
0
Helpful
3
Replies