cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
244
Views
0
Helpful
3
Replies

1701 - ADSL / ISDN Failover with NAT

mosschops
Level 1
Level 1

Hi,

I have a Cisco 1701 router with both ADSL & ISDN WIC's. I can get the router to work on the DSL circuit and I can also get it work on ISDN dialup too.

Problem I am having is with NAT. Ultimatly what I want to acheive is to have the router pass traffic through the ADSL interface and have the ISDN dial up the ISP if the ADSL goes down.

I have the following NAT statement which works when the ADSL is up but I have to manually change it to my alternate dialer (dialer1) when DSL goes down:

ip nat inside source list 101 interface dialer0 overload

I have a static address on the ADSL interface, dynamic address on the ISDN.

3 Replies 3

gmarogi
Level 5
Level 5

You can probably use 'backup interface' to configure dialer0 to backup the ADSL. And then, use a route-map with the 'match interface' command to do the translation based on the interface out of which the packet is sent.

kmarrero
Level 4
Level 4

You can use route-maps with NAT if you are running Cisco IOS Software Release later than 12.1. Below is an example of what the configuration should be. This is just an example and will probably not have your exact network IP scheme in it. Here is a URL that may help as well.

http://www.cisco.com/warp/public/105/nat_routemap.html

http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/12cgcr/qos_c/qcpart1/qcpolicy.htm

ip nat inside source route-map ADSL interface FE1 overload

ip nat inside source route-map ISDN interface FE2 overload

interface Fast ethernet0

ip address 10.1.1.1 255.255.255.0

ip nat inside

interface Fast ethernet1

ip address 10.1.2.1 255.255.255.0

ip nat outside

interface Fast ethernet1

ip address 10.1.3.1 255.255.255.0

ip nat outside

access-list 118 permit ip 10.1.1.0 0.0.0.255 131.118.1.0 0.0.0.255

route-map ADSL permit 10

match ip address 118

set interface FE1

route-map ISDN permit 10

match ip address 118

set interface FE2

PBR only works when defining different parameters in the ACLs such as SA or DA, in this case the SA (Ethernet IP host) and DA (Remote Router) are the same. PBR cannot differentiate between the two route-maps and continues to xlate to the outside address of the interface in the lowest numbered NAT ID.