Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

1710 router doing bridging

Hi,

Has anybody been succesfull in configuring a router to do briding? I'm trying with a 1710 router with IOS 12.2(13)T and after a reboot the router bridging function does not work at all. Many times, the fastethernet interface is shudown or lacks its ip address although I've configured it and saved the configuration.

Here is my current and working (until I reboot) configuration. There is a class-map defined because I'm experimenting with bandwith control on bridged interfaces (as you can do with FreeBSD). On the fast ethernet interface I've only one PC connected with a cross over cable and ip 172.16.30.10

Any help will be appreciated,

Router#sh run

Building configuration...

Current configuration : 1491 bytes

!

version 12.2

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname "Router"

!

!

memory-size iomem 25

ip subnet-zero

no ip routing

!

!

no ip domain lookup

!

ip audit notify log

ip audit po max-events 100

!

class-map match-any from-customer

match access-group 100

class-map match-any to-customer

match access-group 101

!

!

policy-map customer-in

class from-customer

police cir 256000 bc 2000 be 1000

conform-action transmit

exceed-action drop

violate-action drop

policy-map customer-out

class to-customer

police cir 256000 bc 2000 be 1000

conform-action transmit

exceed-action drop

violate-action drop

!

!

!

!

bridge irb

bridge mac-address-table limit 300

!

!

interface Ethernet0

ip address 172.16.30.31 255.255.255.0

no ip route-cache

no ip mroute-cache

half-duplex

bridge-group 1

!

interface FastEthernet0

ip address 172.16.30.32 255.255.255.0

no ip route-cache

no ip mroute-cache

speed 10

half-duplex

bridge-group 1

!

interface Virtual-Template1

no ip address

bridge-group 1

!

interface BVI1

no ip address

no ip route-cache

no ip mroute-cache

!

ip classless

no ip http server

!

!

access-list 100 permit ip host 172.16.30.10 any

access-list 101 permit ip any host 172.16.30.10

!

bridge 1 forward-time 4

bridge 1 hello-time 10

bridge 1 priority 1

bridge 1 protocol ieee

!

line con 0

logging synchronous

line aux 0

line vty 0 4

login

!

no scheduler allocate

end

Router#

2 REPLIES

Re: 1710 router doing bridging

Are you trying to use IRB or TB ? If you want to route from bridged to a routed interface, only then you need the IRB configuration. I think in this case, since both e0 and e1 are part of bridge-group you dont need the BVI ( i dont see a routed interface)..Also on which interface do you plan to police the traffic?

New Member

Re: 1710 router doing bridging

I don't need routing. In fact, routing is disabled. I only need the router to do bridging. Regarding policing, I want the bridge to limit bandwith to 256kbps. This is for a small ISP to transparently limit bandwith coming from users with public ip addresses.

Help! Knowing that this wont work also helps me.

Thanks in advance,

100
Views
0
Helpful
2
Replies
CreatePlease login to create content