Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

1720 boot fails after xmodem restore

Hi there,

I'm novice to Cisco router, and I screwed up big time with my 1720 router. Flash ROM content was gone.

Fortunately, I was able to restore it using xmodem command.

The problem is...

After downloading the file, it still doesn't boot.

Message shows that there's not enough memory to load the image.

>>>>>>>>>>>>>>>>>>>>log file >>>>>>>>>>>>>>>>>>>>>>>>>>>>

System Bootstrap, Version 12.0(3)T, RELEASE SOFTWARE (fc1)

Copyright (c) 1999 by cisco Systems, Inc.

C1700 platform with 16384 Kbytes of main memory

program load complete, entry point: 0x80008000, size: 0x3d7010

Self decompressing the image :

################### [OK]

Memory configuration adjustment:

Image size=11551380, PMem req=14439225, I/O mem=4194304, PMem avail=12582912

Memory configuration adjustment:

Image size=11551380, PMem req=14439225, I/O mem=3354624, PMem avail=13422592

Memory configuration adjustment:

Image size=11551380, PMem req=14439225, I/O mem=2515968, PMem avail=14261248

INSUFFICIENT MEMORY TO LOAD IMAGE!

Please look at the Memory configuration adjustment messages.

The difference between PMem req and PMem avail is how much more memory you

need. A temporary workaround is to remove a WIC or a DSP module; this may

cause the I/O memory requirement to decrease, and may allow you to at least

use the router with reduced functionality until you get more memory.

*** System received a Software forced crash ***

signal= 0x17, code= 0x200, context= 0x80006214

PC = 0xffffffff, Vector = 0x200, SP = 0xffffffff

rommon 2 > dir flash:

File size Checksum File name

4026668 bytes (0x3d712c) 0xb00e ?

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

As you can see, the second problem is that file name is shown as "?".

How can I change it?

Please help.

Thanks in advance.

1 REPLY
New Member

Re: 1720 boot fails after xmodem restore

It looks like you have loaded an image which requires more DRAM than your router has installed. A simple solution would be to change to a bigger memory module (DRAM not Flash) or to install a smaller image, depends which one you have available.

The error message does indicate that you could try removing one of the modules to free up some memory, have you tried this ?

The ? file name may just be that you put in a blank destination filename when uploading the image ?

Regards

John

145
Views
0
Helpful
1
Replies
CreatePlease to create content