Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

1721 and sprint frame relay

I'm new to frame, and cisco routers in general actually, but thought I could configure a frame connection between 2 sites pretty easilly. Maybe I was wrong.

I was told that both ends of the connection were on DLCI = 30 and LMI = CISCO. I'm trying to bring up one side of this connection and was also told that I should see "LMI traffic" even if the other side isn't operating yet. I can't get that to happen, unfortunately.

Router is 1721 w/internal CSU/DSU card. The link is a 384k frac T1. Network is LAN (192.100.100.0) > Frame > LAN (192.100.100.0).

Any help would be greatly appreciated.

Here's my current config:

Current configuration : 1047 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname RouterWI

!

ip subnet-zero

no ip domain-lookup

!

interface FastEthernet0

description connected to Wisconsin_LAN

ip address 192.100.100.5 255.255.255.0

speed auto

half-duplex

!

interface Serial0

no ip address

encapsulation frame-relay

service-module t1 remote-alarm-enable

frame-relay lmi-type cisco

!

interface Serial0.1 point-to-point

description connected to RouterUT

ip address 192.168.0.1 255.255.255.252

snapshot client 5 60

frame-relay interface-dlci 30

!

router rip

version 2

redistribute connected

network 192.100.100.0

network 192.168.0.0

no auto-summary

!

ip classless

no ip http server

!

!

dialer-list 1 protocol ip permit

dialer-list 1 protocol ipx permit

!

line con 0

exec-timeout 0 0

password 7 **************

login

line aux 0

line vty 0 4

password 7 **************

login

!

no scheduler allocate

end

3 REPLIES
New Member

Re: 1721 and sprint frame relay

Hello.

You just about had it ! Since this circuit is a "fractional" T1 it requires you to define the channels you are using. A T1 has 24 channels at 56 or 64k, the telco should provide you with the channels required. eg 17-24. Also why do you have snap shot on that interface ?

Try this.

interface Serial0

no ip address

encapsulation frame-relay IETF ::if the router on the other side is not cisco use IETF on both sides.

no fair-queue

service-module t1 timeslots 1-2 :: put in your timeslots here.

!

interface Serial0.1 point-to-point

bandwidth 128

ip address x.x.x.x 255.255.255.252

no cdp enable

frame-relay interface-dlci 800 ::I can't see both ends being 30, I think they should both be different.

Have fun!

Randy McIver

CGEY

New Member

Re: 1721 and sprint frame relay

DLCIs are locally significant. This means they only have meaning between two network elements (router to router; router to switch; switch to switch). It is quite possible, and actually quite common, for DLCIs to be the same at each location. But they could also be different. For now I would go by what the service providor says. The CSU/DSU needs to be configured for the proper timeslots and the proper channel speed. Once that is done the interface should come up. When the interface is up, the line protocol can be checked. This is your LMI. When LMI request and responses are good, line protocol will come up. When line protocol is up (both ends) check the DLCIs. They should come up too. At this point all should work.

Silver

Re: 1721 and sprint frame relay

If you do a 'debug frame-relay lmi ' this will show your router sending out LMI and the responses from the local FR switch .

When you do a 'sh frame-relay pvc' your DLCI should be active , If it is deleted your local switch is not advertising your dlci , if it is inactive there is a problem on the other end could be a telco problem could be a frame-relay problem . .

494
Views
0
Helpful
3
Replies