Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

1721 ISDN Problems

We have two 1721 routers connected via dial on demand ISDN.

The routers will connect and route with no problems on one channel. Whenever the second channel tries to come up both channels are dropped.

Sometimes one channel will drop and re-establish the connection.

Debug q931 shows several different ISDN cause codes such as Temporary Fault, Circuit not available, No user response.

The ISDN lines have been checked and show no problems.

Another manufacturers routers work both channels with no problems.

Thank you for any assistance!

3 REPLIES
VIP Purple

Re: 1721 ISDN Problems

Hello,

can you post your config, your IOS version (it might be a software bug), and the output of the debug q931 command ?

Regards,

Georg

New Member

Re: 1721 ISDN Problems

IOS v12.2

Current configuration : 1308 bytes

!

version 12.2

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname Redcar

!

enable password 7 xxxxxxxxxxxxxx

!

username PT-Red password 7 xxxxxxxxxx

ip subnet-zero

no ip domain-lookup

!

isdn switch-type basic-net3

!

!

!

interface BRI0

description connected to PT-Red

encapsulation ppp

dialer idle-timeout 1200

dialer fast-idle 120

dialer map ip 192.168.116.202 name PT-Red broadcast 01639888888

dialer load-threshold 85 outbound

dialer-group 1

isdn switch-type basic-net3

no fair-queue

no cdp enable

ppp authentication chap

ppp multilink

!

interface Fastethernet0

description connectoed to EthernetLAN_1

ip address 192.168.144.1 255.255.255.224

ip helper-address 192.168.116.5

no keepalive

speed auto

!

router rip

version 1

network 192.168.144.0

no auto-summary

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.116.202

ip route 192.168.116.202 255.255.255.255 BRI0

no ip http server

!

!

access-list 101 permit icmp any any

access-list 101 permit ip any any

dialer-list 1 protocol ip list 101

snmp-server community public R0

!

line con 0

exec-timeout 0 0

password 7 xxxxxxxxx

login

line aux 0

line vty 0 4

password 7 xxxxxxxxxxxxxxxxxx

login

!

no scheduler allocate

end

This is the config of the remote router the host is identical apart from different tel numbers and usernames etc.

Thanks for the quick response!

Will dig out the q931 output later if you need it.

Many thanks

Ieuan

VIP Purple

Re: 1721 ISDN Problems

Hello,

if you post your IOS version I will check the software bug navigator. Also, try to post the output of:

debug dialer

debug isdn q931

debug ppp negotiation

Meanwhile, there might be some useful information in this document:

Troubleshooting Second B-channel Call Failures on ISDN BRI Links

http://www.cisco.com/en/US/partner/tech/tk801/tk379/technologies_tech_note09186a0080094b7a.shtml

Regards,

Georg

100
Views
0
Helpful
3
Replies
CreatePlease to create content