Cisco Support Community
Community Member

1750 with WIC-1ADSL


I have a 1750 router with 16mb of flash memory and 32mb of dram. I have put a WIC-1ADSL module in it, IOS C1700-y7-mz.122-4.T1.bin (IP/ADSL) and c1700-y7-mz.122-11.T2.bin, but the IOS don't recognize this module. Otherwise, when I type "show running", it shows me the 'interface ATM0', but I can't configure it.

can someone help me?

thanks in advance


Re: 1750 with WIC-1ADSL

Checking the release notes it appears to me that the T-train does not support the WIC-1ADSL. Why they call the image IP/ADSL? I do not know.

You should download the XQ release, image c1700-y7-mz.122-2.XQ1.bin.

In the Release notes for this image is explicitly stated that the WIC-1ADSL is supported.



Community Member

Re: 1750 with WIC-1ADSL

I have tried the image c1700-y7-mz.122-2.XQ1.bin and c1700-y7-mz.122-4.YA2.bin, but the router doesn't recognize the module.

thanks for the help,

do you have another idea?


Cisco Employee

Re: 1750 with WIC-1ADSL

Once it shows is sh run means that the card is recognized. Try to configure it and Post the config activity here and lets see what error you get. Also post the running config too.

Here is the place you will find many sample configs on that

Locate Cisco ADSL WIC section

Community Member

Re: 1750 with WIC-1ADSL

Here is the initial configuration and the 'show version':

Router#sh runn

Building configuration...

Current configuration : 592 bytes


version 12.2

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption


hostname Router


boot system flash c1700-y7-mz.122-2.XJ.bin


memory-size iomem 25

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

ip subnet-zero





interface ATM0

no ip address



interface FastEthernet0

ip address

speed auto


ip classless

no ip http server



line con 0

exec-timeout 0 0

logging synchronous

line aux 0

line vty 0 4

logging synchronous



no scheduler allocate



Router#sh ver

Cisco Internetwork Operating System Software

IOS (tm) C1700 Software (C1700-Y7-M), Version 12.2(2)XJ, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)

TAC Support:

Copyright (c) 1986-2001 by cisco Systems, Inc.

Compiled Wed 12-Sep-01 02:31 by ealyon

Image text-base: 0x80008108, data-base: 0x80867430

ROM: System Bootstrap, Version 12.0(3)T, RELEASE SOFTWARE (fc1)

ROM: C1700 Software (C1700-Y7-M), Version 12.2(4)YA2, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)

Router uptime is 0 minutes

System returned to ROM by reload

System image file is "flash:c1700-y7-mz.122-2.XJ.bin"

cisco 1750 (MPC860T) processor (revision 0x501) with 24576K/8192K bytes of memory.

Processor board ID JAD041106FI (391169062), with hardware revision 0000

MPC860T processor: part number 0, mask 32

Bridging software.

X.25 software, Version 3.0.0.

1 FastEthernet/IEEE 802.3 interface(s)

32K bytes of non-volatile configuration memory.

16384K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102



When I try to configure something, ex:

Router#conf t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#int atm0

Router(config-if)#pvc 0/35


% Invalid input detected at '^' marker.


Interface configuration commands:

access-expression Build a bridge boolean access expression

arp Set arp type (arpa, probe, snap) or timeout

backup Modify backup parameters

bandwidth Set bandwidth informational parameter

bridge-group Transparent bridging interface parameters

carrier-delay Specify delay for interface transitions

cdp CDP interface subcommands

custom-queue-list Assign a custom queue list to an interface

default Set a command to its defaults

delay Specify interface throughput delay

description Interface specific description

exit Exit from interface configuration mode

fair-queue Enable Fair Queuing on an Interface

help Description of the interactive help system

hold-queue Set hold queue depth

ip Interface Internet Protocol config commands

llc2 LLC2 Interface Subcommands

load-interval Specify interval for load calculation for an


logging Configure logging for interface

loopback Configure internal loopback on an interface

mac-address Manually set interface MAC address

map-group Configure static map group

max-reserved-bandwidth Maximum Reservable Bandwidth on an Interface

mtu Set the interface Maximum Transmission Unit (MTU)

multilink-group Put interface in a multilink bundle

multiring Enable RIF usage for a routable protocol

netbios Use a defined NETBIOS access list or enable


no Negate a command or set its defaults

priority-group Assign a priority group to an interface

random-detect Enable Weighted Random Early Detection (WRED) on an


service-policy Configure QoS Service Policy

shutdown Shutdown the selected interface

snapshot Configure snapshot support on the interface

snmp Modify SNMP interface parameters

standby Interface HSRP configuration commands

timeout Define timeout values for this interface

traffic-shape Enable Traffic Shaping on an Interface or


transmit-interface Assign a transmit interface to a receive-only


trunk-group Configure interface to be in a trunk group



If I try type "no shut" in the atm interface, the router reloads,

Router(config)#int atm0

Router(config-if)#no shut

=== Flushing messages (00:05:05 UTC Mon Mar 1 1993) ===

Queued messages:

*** System received a SegV exception ***

signal= 0xb, code= 0x1200, context= 0x80c45c18

PC = 0x807597e4, Vector = 0x1200, SP = 0x80ea5278

System Bootstrap, Version 12.0(3)T, RELEASE SOFTWARE (fc1)

Copyright (c) 1999 by cisco Systems, Inc.

C1700 platform with 32768 Kbytes of main memory


Cisco Employee

Re: 1750 with WIC-1ADSL

The card is recognized but it has some issue with it so its crashing the router when you try to configure it. I would say re-seat the card in the chassis again and if it still dosen't work, try to replace it

Community Member

Re: 1750 with WIC-1ADSL

I have two modules WIC-1ADSL and I have tried with both. I have put the two modules in the slot 0 and the slot 1, but it doesn't work.

Cisco Employee

Re: 1750 with WIC-1ADSL

Things are getting messy now..Pl. open a tac case after login at for this issue.

CreatePlease to create content