Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
jk-
New Member

1751 PPP Routing Help

Hello!

I am new to working with Cisco Routers, and we have purchased a new 1751 with 1 CSU/DSU t1 WAN card.

The connection is a PPP T1 line, going from the school to the main district office where all the PPP connections meet from all the schools...

I am trying to configure this router, but have seem to have stumbled onto a roadblock...I know its probably something dumb (like a missing configuration, etc), but please bear with me as I am learning as I go along....

Ethernet IP is: 192.168.4.250

Serial IP is: 192.168.14.249

The serial gateway (located at the telco) is : 192.168.14.250

The issue:

We can ping the ethernet side of the router, but cannot route past it. Traceroutes to other subnets fail at the ethernet side of the router and cannot go any further.

Funny thing is...when we work from the 1751 console...we can traceroute, and ping other subnets without any problems..

Here is a copy of the config, please keep in mind Im trying to keep the config file as basic as possible until I get the router up and running, then Ill add more configurations to the existing config:

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname ##############

!

no logging console

enable secret 5 ############################

enable password ##############################

!

memory-size iomem 25

ip subnet-zero

!

!

!

!

interface FastEthernet0/0

ip address 192.168.4.250 255.255.255.0

speed auto

half-duplex

!

interface Serial0/0

description ###########################

ip address 192.168.14.249 255.255.255.0

encapsulation ppp

!

router ospf 1

log-adjacency-changes

!

router rip

version 2

passive-interface Serial0/0

network 192.168.4.0

no auto-summary

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.14.250

no ip http server

!

snmp-server community ####################

!

line con 0

line aux 0

line vty 0 4

password ################################

login

!

end

Thanks guys for any info..Since Im new to this..Im pretty much stumped as to what I need to do next...Perhaps Im missing an extra static route, etc?

JK

4 REPLIES
Bronze

Re: 1751 PPP Routing Help

Do you mean you cannot get beyond the etheret from the router itself or from the router(s) on the far side of the ppp line?

If it is from this router, you need to have learned a router to anything which is not directly connected, unless you get to it via the default static route. In other words, any other routers in your environment must be configured to send RIP V2 routes to you since that is the only routing protocol configured. (OSPF is only partially configured.)

A sh ip route will show if you have learned these routes.

You have made the PPP line a passive interface in RIP so it will not be sending updates on it. This means that the router at the other end must have static routes pointing to any other subnets at this end in order to reach them.

I hope this is of some help.

Cisco Employee

Re: 1751 PPP Routing Help

Do the hosts on the ethernet subnet have their default gateway set to the ethernet address of the router?

Seems like they don't know how to get back to the 192.168.14.0 subnet.

For testing, you can try to do an extended ping from the router, sourcing from the serial interface, I am pretty sure that will fail too.

hope this helps

-Nairi

jk-
New Member

Re: 1751 PPP Routing Help

Thanks for the reply Nairi and rsissons,

We do have the correct gateway (192.168.4.250) on the workstations/servers we are trying to run traceroutes/pings from.

The traceroute from the workstations/servers hits the ethernet side of the router and then times out after that....seems like they arent even hitting the serial side of the router..

Like I said in my orig post tho...we can console to the router and do traceroutes and pings to other subnets without any issues (Traceroutes specifying the IP as the serial side)..that is the weird thing that is confusing me a bit :-)

I was thinking of adding a couple of static routes and seeing if it helps the issue..I was just curious if there was a config setting I was missing, because after looking at other config files on the net..I thought it was pretty right on..

I will try running an extended ping and see what happens...I should be back at the schools tommorow to test the router..

Thanks again :-)

JK

New Member

Re: 1751 PPP Routing Help

Hi JK.

copy and paste the sho ip route.

i think that your static default route is wrong.

currently it is;

ip route 0.0.0.0 0.0.0.0 192.168.14.250

this points to the ethernet 0/0

a router cannot send a packet back into the same interface that it came from.

this will violate the poison-reverse rule, unless the ethernet is divided into subinterfaces which you dont have.

change it to 0.0.0.0 0.0.0.0 192.168.14.249

copy the config and see what happens.

also see what is the default-gateway on the workstations.

they should be 192.168.14.250, which is ethernet 0/0

---joseph

88
Views
0
Helpful
4
Replies
CreatePlease to create content