Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

1760 doesn't dial with one dialer pool-member unconnected

Hi everybody,

i have an 1760 with two WIC-1B-S/T and 12.2(7.1)T. I have configured both BRI's as "dialer pool-member 1". When connecting the ISDN NT to bri1/0 the Dialer brings up the interface and everything's fine. When connecting the ISDN NT to bri0/0 the Dialer still trys to bring up bri1/0 and no call is beeing set up. It's only a test, but in the event of an failure of bri1/0 i would get no connection over the functioning bri0/0.

Thank's for any help

4 REPLIES
Bronze

Re: 1760 doesn't dial with one dialer pool-member unconnected

First of, the Dialer should only consider those ISDN interfaces whose layer1 us UP. If you only have one interface that is UP, that interface should be dialing. If there are multiple interfaces which are UP, and neither has a configured priority higher than the other (an option with the "dialer pool" command), then the first physical interface (0/0 in your case) will always be attempted first. If there is a priority configured, the one with the highest priority will always be used first. Note that, as an aside, there is no need to use dialer profiles unless you will be connecting to different remote sites and need different configuration characterstics for each remote site. Otherwise, regular DDR should be fine (configure a dialer rotary group and place each BRI in the rotary group) and is likely easier to configure.

To troubleshoot your problem when connected to 0/0, you should ensure that 0/0 is UP (sh isdn status), and then have a look at "debug isdn q931" and "debug dialer" to see what's going on during the call attempt.

New Member

Re: 1760 doesn't dial with one dialer pool-member unconnected

Thanks for your response. Here's some more information. Now I tried using rotary-group and got the same result. Please see the "sh isdn status" output as well as the configuration and debugging:

nst40-r-malu40#sh isdn stat

Global ISDN Switchtype = basic-net3

ISDN BRI0/0 interface

dsl 0, interface ISDN Switchtype = basic-net3

Layer 1 Status:

ACTIVE

Layer 2 Status:

TEI = 69, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED

Layer 3 Status:

0 Active Layer 3 Call(s)

Active dsl 0 CCBs = 0

The Free Channel Mask: 0x80000003

Number of L2 Discards = 0, L2 Session ID = 6

ISDN BRI1/0 interface

dsl 1, interface ISDN Switchtype = basic-net3

Layer 1 Status:

DEACTIVATED

Layer 2 Status:

Layer 2 NOT Activated

Layer 3 Status:

0 Active Layer 3 Call(s)

Active dsl 1 CCBs = 0

The Free Channel Mask: 0x80000003

Number of L2 Discards = 0, L2 Session ID = 90

Total Allocated ISDN CCBs = 0

nst40-r-malu40#

nst40-r-malu40#

nst40-r-malu40#

nst40-r-malu40#

nst40-r-malu40#

nst40-r-malu40#

nst40-r-malu40#ping 10.10.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.10.1.1, timeout is 2 seconds:

*Mar 1 21:09:23 UTC: BR1/0 DDR: rotor dialout [priority]

*Mar 1 21:09:23 UTC: BR1/0 DDR: Dialing cause ip (s=192.168.1.4, d=10.10.1.1)

*Mar 1 21:09:23 UTC: BR1/0 DDR: Attempting to dial 1866

*Mar 1 21:09:23 UTC: ISDN BR1/0 EVENT: UserIdle: callid 0x8032 received ISDN_CA

LL (0x0)

*Mar 1 21:09:23 UTC: ISDN **ERROR**: Module-lif Function-LIF_AddTimer Error-

Unknown Class.

*Mar 1 21:09:23 UTC: ISDN **ERROR**: Module-lif Function-LIF_AddTimer Error-

Unknown Class.

*Mar 1 21:09:23 UTC: ISDN **ERROR**: Module-lif Function-LIF_AddTimer Error-

Unknown Class.

*Mar 1 21:09:23 UTC: ISDN BR1/0 EVENT: handle_l2d_srq_mail: Activating Layer 1

*Mar 1 21:09:23 UTC: ISDN BR1/0 EVENT: isdn_sw_cstate: State = 4, Old State = 4

.

*Mar 1 21:09:24 UTC: ISDN BR1/0 EVENT: handle_l2d_srq_mail: Layer 1 not Active

after T3 delay

*Mar 1 21:09:24 UTC: BRI1/0: wait for isdn carrier timeout, call id=0x8032

*Mar 1 21:09:24 UTC: ISDN **ERROR**: LIF_RemoveTimer Timer class 1 UNKNOWN

*Mar 1 21:09:24 UTC: ISDN **ERROR**: LIF_RemoveTimer Timer class 1 UNKNOWN

*Mar 1 21:09:24 UTC: ISDN **ERROR**: LIF_RemoveTimer Timer class 1 UNKNOWN

*Mar 1 21:09:25 UTC: ISDN BR1/0 EVENT: process_rxstate: ces/callid 1/0x8032 cal

ltype 1 HOST_DISCONNECT_ACK

*Mar 1 21:09:25 UTC: ISDN BR1/0 **ERROR**: host_disconnect_ack: Unfound B-chann

el on Disconnect_Ack call id 0x8032

*Mar 1 21:09:25 UTC: BR1/0 DDR: rotor dialout [priority]

*Mar 1 21:09:25 UTC: BR1/0 DDR: Dialing cause ip (s=192.168.1.4, d=10.10.1.1)

*Mar 1 21:09:25 UTC: BR1/0 DDR: Attempting to dial 1866

*Mar 1 21:09:25 UTC: ISDN BR1/0 EVENT: UserIdle: callid 0x8033 received ISDN_CA

LL (0x0)

*Mar 1 21:09:25 UTC: ISDN **ERROR**: Module-lif Function-LIF_AddTimer Error-

Unknown Class.

*Mar 1 21:09:25 UTC: ISDN **ERROR**: Module-lif Function-LIF_AddTimer Error-

Unknown Class.

*Mar 1 21:09:25 UTC: ISDN **ERROR**: Module-lif Function-LIF_AddTimer Error-

Unknown Class.

*Mar 1 21:09:25 UTC: ISDN BR1/0 EVENT: handle_l2d_srq_mail: Activating Layer 1.

*Mar 1 21:09:27 UTC: ISDN BR1/0 EVENT: handle_l2d_srq_mail: Layer 1 not Active

after T3 delay

*Mar 1 21:09:27 UTC: BRI1/0: wait for isdn carrier timeout, call id=0x8033

*Mar 1 21:09:27 UTC: ISDN **ERROR**: LIF_RemoveTimer Timer class 1 UNKNOWN

*Mar 1 21:09:27 UTC: ISDN **ERROR**: LIF_RemoveTimer Timer class 1 UNKNOWN

*Mar 1 21:09:27 UTC: ISDN **ERROR**: LIF_RemoveTimer Timer class 1 UNKNOWN

*Mar 1 21:09:27 UTC: ISDN BR1/0 EVENT: process_rxstate: ces/callid 1/0x8033 cal

ltype 1 HOST_DISCONNECT_ACK

*Mar 1 21:09:27 UTC: ISDN BR1/0 **ERROR**: host_disconnect_ack: Unfound B-chann

el on Disconnect_Ack call id 0x8033

*Mar 1 21:09:27 UTC: ISDN BR1/0 EVENT: handle_l2d_srq_mail: Activating Layer 1.

*Mar 1 21:09:29 UTC: BR1/0 DDR: rotor dialout [priority]

*Mar 1 21:09:29 UTC: BR1/0 DDR: Dialing cause ip (s=192.168.1.4, d=10.10.1.1)

*Mar 1 21:09:29 UTC: BR1/0 DDR: Attempting to dial 1866

*Mar 1 21:09:29 UTC: ISDN BR1/0 EVENT: UserIdle: callid 0x8034 received ISDN_CA

LL (0x0)

*Mar 1 21:09:29 UTC: ISDN **ERROR**: Module-lif Function-LIF_AddTimer Error-

Unknown Class.

*Mar 1 21:09:29 UTC: ISDN **ERROR**: Module-lif Function-LIF_AddTimer Error-

Unknown Class.

*Mar 1 21:09:29 UTC: ISDN **ERROR**: Module-lif Function-LIF_AddTimer Error-

Unknown Class.

*Mar 1 21:09:29 UTC: ISDN BR1/0 EVENT: handle_l2d_srq_mail: Layer 1 not Active

after T3 delay

*Mar 1 21:09:29 UTC: BRI1/0: wait for isdn carrier timeout, call id=0x8034

*Mar 1 21:09:29 UTC: ISDN **ERROR**: LIF_RemoveTimer Timer class 1 UNKNOWN

*Mar 1 21:09:29 UTC: ISDN **ERROR**: LIF_RemoveTimer Timer class 1 UNKNOWN

*Mar 1 21:09:29 UTC: ISDN **ERROR**: LIF_RemoveTimer Timer class 1 UNKNOWN

*Mar 1 21:09:29 UTC: ISDN BR1/0 EVENT: process_rxstate: ces/callid 1/0x8034 cal

ltype 1 HOST_DISCONNECT_ACK

*Mar 1 21:09:29 UTC: ISDN BR1/0 **ERROR**: host_disconnect_ack: Unfound B-chann

el on Disconnect_Ack call id 0x8034.

*Mar 1 21:09:31 UTC: BR1/0 DDR: rotor dialout [priority]

*Mar 1 21:09:31 UTC: BR1/0 DDR: Dialing cause ip (s=192.168.1.4, d=10.10.1.1)

*Mar 1 21:09:31 UTC: BR1/0 DDR: Attempting to dial 1866

*Mar 1 21:09:31 UTC: ISDN BR1/0 EVENT: UserIdle: callid 0x8035 received ISDN_CA

LL (0x0)

*Mar 1 21:09:31 UTC: ISDN **ERROR**: Module-lif Function-LIF_AddTimer Error-

Unknown Class.

*Mar 1 21:09:31 UTC: ISDN **ERROR**: Module-lif Function-LIF_AddTimer Error-

Unknown Class.

*Mar 1 21:09:31 UTC: ISDN **ERROR**: Module-lif Function-LIF_AddTimer Error-

Unknown Class.

*Mar 1 21:09:31 UTC: ISDN BR1/0 EVENT: handle_l2d_srq_mail: Activating Layer 1

*Mar 1 21:09:31 UTC: ISDN BR1/0 EVENT: service_queue_from_physical_layer: Recvd

L1 prim 3 state is 0

*Mar 1 21:09:31 UTC: BRI1/0: wait for isdn carrier timeout, call id=0x8035

*Mar 1 21:09:31 UTC: ISDN BR1/0 EVENT: isdn_sw_cstate: State = 0, Old State = 4

*Mar 1 21:09:31 UTC: ISDN BR1/0 EVENT: handle_l2d_srq_mail: Layer 1 not Active

after T3 delay

*Mar 1 21:09:31 UTC: ISDN **ERROR**: LIF_RemoveTimer Timer class 1 UNKNOWN

*Mar 1 21:09:31 UTC: ISDN **ERROR**: LIF_RemoveTimer Timer class 1 UNKNOWN

*Mar 1 21:09:31 UTC: ISDN **ERROR**: LIF_RemoveTimer Timer class 1 UNKNOWN

*Mar 1 21:09:31 UTC: ISDN BR1/0 EVENT: process_rxstate: ces/callid 1/0x8035 cal

ltype 1 HOST_DISCONNECT_ACK

*Mar 1 21:09:31 UTC: ISDN BR1/0 **ERROR**: host_disconnect_ack: Unfound B-chann

el on Disconnect_Ack call id 0x8035.

Success rate is 0 percent (0/5)

nst40-r-malu40#

nst40-r-malu40#

nst40-r-malu40#sh run

...

isdn switch-type basic-net3

!

!

!

interface FastEthernet0/0

ip address 172.17.184.10 255.255.248.0

speed auto

no cdp enable

!

interface BRI0/0

no ip address

encapsulation ppp

dialer rotary-group 1

dialer priority 10

dialer-group 5

isdn switch-type basic-net3

no cdp enable

ppp authentication chap

ppp multilink

!

interface BRI1/0

no ip address

encapsulation ppp

dialer rotary-group 1

dialer priority 10

dialer-group 5

isdn switch-type basic-net3

no cdp enable

ppp authentication chap

ppp multilink

!

interface Dialer1

description "ppp Einwahl Interface nach Mannheim"

ip address 192.168.1.4 255.255.255.0

encapsulation ppp

dialer in-band

dialer map ip 192.168.1.1 1866

dialer map ip 192.168.1.2 1866

dialer-group 5

no cdp enable

ppp authentication chap pap

ppp multilink

multilink max-links 4

!

ip classless

ip route 10.3.0.0 255.255.0.0 Dialer1

ip route 10.3.0.0 255.255.0.0 192.168.1.2

ip route 10.10.0.0 255.255.0.0 192.168.1.1

no ip http server

!

!

dialer-list 5 protocol ip permit

no cdp run

!

line con 0

exec-timeout 0 0

login local

line aux 0

line vty 0 4

login local

!

end

Bronze

Re: 1760 doesn't dial with one dialer pool-member unconnected

Can you try removing the "dialer priority" commands from the BRI's? If the problem persists, then please try saving the config and reloading the router. If the problem *still* persists, then try "dialer rotor best" under the dialer interface. Thanks.

New Member

Re: 1760 doesn't dial with one dialer pool-member unconnected

I tried without "dialer priority" before. Reboot didn't help.

"dialer rotor best" solved the problem!!

Thank you

184
Views
4
Helpful
4
Replies
CreatePlease to create content