Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

1841 Router Layer 2 routing

I have 4 layer 2 ports on my router. I would like to connect them to my different vlan segments on my switch or directly to server boxes. I can't seem to be able to route the traffic from those boxes out. The router sees the interfaces as up, but I can't seem to do anything with routing the data.

Here is my config:

boot-start-marker

boot-end-marker

!

!

username xxxxxx password 0 xxxxxx

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

no aaa new-model

ip subnet-zero

ip cef

!

!

!

ip dhcp pool group1

network 10.1.10.0 255.255.255.0

dns-server 208.x.x.x.x.37.246 4.2.2.2

default-router 10.1.10.1 255.0.0.0

!

!

ip name-server 64.56.37.246

vpdn enable

vpdn logging

vpdn logging user

!

vpdn-template

!

vpdn-group 1

! Default PPTP VPDN group

accept-dialin

protocol pptp

virtual-template 1

!

no ftp-server write-enable

!

!

!

!

interface FastEthernet0/0

ip address 10.1.10.1 255.255.0.0

ip nat inside

duplex auto

speed auto

no keepalive

!

interface FastEthernet0/1

ip address xxxxx secondary

ip address xxxxx

ip nat outside

duplex auto

speed auto

no keepalive

!

interface FastEthernet0/0/0

no ip address

ip access-group 102 in

ip access-group 102 out

!

interface FastEthernet0/0/1

no ip address

shutdown

!

interface FastEthernet0/0/2

no ip address

shutdown

no keepalive

!

interface FastEthernet0/0/3

no ip address

shutdown

!

interface Vlan1

no ip address

!

router eigrp 2

network 10.3.0.0 0.0.255.255

!

ip local pool group2 10.1.11.1 10.1.11.254

ip default-gateway xxxxx

ip classless

ip route 0.0.0.0 0.0.0.0 xxxxx

!

no ip http server

ip nat inside source list 102 interface FastEthernet0/1 overload

ip nat inside source static udp xxxxx 8767 10.3.10.250 8767 extendable

!

access-list 102 permit ip 10.1.0.0 0.0.255.255 any

access-list 102 permit tcp 10.1.0.0 0.0.255.255 any

access-list 102 permit tcp any eq domain any

access-list 102 permit udp 10.1.0.0 0.0.255.255 any

access-list 102 permit ip 10.3.0.0 0.0.255.255 any

access-list 102 permit udp 10.3.0.0 0.0.255.255 any

!

control-plane

!

!

line con 0

password xxxxx

logging synchronous

login

line aux 0

line vty 0 4

password xxxxx

logging synchronous

login

!

end

I want to route the 10.3.0.0 network out fa0/1 secondary ip.

Thanks for the help,

1 ACCEPTED SOLUTION

Accepted Solutions
Purple

Re: 1841 Router Layer 2 routing

I'm not sure I fully understand your situation yet...but could you try the following:

interface vlan1

ip nat inside

ip address 10.3.10.1 255.255.0.0

Make sure you leave the servers configured as:

IP: 10.3.10.250

Mask: 255.255.0.0

Gate: 10.3.10.

Hope that helps - pls rate the post if it does.

Paresh.

5 REPLIES
Purple

Re: 1841 Router Layer 2 routing

Hi,

I am assuming that nertwork 10.3.0.0 is reachable by a router attached to the switch connected to your fa0/1 interface. In that case, enter in the following:

ip route 10.3.0.0 255.255.0.0 fast0/1

Ensure that the next-hop IP address you specify above is on the same subnet that your secondary IP address on fas0/1 is..

Hope that helps - pls rate the post if it does.

Regards,

Paresh.

New Member

Re: 1841 Router Layer 2 routing

Thanks for the reply.

The 10.3.0.0 network in which the servers are staticly set on. Since they are connected to layer 2 ports I can't set an ip on the port.

Fa0/1 is my connection to the internet. The ip and secondary ip are 2 public ips I have. No matter how I route the 10.3 network I still can't get out.

The server ip information is:

IP: 10.3.10.250

Mask: 255.255.0.0

Gate: 10.3.10.1 <-- I have also tried setting this for the ip on fa0/1.

Purple

Re: 1841 Router Layer 2 routing

I'm not sure I fully understand your situation yet...but could you try the following:

interface vlan1

ip nat inside

ip address 10.3.10.1 255.255.0.0

Make sure you leave the servers configured as:

IP: 10.3.10.250

Mask: 255.255.0.0

Gate: 10.3.10.

Hope that helps - pls rate the post if it does.

Paresh.

Purple

Re: 1841 Router Layer 2 routing

Whoops .. I left out the last octet for the server's gateway IP.. it should be:

IP: 10.3.10.250

Mask: 255.255.0.0

Gate: 10.3.10.1

Regards,

Paresh.

New Member

Re: 1841 Router Layer 2 routing

Works like a charm, thank you very much.

181
Views
3
Helpful
5
Replies
CreatePlease to create content