Cisco Support Community
Community Member

1900 Firmware upgrade problems

When I attempt to load the Enterprise v.9 IOS on the 1924 model WS-C1900 switch I receive an error that states the transfer was canceled by remote host. I connect to the switch via a 9 pin null modem cable to the console port while I hold in the mode button. I select U to upgrade the f/w via Xmodem. Yes, to proceed with download. I pick 9600 as the upgrade speed(as Hyper Terminal is configed 9600, 8, none,1). Then it states the flash erase completed. It shows dollars signs that it is ready for the image. I send it via Hyper Terminal at 9600 and I pick the bin file and Xmodem. After one frame is sent I receive Transfer canceled by remote host.

I have done this on other 1924s, however their model number was WS-C1924C-A and they had a RJ45 console port instead of a 9 pin console port as the switch I'm having problems with has. Am I using the wrong cable(I have also tried the rollover cable with an adapter that worked on the other 1924s with a rj45 port and a null modem cable)? Is this model not upgradable...any ideas??

Community Member

Re: 1900 Firmware upgrade problems

I have run into this problem before. If you are able to connect to the switch and are able to make selections (such as Upgrade Firmware) than your connection parameters are correct. What I found to be the problem, or the reason for that message was because I was trying to load the wrong image. For example if you try to load an enterprise image on a standard 1900 switch, it will reply with "transfer was cancelled by remote host". Ensure you have exactly the right image for your model number. When you go to CCO to download a 1900 image it specifically tells you the image is meant for a certain model number.


Community Member

Re: 1900 Firmware upgrade problems


Thanks you for your reply. However, I have gone to CCO and they have two standard firmware images available v 9.0 and 9.04(and it really doesn't specify andy particular version of 1900 should be used). I should have mentioned I have tried both of those in addition to the enterprise software. I am thinking it uses a weird command as this may be an older switch or it needs some sort of chip upgrade...I hope someone can help.


CreatePlease to create content