Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

(2)6513's to a 2621

Is it possible to have the 2 ethernet ports on a 2621 connect to 2 separate 6513's that are linked via fiber? The obvious reason is redundancy. Neither switch has layer 3 capabilities and it is a flat network. How would you address the ports so the users could all use the same gateway?

6 REPLIES
Bronze

Re: (2)6513's to a 2621

Yes, this is possible. You would configure the 2621 for HSRP using 2 standby groups for load sharing and redundancy. See the following URL for an example -

http://www.cisco.com/univercd/cc/td/doc/cisintwk/ics/cs009.htm

New Member

Re: (2)6513's to a 2621

I think rsissons is wrong. With what you have, you cannot do it. You need at least two routers to do HSRP correctly for what you are doing "One gateway for every PC".

Because with one router, you have to create two broadcast domain, but with two routers, you can have them in one broadcast domain.

New Member

Re: (2)6513's to a 2621

This is possible in (at least) two ways:

1. Join the two interfaces in a bridge group, run IRB and configure the BVI for the bridge group with the default gateway address. I.e.:

bridge irb

!

interface fa0/0

no ip address

bridge-group 1

!

interface fa0/1

no ip address

bridge-group 1

!

interface BVI 1

ip address x.x.x.x y.y.y.y

!

bridge-group 1 protocol ieee

This will work, but may not be very efficient.

2. Assign fictitious addresses to the interfaces, then assign secondary addresses to them consistent with your IP subnet. Configure an HSRP group on the secondary addresses. This avoids the restriction on configuring multiple interfaces in the same network on the same router. For example, if your "real" IP network is 172.16.0.0/16...

interface fa0/0

ip address 192.168.0.1 255.255.255.252

ip address 172.16.0.2 255.255.0.0 secondary

standby 1 ip 172.16.0.1

standby 1 priority 100

!

interface fa0/1

ip address 192.168.0.2 255.255.255.252

ip address 172.16.0.3 255.255.0.0 secondary

standby 1 ip 172.16.0.1

standby 1 priority 90

This will allow both interfaces to send traffic to hosts on the ethernet LAN (using per-destination or per-packet load-sharing depending on configuration), although only one interface - the active hsrp interface - will receive traffic from the network.

Hope this helps.

New Member

Re: (2)6513's to a 2621

well, I don't know what version of IOS you are using, the 2nd method doesn't work for me.

Router(config)#int f0/1

Router(config-if)#ip add 172.16.0.3 255.255.0.0 secondary

172.16.0.0 is assigned as a secondary address on FastEthernet0/0.

New Member

Re: (2)6513's to a 2621

Good question! This is something I KNOW we achieved at a previous employer's core site, on 4500M routers, but unfortunately I don't remember the IOS version we used. I have just tried it on several routers in our lab here running various versions of IOS and all of them rejected it!

Sorry for the misleading advice - I guess your option is IRB or nothing.

New Member

Re: (2)6513's to a 2621

Thank you all for your suggestions. I have tried them all and it seems that the bridging solution is the only one that worked. I have heard horror stories using this though.

104
Views
0
Helpful
6
Replies