Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

2 different outside NAT schemes on 1 router possible?

Is it possible to NAT to one address on one outside interface and another address on another outside interface?

Thanks

2 REPLIES
New Member

Re: 2 different outside NAT schemes on 1 router possible?

Greetings:

Here is how you do it. You can vary it and use a NAT pool if you want.

Thanks...Steve

===================

!

interface Serial0

no ip address

encapsulation frame-relay

service-module t1 timeslots 1-24

!

interface Serial0.16 point-to-point

ip address 65.227.227.158 255.255.255.252

ip nat outside

frame-relay interface-dlci 16 IETF

!

interface serial0.17 point-to-point

ip address 65.227.227.161 255.255.255.252

ip nat outside

frame-relay interface-dlci 17 IETF

!

ip nat inside source route-map Internet interface Serial0.16 overload

ip nat inside source route-map Internet_Backup interface serial0.17 overload

!

ip classless

ip route 0.0.0.0 0.0.0.0 serial0.16

ip route 0.0.0.0 0.0.0.0 serial0.17 200

no ip http server

!

access-list 2 remark

access-list 2 remark NAT List

access-list 2 permit 10.0.0.0 0.0.0.31

!

route-map Internet permit 10

match ip address 2

match interface Serial0.16

!

route-map Internet_Backup permit 10

match ip address 2

match interface serial0.17

New Member

Re: 2 different outside NAT schemes on 1 router possible?

do you mean to specify two match clauses in each route map, or should the second match clause really say "set interface Serial0.16"

I can't find this variant of the ip nat inside source documented in the 12.2 documentation. Any idea where it is discussed?

Thanks

John

109
Views
0
Helpful
2
Replies