cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
406
Views
5
Helpful
4
Replies

2 isp wan connection for the NAT LAN

samuel.lam
Level 1
Level 1

Dear all

In order to provide the non-stop internet access for the lan, a 3600 router is connected to 2 wan connection.

each wan interface is connected to public ip from 2 isp.

the lan is 192.168.1.0/24

how can i do the nat rule?

e.g.

ip route 0.0.0.0 0.0.0.0 a.a.a.a

ip route 0.0.0.0 0.0.0.0 b.b.b.b 10

but how can i do the nat , or any other solution for the redundant. any suggestion?

4 Replies 4

pkhatri
Level 11
Level 11

Try something like the following:

interface serial0

ip address 255.255.255.252

ip nat outside

!

interface serial1

ip address 255.255.255.252

ip nat outside

!

interface GigabitEthernet0/0

ip address 10.1.1.1 255.255.255.0

ip nat inside

!

ip route 0.0.0.0 0.0.0.0 serial0

ip route 0.0.0.0 0.0.0.0 serial1

!

ip nat inside source route-map ISP1-map interface serial0

ip nat inside source route-map ISP2-map interface serial1

!

route-map ISP11-map permit 10

match interface serial0

!

route-map ISP12-map permit 10

match interface serial1

Explanation:

- the use of two static routes will allow you to load-balance over the two links and provide redundancy at the same time

- the NAT config will dynamically choose the NAT'ed address depending on which interface CEF has chosen to send the packet out of...

Hope that helps - pls rate the post if it does.

Regards,

Paresh

Hi Paresh,

I would like to ask you if you have actually implemented this config in a live environment. has it worked ?

after 1 ISp goes down, will the traffic starting getting NATed from 2nd ISP NAT pool?

what happens to the 1st NAT table which was created by 1st ISP pool, say 1st ISP is down now ?

i`ve not seen this in live environment. rather I have suggested PBR will multiple tracking options to my clients or OER.

thanks and regards

aashish C

Hi, I am also facing the same problem & i tried with route-map but its not working...I have VSAT & ISDN connection as a backup link..I tried with creating two access-list & putting tow commands IP nat insisde source list for vsat interface & dailer interface but this is also not working & m still searching for the solution..

All

If i got 2 ip nat inside for 192.168.1.0/24, and 192.168.2.0/24, can the route-map be 192.168.0.0 255.255.0.0 for all the private subnet?

tks all