Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

2 LANs 2 subnets over fiber

Hi All,

What is the best/cheapest way to connect 2 lans in the same building over fiber. I have a switch in office(A) where i can plug fiber, what shoul i have in office(B)? what is the best practice? Should i use Router --fiber--Router or Switch --fiber--Router. I must have 2 different subnets office(A) 192.168.1.0/27 and office(B) 192.168.15.0/27

Thank You

6 REPLIES

Re: 2 LANs 2 subnets over fiber

You dont need two routers at each office.

SInce you are using two subnets, routing between them can take place only if there is a router.

you can use office A--switch -fiber - switch--office B

|

Router

You can get cheap routers which can do the job of routing. IF you have a router already for your wan connection, you can use that to route between the subnets.

ANother way of communication between subnets, would be to set the default gateway as its own ip address, in each PC. This way you wont need a router to route between both subnets.

If you are using this method, you can use,

office A--switchA=====fiber-====switchB---office B

New Member

Re: 2 LANs 2 subnets over fiber

can u re-explain :

ANother way of communication between subnets, would be to set the default gateway as its own ip address, in each PC. This way you wont need a router to route between both subnets

i 'm afraid i understand that we can route between 2 ip subnets without a router!

Re: 2 LANs 2 subnets over fiber

This was something that I observed, while playing around with PCs and Routers an year back.

PC was set with default-gateway as its own ip address. PC1 was in subnet 1 and PC2 was in subnet 2. Both of them were able to ping. I put a sniffer and found that ARP requests were made directly between the hosts, and each PC had each others mac address entries. So conclusion was that, you really dont need a router to route between subnets. PC themselves have the capability to do that

New Member

Re: 2 LANs 2 subnets over fiber

The way I would do it is to get just two switches and one router. Dell makes a 3248 Switch that is comparable to Cisco's 2950g-48 series but is 1/4 the cost. Set it up as switch-fiber-switch-router. You will want to set up the first switch in VLAN 1 and the second switch in VLAN2 (or whatever VLAN you want). You will want to allow 802.1q encapsulation and trunking on the uplinked interfaces from switch to switch and switch to router. You will then want to configure subinterfaces on your ethernet port on the router- each IP address on the ethernet interface will be the address of each VLAN. You will need a Cisco router with a Fastethernet interface on it to support this.

This would be the easiest and best solution. Finding a router that can support gigabit speeds is not easy when you want to keep the costs down. Go fiber between the switches and put the router in the same closet as one of the swtiches.

New Member

Re: 2 LANs 2 subnets over fiber

Hi, thenk you for your info. I got the VLAN on switches part and guess what i do have DELL 3248 switches. I didn't get the routers part, what shoud i do on the router? What commands/programming should i add to a interface fastethernet0? I already have ip address 192.168.1.2. The serial port i have on the router goest to my remote location in another city and is set to 192.168.2.1 255.255.255.252

Thank you

New Member

Re: 2 LANs 2 subnets over fiber

In order to add the sub interfaces you will first have to take the config off of the FE0/0 port then add the subinterfaces. Adding a subinterface is the same as adding a VLAN in a switch:

router(config)#int fastethernet 0/0.1

router(config-int)#:ip address 172.25.130.200

router(config-int)#:encapsulation dot1q 2 (where 2 is the VLAN number)

router(config)#:int fastethernet 0/0.2

router(config-int)#:ip address 172.25.131.200

router(config-int)#:encapsulation dot1q 3

After entering the above commands, your config should look like this for the fastethernet port:

interface FastEthernet0/0

no ip address

duplex full

speed auto

!

interface FastEthernet0/0.1

encapsulation dot1Q 2

ip address 172.25.130.200 255.255.255.0

!

interface FastEthernet0/0.2

encapsulation dot1Q 3

ip address 172.25.131.200 255.255.255.0

What this allows is to have both the 172.25.131.x and the 172.25.130.x network to connect to the same physical port on the router.

If you are running OSPF or another routing protocol, you really shouldnt have any routing issues. Just make sure that the link from switch to switch and switch to router are set for TRUNK MODE. You will then want to put individual ports on your switches into appropriate VLANs. On one of our switches we have the following configuration for a few of the ports:

interface FastEthernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk (trunkport to router)

!

interface FastEthernet0/2

switchport access vlan 2 (port in VLAN 2)

!

interface FastEthernet0/3

switchport trunk encapsulation dot1q

switchport mode trunk (trunkport to downstream switch)

!

interface FastEthernet0/4

switchport access vlan 2 (port in VLAN 2)

I think that should help out a bit.

We are scheduled for some Dell 3248 in the next month.

James

230
Views
6
Helpful
6
Replies