Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

2 x Cisco 3560 and NIC Teaming

Hello

I have a HP DL380 with dual NIC's and 2 Cisco 3560 Switches. I would like to configure the server for redundancy, with NIC1 connected to SWITCH1 and NIC2 connected to SWITCH2. The NICS are configured for NFT. The Cisco 3560's are connected together via a trunk and the ports on both switches are within the same VLAN.

There is a problem with the config as the switches lock up.

Config for both switches

interface FastEthernet0/2

switchport access vlan 10

switchport mode access

speed 100

duplex full

spanning-tree portfast

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

macro description cisco-switch

auto qos voip trust

spanning-tree link-type point-to-point

!

interface GigabitEthernet0/2

shutdown

!

interface GigabitEthernet0/3

switchport trunk encapsulation dot1q

switchport mode trunk

macro description cisco-switch

auto qos voip trust

spanning-tree link-type point-to-point

!

interface GigabitEthernet0/4

shutdown

Any help would be much appreciated

Thanks

3 REPLIES

Re: 2 x Cisco 3560 and NIC Teaming

I am not saying that it's a loop but here are the thing you can do to troubleshoot.

1. When the switches are unresponsive, can you disconnect the one of the links of the teamed NIC? See if that quiets down.

2. If after disconnecting, the switch becomes responsive that would be a good indication that there was a loop. Make sure that the NICs are not blindly passing traffic from one NIC out to the other NIC. The ports have portfast enabled which puts them to forwarding immediately. The switch will not be able to control the loop if the NIC just blindly passing traffic and not participating in the STP.

Please rate post if it helps.

New Member

Re: 2 x Cisco 3560 and NIC Teaming

Thanks for the info, I had already tried your suggestion and yes the switches respond when only one NIC is connected. The NIC's on the server are set to NFT - with one NIC active and the other Passive (disabled), so I don't see how the server can be passing traffic over both links.

Do you have any suggestions for debugging on the switch or any other config I should be running. Do you recommend Etherchannels? If so, do you know how I would configure this on the both switches?

Many thanks

Re: 2 x Cisco 3560 and NIC Teaming

Etherchannel is not supported when the link terminates on two different switch. That your description, the NIC connects to two different 3560. channeling combines two port on the same switch and terminates on the other end on the same device. Something is not working right on NFT, obviously. Maybe you can try removing the portfast as it put the port in forwarding mode immediately. Have you tried removing it?

871
Views
3
Helpful
3
Replies
CreatePlease to create content