Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

2611 inter-vlan routing

Hello,

I am attempting to set up 2 vlan's on my lab system.

Router = 2611,ios image: c2600-ik9o3s-mz.122-11.T9.bin

Switch = 2950, 24 fast eth, ios image: c2950-i6q4l2-mz.121-19.EA1.bin

As I understand it, 802.1q trunking is now supported on ethernet interfaces; however, I am unable to trunk these vlans. I cannot ping between the vlans. Below are excerpts of the 2611 and 2950 configs. Eth0/1 of the 2611 and Fa0/1 of the 2950 are configured for trunking.

2611:

interface Ethernet0/1

description internal interface

no ip address

interface Ethernet0/1.1

encapsulation dot1q 1 native

ip address 192.168.1.1 255.255.255.0

interface Ethernet0/1.2

encapsulation dot1q 2

ip address 192.168.2.1 255.255.255.0

2950:

interface fa0/1

no ip address

no cdp enable

speed 10

duplex full

switchport mode trunk

switchport trunk native vlan 1

switchport trunk allowed vlan all

interface range fa0/2 - 23

no ip address

no cdp enable

speed 100

spanning-tree portfast

duplex full

!

interface fa0/24

no ip address

no cdp enable

speed 100

duplex full

switchport access vlan 2

spanning-tree portfast

Any pointers here from someone who has successfully configured 802.1q on eth interfaces would be greatly appreciated.

joey

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: 2611 inter-vlan routing

Native keyword is not supported on built in ethernet interface in the 2600 series router

http://www.cisco.com/cgi-bin/bugtool/onebug.pl?bugid=CSCea47421

Change your 2600 router config to the following and you should be all set

2611:

interface Ethernet0/1

description native interface

ip address 192.168.1.1 255.255.255.0

interface Ethernet0/1.2

encapsulation dot1q 2

ip address 192.168.2.1 255.255.255.0

4 REPLIES
New Member

Re: 2611 inter-vlan routing

The configs seem ok except that the duplex is hard-coded on the 2950 but not the 2611. So, on the 2611 it probably defaulted to half-duplex. Try hard-coding it to full on the router. And, make sure that the devics connected to the 2950 are hard-coded as well.

New Member

Re: 2611 inter-vlan routing

I went ahead and tried the duplex mod. No change.

Below is some more detail on the issue:

1. From the router's command line, cannot ping any node within vlan 1 or 2.

2. From the switch and any node within vlan 1, cannot ping either of the router's subinterfaces (192.168.1.1 or 192.168.2.1).

3. From a node within vlan 2, successfully ping both of the router's subinterfaces, but cannot ping any node within vlan 1.

Below are some excerpts of traces of pings with debug turned up on the router:

Router to node in vlan 1 (192.168.1.2 is the address of the vlan1 interface on 2950):

router#ping 192.168.1.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:

IP: s=192.168.1.1 (local), d=192.168.1.2 (Ethernet0/1.1), len 100, sending ICMP type=8, code=0

IP: s=192.168.1.1 (local), d=192.168.1.2(Ethernet0/1.1), len 100, encapsulation failed

Success rate is 0 percent (0/5)

Router to node in vlan2:

router#ping 192.168.2.60

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.2.60, timeout is 2 seconds:

IP: s=192.168.2.1 (local), d=192.168.2.60 (Ethernet0/1.2), len 100, sending ICMP type=8, code=0.

Success rate is 0 percent (0/5)

Router trace of ping from node within vlan2 pinging vlan1:

IP: s=192.168.2.60 (Ethernet0/1.2), d=192.168.1.2 (Ethernet0/1.1), g=192.168.1.2, len 60, forward ICMP type=8, code=0

IP: s=192.168.2.60 (Ethernet0/1.2), d=192.168.1.2 (Ethernet0/1.1), len 60, encapsulation failed

Any ideas as to what the "encapsulation failed" verbiage could be a symptom of?

thanks

New Member

Re: 2611 inter-vlan routing

I do not understand how #3 would work and not #1? Ping requires both ends to respond and should not matter who originates the traffic. There was also a bug that should be fixed in your code where fast-switching on the router was broken - CSCds42715. Try disabling that on the 2600 under the main interface, no ip route-cache. If that still does not work, SPAN the 2950 switchport and see which direction it is broke.

Cisco Employee

Re: 2611 inter-vlan routing

Native keyword is not supported on built in ethernet interface in the 2600 series router

http://www.cisco.com/cgi-bin/bugtool/onebug.pl?bugid=CSCea47421

Change your 2600 router config to the following and you should be all set

2611:

interface Ethernet0/1

description native interface

ip address 192.168.1.1 255.255.255.0

interface Ethernet0/1.2

encapsulation dot1q 2

ip address 192.168.2.1 255.255.255.0

288
Views
0
Helpful
4
Replies
CreatePlease login to create content