Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

2801 with a 9 port Ethernet HWIC

have a 2801 with a 9 port Ethernet HWIC and a 4 port Ethernet HWIC. If you plug a machine into the switch modules, the machine will not pick up a dhcp address. If you put a static address on the machine, you can not ping the default gateway. You can ping another machine that is plugged into either the 9 port or 4 port modules. If you plug a cable into fa0/0 and the other end into the switch module, it still does not work. It is like the switch modules want to stay in their own little world.

any one any ideas how i manage to get devices plugged into the module switch ports to see the outside past the module

cheers for any info

4 REPLIES

Re: 2801 with a 9 port Ethernet HWIC

hi

Can you give some lead on how the configuration is done ? have you configured any SVI and have ip assigned to that interface ?if thats the case have you made all these ports as a member of that vlan ?

if possible do post your configs here with both your public ips and passwords masked ..

regs

New Member

Re: 2801 with a 9 port Ethernet HWIC

hostname **********

!

boot-start-marker

boot-end-marker

!

logging buffered 51200 warnings

enable secret ********************

!

clock summer-time BST recurring last Sun Mar 1:00 last Sun Oct 1:00

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

no aaa new-model

ip subnet-zero

ip cef

!

!

ip dhcp excluded-address 10.14.60.129

ip dhcp excluded-address 10.14.60.161

!

ip dhcp pool VOICE

network 10.14.60.160 255.255.255.224

default-router 10.14.60.161

option 150 ip 10.18.1.11

dns-server 10.17.1.23 10.17.1.64

!

ip dhcp pool DATA

network 10.14.60.128 255.255.255.224

default-router 10.14.60.129

dns-server 10.17.1.23 10.17.1.64

!

!

ip host ccm1 **********

ip host ccm2 **********

ip multicast-routing

ip rcmd rcp-enable

!

voice-card 0

dsp services dspfarm

!

!

voice call convert-discpi-to-prog

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

no ip address

ip pim sparse-mode

speed 100

full-duplex

!

interface FastEthernet0/0.128

description DATA VLAN

encapsulation dot1Q 128

ip address 10.14.60.129 255.255.255.224

!

interface FastEthernet0/0.160

description VOICE VLAN

encapsulation dot1Q 160

ip address 10.14.60.161 255.255.255.224

!

interface FastEthernet0/1

ip address 10.14.200.18 255.255.255.252

duplex auto

speed 10

!

interface FastEthernet0/1/0

switchport trunk native vlan 128

switchport mode trunk

switchport voice vlan 160

spanning-tree portfast

!

interface FastEthernet0/1/1

switchport trunk native vlan 128

switchport mode trunk

switchport voice vlan 160

spanning-tree portfast

!

interface FastEthernet0/1/2

switchport trunk native vlan 128

switchport mode trunk

switchport voice vlan 160

spanning-tree portfast

!

interface FastEthernet0/1/3

switchport trunk native vlan 128

switchport mode trunk

switchport voice vlan 160

spanning-tree portfast

!

interface FastEthernet0/1/4

switchport trunk native vlan 128

switchport mode trunk

switchport voice vlan 160

spanning-tree portfast

!

interface FastEthernet0/1/5

switchport access vlan 128

spanning-tree portfast

!

interface FastEthernet0/1/6

switchport trunk native vlan 128

switchport mode trunk

switchport voice vlan 160

spanning-tree portfast

!

interface FastEthernet0/1/7

switchport trunk native vlan 128

switchport mode trunk

switchport voice vlan 160

spanning-tree portfast

!

interface FastEthernet0/1/8

switchport stacking-partner interface FastEthernet0/3/0

!

interface FastEthernet0/3/0

switchport stacking-partner interface FastEthernet0/1/8

!

interface FastEthernet0/3/1

switchport trunk native vlan 128

switchport mode trunk

switchport voice vlan 160

spanning-tree portfast

!

interface FastEthernet0/3/2

switchport trunk native vlan 128

switchport mode trunk

switchport voice vlan 160

spanning-tree portfast

!

interface FastEthernet0/3/3

switchport trunk native vlan 128

switchport mode trunk

switchport voice vlan 160

spanning-tree portfast

!

interface ATM0/2/0

no ip address

atm vc-per-vp 128

no atm ilmi-keepalive

dsl operating-mode auto

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

!

interface Vlan1

no ip address

!

interface Dialer1

ip address ****************

ip pim sparse-mode

ip nat outside

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap callin

ppp chap hostname ********************

ppp chap password ********************

ppp pap sent-username ****************

ppp ipcp dns request

hold-queue 224 in

!

ip classless

ip route 10.17.0.0 255.255.0.0 Dialer1

!

!

no ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 600 life 86400 requests 10000

Re: 2801 with a 9 port Ethernet HWIC

As this is a switching module you must also configure the vlan database, either through the (deprecated "vlan dat" command or via the IOS config)

Your switched vlan ports might be down otherwise.

The problem may also lie in the switchport mode trunk command that you have put on all ports. With the latest software you should configure the ports in access mode with an additional switchport voice vlan command.

The netto result of that is that it works as desired. I have not found any docs on the deeper issues behind this (may be something with autonegotiation) but in practice, it worked with me.

Regards,

Leo

Bronze

Re: 2801 with a 9 port Ethernet HWIC

Hello,

multiple Ethernet Switch HWICs installed in a host router will not act independently of each other. You need to configure stacking for both modules, as they will not work at all otherwise.

Stacking is the connection of two switch modules resident in the same chassis so that they behave as a single switch. When a chassis is populated with two switch modules, the user must configure both of them to operate in stacked mode. This is done by selecting one port from each switch module and configuring it to be a stacking partner. The user must then connect with a cable the stacking partners from each switch module to physically stack the switch modules. Any one port in a switch module can be designated as the stacking partner for that switch module.

Beginning in privileged EXEC mode, follow these steps to configure a pair of ports on two different switch modules as stacking partners.

COMMAND SUMMARY STEPS

1. interface fastethernet interface-id

2. no shutdown

3. switchport stacking-partner interface FastEthernet partner-interface-id

4. exit

5. interface fastethernet partner-interface-id

6. no shutdown

7. end

Regards,

Nethelper

305
Views
0
Helpful
4
Replies
CreatePlease to create content