Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

2811 router doesn't pull DHCP from DSL or Cable

I have ten 2811 routers that won't pull DHCP address from a DSL or cable modem. If I plug in a laptop to the cable modem it pulls a DHCP address. Most of the sites have a static IP, but the cable modem company does not have static addresses, so two of the sites must use DHCP. Any ideas?

9 REPLIES

Re: 2811 router doesn't pull DHCP from DSL or Cable

Hello Paul,

did you configure the router with

interface Ethernet0/0

ip address dhcp

on the interface connected to the cable modem? Second, does your provider check MAC addresses? In case yes, you can reconfigure them with "mac-address 00.11.22.33.44.55" on your ethernet interface and substitute it with the MAC address required.

In case this does not solve the problem, what is the output of "debug dhcp" give you?

Do not forget to disable the debug after use (undebug all).

Hope this helps! Please rate all posts.

Regards, Martin

New Member

Re: 2811 router doesn't pull DHCP from DSL or Cable

Hi Martin, I did configure Ethernet0/0 with ip address dhcp. When I do a show dhcp server it replys back with 0 (Offers 0,lease 0, request 0, etc...)

So I can enter mac-address ... basically mac spoofing? This may work.

The strange thing is I have tried with 3 different DSL providers and 1 cable company and can not get any of them to pull DHCP. I even had a consultant look at it (he is a CCIE) and he couldn't get the router to pull a DHCP address. I tried to google the problem and I couldn't find much on it. Thanks for the help, it is greatly appreciated!

Re: 2811 router doesn't pull DHCP from DSL or Cable

Hello Paul,

the command "show dhcp server" gives statistics about the IOS DHCP server, so only will give some output in case the router is DHCP server for LAN clients. This is unfortunately not your case.

There is another command "ip dhcp-client broadcast-flag" described at

http://www.cisco.com/en/US/products/sw/iosswrel/ps1835/products_command_reference_chapter09186a0080087376.html#wp1062678

I have no clue whether this will change the outcome, but you could give it a try.

Can you post the relevant config of the interface not pulling a DHCP address?

Regards, Martin

New Member

Re: 2811 router doesn't pull DHCP from DSL or Cable

Hi Martin,

Thanks for the info on sh DHCP server. I will look at the article. Here is the int info.

interface FastEthernet0/0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0/0$

ip address dhcp

ip verify unicast reverse-path

ip nat outside

ip inspect DEFAULT100 out

ip virtual-reassembly

duplex auto

speed auto

crypto ipsec df-bit clear

crypto ipsec client ezvpn Proc

VIP Purple

Re: 2811 router doesn't pull DHCP from DSL or Cable

Hello,

you might want to take out the 'ip inspect DEFAULT100 out' statement, see if that makes a difference...

Regards,

GP

Re: 2811 router doesn't pull DHCP from DSL or Cable

Hello Paul,

for trouble shooting purposes please remove most commands and use

interface FastEthernet0/0

ip address dhcp

duplex half

speed 10

This way we can find out, if dhcp does not work or any other feature interferes with it.

In case this will work, add one line of config after the other again and check when it doesn´t work again to find what prevents IP address negotiation.

One more thing: is the interface operational?

show interface FastEthernet0/0

should show interface up, line protocol up.

Hope this helps!

Martin

New Member

Re: 2811 router doesn't pull DHCP from DSL or Cable

Hi Martin, thanks for the help. Yes it is operational, the cable company gave me a sticky IP address (must be like a static, but can get released if it doesn't see a device). So with the sticky it was working. The strange thing is I have ten of these routers all doing the same thing with different ISPs. The other routers I could take an internal DHCP address from the scope and assign it to the FastEthernet0/0 making it static. The cable modem is different as the first time the device connects to the cable network it is a 10. address once you register the device it becomes a 12. that is associated with the mac address.

I may take your advice and connect one of the sites PCs directly to the cable modem, register the PC and then assign that mac address to the FastEthernet0/0. I won't have any conflicts between that PC and the router will I? I have my LinkSys at home setup to do mac spoofing, so it sounds like the same idea.

Re: 2811 router doesn't pull DHCP from DSL or Cable

Hi Paul,

first congratulations that you found a working solution for your clients. Second, two remarks:

1) with different ISP ... this might be the reason.

2) You could reconfigure the PCs MAC to the router MAC, register and then connect the router and revert the PC to the original MAC.

Just to avoid having identical MAC in two devices

Hope this helps! Please rate all posts.

Regards, Martin

lap
New Member

Re: 2811 router doesn't pull DHCP from DSL or Cable

Hi,

I had a similar problem today when I was configuring a router 881W with a new IP for a customer. The ISP could see the DHCP discover of my router but the router wasn't pooling the IP.

The config on the interface was like that:

interface FastEthernet4
ip address dhcp
ip access-group 102 in
ip verify unicast reverse-path
no ip redirects
no ip unreachables
no ip proxy-arp
ip flow ingress
ip nat outside
ip inspect DEFAULT100 out
ip virtual-reassembly
duplex auto
speed auto
snmp trap ip verify drop-rate
crypto map kreds103

So what I did is configure the interface to default with default interface f4. Then I just configured ip address dhcp and I could get the IP.

Then I configured everything back on the interface.

Hope this help! Remember to rate if you think it helps.

Best regards,

Laurent

2000
Views
10
Helpful
9
Replies
CreatePlease to create content