Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

2900mXL switch won't boot HELP PLEASE!!!!!!! asap

Hello all, I've erase the NVRAM old IOS version of 12.0(5)WC3b and while I still had the console I copied the new IOS version that I wanted via tftp which was 12.0(5.1)XP Now, my switch won't boot up properly!!!! I need to get this switch into the production environment by the end of today, can anyone help? If not I guess I can open a TAC case. This is the error message I'm getting, look towards the bottom where it says "PERMISSION DENIED" I've tried to set the BOOT FS: to RW but it won't let me, please HELP!!!!

2900XL Boot Loader (C2900-HBOOT-M) Version 12.0(5.1)XP, MAINTENANCE INTERIM SOFTWARE

Compiled Fri 10-Dec-99 11:06 by cchang

starting...

Base ethernet MAC Address: 00:01:42:5e:b5:00

Xmodem file system is available.

Initializing Flash...

flashfs[0]: changing status of block 20 from "committed" to "in use".

flashfs[0]: Checking block 21...bad block number (-1)

flashfs[0]: erasing block 21...done.

flashfs[0]: 27 files, 4 directories

flashfs[0]: 0 orphaned files, 0 orphaned directories

flashfs[0]: Total bytes: 3612672

flashfs[0]: Bytes used: 3020288

flashfs[0]: Bytes available: 592384

flashfs[0]: flashfs fsck took 8 seconds.

...done Initializing Flash.

Boot Sector Filesystem (bs:) installed, fsid: 3

Parameter Block Filesystem (pb:) installed, fsid: 4

Loading "c2900XL-h2s-mz-120.5.1-XP.bin"...c2900XL-h2s-mz-120.5.1-XP.bin: permission denied

4 REPLIES
Cisco Employee

Re: 2900mXL switch won't boot HELP PLEASE!!!!!!! asap

Does the switch go back to "switch:" prompt? Can you paste the output of "dir flash:"? if you have not tried a manual boot with command "boot flash:file_name", try it.

New Member

Re: 2900mXL switch won't boot HELP PLEASE!!!!!!! asap

Yes, I believe I have tried the "boot flash:file_name" but if you look towards the bottom of this page you will see that there is no file in flash, I deleted the original and now I'm STUCK :-( It says I don't have proper permission.

switch: dir flash:

Directory of flash:/

3 -rwx 102893 c2900XL-diag-mz-120.5.1-XP

4 drwx 768 html

6 -rwx 1490614 c2900XL-h2s-mz-120.5.1-XP.bin

180 -rwx 109 info

181 -rwx 556 vlan.dat

19 -rwx 345 env_vars

17 -rwx 8192 e2rb.bin

18 -rwx 109 info.ver

20 -rwx 2673 config.text

592384 bytes available (3020288 bytes used)

switch: dir

List of filesystems currently registered:

flash[0]: (read-write)

xmodem[1]: (read-only)

null[2]: (read-write)

bs[3]: (read-only)

switch:

New Member

Re: 2900mXL switch won't boot HELP PLEASE!!!!!!! asap

Yes, it does go back to switch prompt but with limited commands

switch: ?

? -- Present list of available commands

boot -- Load and boot an executable image

cat -- Concatenate (type) file(s)

copy -- Copy a file

delete -- Delete file(s)

dir -- List files in directories

flash_init -- Initialize flash filesystem(s)

format -- Format a filesystem

fsck -- Check filesystem consistency

help -- Present list of available commands

load_helper -- Load and initialize a helper image

memory -- Present memory heap utilization information

mkdir -- Create dir(s)

more -- Concatenate (display) file(s)

rename -- Rename a file

reset -- Reset the system

rmdir -- Delete empty dir(s)

set -- Set or display environment variables

set_bs -- Set attributes on a boot sector filesystem

set_param -- Set system parameters in flash

sleep -- Sleep a specified number of seconds

trap -- Cause a software breakpoint to occur

type -- Concatenate (type) file(s)

unset -- Unset one or more environment variables

version -- Display boot loader version

switch:

New Member

Re: 2900mXL switch won't boot HELP PLEASE!!!!!!! asap

I am going to try using Xmodem to bring this puppy back to life.

Here is where I found it..

http://www.cisco.com/warp/public/473/36.shtml#xmodem

Thanks for your help all :-)

135
Views
0
Helpful
4
Replies
CreatePlease login to create content