Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

2948G L3 configuration help

Im currently employing a 2948G L3 switch/router doing our core routing with some fastetherchannel and two BVI's. This configuration was done through reading and browsing the internet for notes. Im currently encountering a problem that totally shuts down my network. On the two BVI's, one is Ok while the other often drops. On my 2948G I have all the servers and routers connected to BVI 1 while another is using BVI2. The BVI1 often goes down often and the only solution we found is to reload it.

A couple of subnets is directed to BVI1 where only one subnet is on BVI2. We bought a 3660 recently and hope to move all the routes to that router and let the 2948G L3 do the switching and fastetherchannel. Below is my configuration and I hope someone can point out my problem

ITC2948Switch#sho conf

Using 11312 out of 124920 bytes

!

! Last configuration change at 12:51:11 UTC Fri Jul 12 2002

! NVRAM config last updated at 12:51:12 UTC Fri Jul 12 2002

!

version 12.0

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname ITC2948Switch

!

!

sdm size ipx-bvi-network 32

sdm size ip-adjacency 2048

sdm size ipx-node 2048

sdm size ip-prefix 8192

sdm size ipx-network 6144

sdm size ip-mcast 3072

sdm size udp-flooding 256

sdm size l2-switching 1024

sdm autolearn

ip subnet-zero

bridge irb

!

!

!

interface Port-channel1

no ip address

no ip directed-broadcast

shutdown

hold-queue 300 in

!

interface Port-channel2

description Unicenter01 port 33_34

no ip address

no ip directed-broadcast

bridge-group 1

hold-queue 300 in

!

interface Port-channel3

description Finsuvantsrv01 port 31_32

no ip address

no ip directed-broadcast

bridge-group 1

hold-queue 300 in

!

interface Port-channel4

description ntsrv005 port 29_30

no ip address

no ip directed-broadcast

bridge-group 1

hold-queue 300 in

!

interface Port-channel5

description Cache port 27_28

no ip address

no ip directed-broadcast

bridge-group 1

hold-queue 300 in

!

interface Port-channel6

description SQL Production port 25_26

no ip address

no ip directed-broadcast

bridge-group 1

hold-queue 300 in

!

interface Port-channel7

description nexchange port43-46

no ip address

no ip directed-broadcast

bridge-group 1

hold-queue 300 in

!

interface FastEthernet1

description Netman

no ip address

ip directed-broadcast

duplex full

bridge-group 2

!

interface FastEthernet2

no ip address

no ip directed-broadcast

no keepalive

duplex full

!

interface FastEthernet2.2

encapsulation isl 2

no ip redirects

no ip directed-broadcast

bridge-group 2

!

interface FastEthernet3

description link_to_ITCSwitch

no ip address

no ip directed-broadcast

duplex full

bridge-group 1

!

interface FastEthernet4

no ip address

no ip directed-broadcast

shutdown

!

interface FastEthernet5

description Subnet 10.1.87.1

no ip address

ip directed-broadcast

duplex full

!

interface FastEthernet5.1

encapsulation isl 2

no ip redirects

no ip directed-broadcast

bridge-group 2

!

interface FastEthernet6

no ip address

ip directed-broadcast

bridge-group 1

!

interface FastEthernet7

description ITC Frame-Relay Gateway

no ip address

no ip directed-broadcast

bridge-group 1

!

interface FastEthernet8

no ip address

no ip directed-broadcast

shutdown

!

interface FastEthernet9

description dialup_router1

no ip address

no ip directed-broadcast

duplex half

speed 10

bridge-group 1

!

interface FastEthernet10

description dialup_router2

no ip address

no ip directed-broadcast

duplex half

speed 10

bridge-group 1

!

interface FastEthernet11

description gateway_router2

no ip address

no ip directed-broadcast

speed 10

bridge-group 1

!

interface FastEthernet12

description gateway_router1

no ip address

no ip directed-broadcast

duplex half

speed 10

bridge-group 1

!

interface FastEthernet13

description LNSRV010

no ip address

no ip directed-broadcast

duplex full

bridge-group 1

!

interface FastEthernet14

description Ntsrv003

no ip address

no ip directed-broadcast

bridge-group 1

!

interface FastEthernet15

description ntdc01

no ip address

no ip directed-broadcast

bridge-group 1

!

interface FastEthernet16

description ntsrv001

no ip address

no ip directed-broadcast

bridge-group 1

!

interface FastEthernet17

description ntsrv002

no ip address

no ip directed-broadcast

bridge-group 1

!

interface FastEthernet18

description ntdc04

no ip address

no ip directed-broadcast

bridge-group 1

!

interface FastEthernet19

description TNG02

no ip address

no ip directed-broadcast

bridge-group 1

!

interface FastEthernet20

description Link to Qmail-temp exchange

no ip address

no ip directed-broadcast

duplex full

bridge-group 1

!

interface FastEthernet21

description NTSRV008

no ip address

no ip directed-broadcast

bridge-group 1

!

interface FastEthernet22

description Web Serv Test

no ip address

no ip directed-broadcast

shutdown

bridge-group 1

!

interface FastEthernet23

description unicenter02

no ip address

no ip directed-broadcast

bridge-group 1

!

interface FastEthernet24

description spare port for itcsuvantsrv02

no ip address

no ip directed-broadcast

bridge-group 1

!

interface FastEthernet25

description Production_SQL

no ip address

no ip directed-broadcast

duplex full

channel-group 6

!

interface FastEthernet26

description Production_SQL

no ip address

no ip directed-broadcast

duplex full

channel-group 6

!

interface FastEthernet27

description cache

no ip address

no ip directed-broadcast

duplex full

channel-group 5

!

interface FastEthernet28

description cache

no ip address

no ip directed-broadcast

duplex full

channel-group 5

!

interface FastEthernet29

description ntsrv005

no ip address

no ip directed-broadcast

duplex full

channel-group 4

!

interface FastEthernet30

description ntsrv005

no ip address

no ip directed-broadcast

duplex full

channel-group 4

!

interface FastEthernet31

description finsuvantsrv01

no ip address

no ip directed-broadcast

duplex full

channel-group 3

!

interface FastEthernet32

description finsuvantsrv01

no ip address

no ip directed-broadcast

duplex full

channel-group 3

!

interface FastEthernet33

description unicenter01

no ip address

no ip directed-broadcast

duplex full

channel-group 2

!

interface FastEthernet34

description unicenter01

no ip address

no ip directed-broadcast

duplex full

channel-group 2

!

interface FastEthernet35

description TNG01

no ip address

no ip directed-broadcast

duplex full

bridge-group 1

!

interface FastEthernet36

description TNG03

no ip address

no ip directed-broadcast

duplex full

bridge-group 1

!

interface FastEthernet37

description itcsuvantsrv03

no ip address

no ip directed-broadcast

bridge-group 1

!

interface FastEthernet38

description itcsuvantsrv01

no ip address

no ip directed-broadcast

bridge-group 1

!

interface FastEthernet39

description itcsuvantsrv08

no ip address

no ip directed-broadcast

bridge-group 1

!

interface FastEthernet40

description TNG04

no ip address

no ip directed-broadcast

shutdown

bridge-group 1

!

interface FastEthernet41

description irdsuvantsrv01

no ip address

no ip directed-broadcast

bridge-group 1

!

interface FastEthernet42

no ip address

no ip directed-broadcast

shutdown

!

interface FastEthernet43

description nexchange01

no ip address

no ip directed-broadcast

duplex full

channel-group 7

!

interface FastEthernet44

description nexchange01

no ip address

no ip directed-broadcast

duplex full

channel-group 7

!

interface FastEthernet45

description nexchange01

no ip address

no ip directed-broadcast

duplex full

channel-group 7

!

interface FastEthernet46

description nexchange01

no ip address

no ip directed-broadcast

duplex full

channel-group 7

!

interface FastEthernet47

no ip address

no ip directed-broadcast

shutdown

!

interface FastEthernet48

description fibre link to IRD_Education

no ip address

no ip directed-broadcast

duplex full

speed 100

bridge-group 1

!

interface GigabitEthernet49

no ip address

no ip directed-broadcast

bridge-group 1

!

interface GigabitEthernet50

no ip address

no ip directed-broadcast

bridge-group 1

!

interface BVI1

description Govnet_Bridgegroup

ip address 10.1.85.22 255.255.255.0

no ip directed-broadcast

!

interface BVI2

description ITC_bridge-group

ip address 10.1.87.1 255.255.255.0

no ip directed-broadcast

no ip route-cache cef

!

router eigrp 100

network 10.0.0.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.1.85.1 permanent

ip route 10.1.1.0 255.255.255.0 10.1.85.5

ip route 10.1.2.0 255.255.255.0 10.1.85.20

ip route 10.1.3.0 255.255.255.0 10.1.85.23

ip route 10.1.6.0 255.255.255.0 10.1.85.5

ip route 10.1.7.0 255.255.255.0 10.1.85.5

ip route 10.1.10.0 255.255.255.0 BVI1

ip route 10.1.11.0 255.255.255.0 10.1.85.20

ip route 10.1.12.0 255.255.255.0 BVI1

ip route 10.1.13.0 255.255.255.0 10.1.85.23

ip route 10.1.14.0 255.255.255.0 BVI1

ip route 10.1.19.0 255.255.255.0 BVI1

ip route 10.1.21.0 255.255.255.0 BVI1

ip route 10.1.25.0 255.255.255.0 10.1.85.20

ip route 10.1.26.0 255.255.255.0 10.1.85.23

ip route 10.1.30.0 255.255.255.0 BVI1

ip route 10.1.35.0 255.255.255.0 BVI1

ip route 10.1.40.0 255.255.255.0 BVI1

ip route 10.1.45.0 255.255.255.0 10.1.85.20

ip route 10.1.46.0 255.255.255.0 BVI1

ip route 10.1.48.0 255.255.255.0 10.1.85.20

ip route 10.1.51.0 255.255.255.0 10.1.85.5

ip route 10.1.55.0 255.255.255.0 BVI1

ip route 10.1.56.0 255.255.255.0 10.1.85.5

ip route 10.1.57.0 255.255.255.0 10.1.85.23

ip route 10.1.70.0 255.255.255.0 BVI1

ip route 10.1.71.0 255.255.255.0 BVI1

ip route 10.1.75.0 255.255.255.0 10.1.85.5

ip route 10.1.77.0 255.255.255.0 10.1.85.5

ip route 10.1.80.0 255.255.255.0 10.1.85.23

ip route 10.1.81.0 255.255.255.0 10.1.85.20

ip route 10.1.84.0 255.255.255.0 BVI1

ip route 10.1.85.0 255.255.255.0 BVI1

ip route 10.1.86.0 255.255.255.192 10.1.85.2

ip route 10.1.86.64 255.255.255.192 10.1.85.3

ip route 10.1.87.0 255.255.255.0 BVI2

ip route 10.1.91.0 255.255.255.0 10.1.85.23

ip route 10.1.92.0 255.255.255.0 10.1.85.23

ip route 10.1.93.0 255.255.255.0 10.1.85.23

ip route 10.1.96.0 255.255.255.0 BVI1

ip route 10.1.97.0 255.255.255.0 BVI1

ip route 10.1.103.0 255.255.255.0 10.1.85.20

ip route 10.1.105.0 255.255.255.0 BVI1

ip route 10.1.108.0 255.255.255.0 BVI1

ip route 10.1.109.0 255.255.255.0 10.1.85.23

ip route 10.1.111.0 255.255.255.0 10.1.85.5

ip route 10.1.113.0 255.255.255.0 BVI1

ip route 10.1.115.0 255.255.255.0 10.1.85.23

ip route 10.1.116.0 255.255.255.0 10.1.85.23

ip route 10.1.117.0 255.255.255.0 10.1.85.23

ip route 10.1.118.0 255.255.255.0 10.1.85.23

ip route 10.1.119.0 255.255.255.0 10.1.85.23

ip route 10.1.120.0 255.255.255.0 10.1.85.23

ip route 10.1.121.0 255.255.255.0 10.1.85.20

ip route 10.1.125.0 255.255.255.0 BVI1

ip route 10.1.130.0 255.255.255.0 BVI1

ip route 10.1.132.0 255.255.255.0 BVI1

ip route 10.1.134.0 255.255.255.0 BVI1

ip route 10.3.70.0 255.255.255.0 10.1.85.23

ip route 10.4.0.0 255.255.0.0 10.1.85.20

ip route 10.7.0.0 255.255.0.0 10.1.85.23

ip route 10.10.0.0 255.255.0.0 10.1.85.23

ip route 10.13.0.0 255.255.0.0 10.1.85.23

ip route 10.160.0.0 255.255.0.0 10.1.85.5

ip http server

!

bridge 1 protocol ieee

bridge 1 route ip

bridge 2 protocol ieee

bridge 2 route ip

!

line con 0

exec-timeout 5 30

password 7 020C11481F02002858

login

transport input none

line aux 0

line vty 0 4

password 7 032F4E012D0E2D1E1C

login

!

end

3 REPLIES
New Member

Re: 2948G L3 configuration help

please try the lastest software available and if that doesn't fix the issue. please open a TAC case for further investigation

New Member

Re: 2948G L3 configuration help

Where can I get the latest IOS for this model ? Can I download it from the cisco site. I have been looking for it for a long time but to no avail. Please help

Cisco Employee

Re: 2948G L3 configuration help

Here you go. You can download 12.0(18)W5(22b) from

http://www.cisco.com/cgi-bin/tablebuild.pl/cat2948g-l3

LAN Switching software section in CCO is at

http://www.cisco.com/kobayashi/sw-center/sw-lan.shtml

105
Views
0
Helpful
3
Replies
CreatePlease to create content