Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

2948G L3 switch problem

I was using a 2948G L3 and it was giving me problems. I was told by someone that I need to upgrade the IOS as the IOS I was using gives problem. I was also told that this model of switch is not a good one

Can somebody enlighten me with more information on this particular model

4 REPLIES
Gold

Re: 2948G L3 switch problem

Its an entry level layer 3 swtich, its been "around the block a while" .

I have used em, with no problem....what particular issue are you running into ?

Which version of the IOS are you using ?

New Member

Re: 2948G L3 switch problem

Sorry for the late reply. Was out of the office. Anyway, I was using it to connect all our routers and servers. Do some etherchannel and two BVI's.

Here is my config and the current IOS version

GOVNET-L3#sho conf

Using 8998 out of 124920 bytes

!

! Last configuration change at 10:35:39 PST Thu Jul 18 2002

! NVRAM config last updated at 10:35:41 PST Thu Jul 18 2002

!

version 12.0

no service pad

service timestamps debug datetime msec localtime

service timestamps log datetime msec localtime

no service password-encryption

!

hostname GOVNET-L3

!

enable secret 5 $1$gGV6$Gj00Ns4trlWDS8RGT22QP/

enable password openlook

!

clock timezone PST -8

clock calendar-valid

sdm size ipx-bvi-network 32

sdm size ip-adjacency 2048

sdm size ipx-node 2048

sdm size ip-prefix 8192

sdm size ipx-network 6144

sdm size ip-mcast 3072

sdm size udp-flooding 256

sdm size l2-switching 1024

sdm autolearn

ip subnet-zero

bridge irb

!

!

!

interface Port-channel1

description NTDC01 port 39_40

no ip address

no ip directed-broadcast

bridge-group 1

bridge-group 1 spanning-disabled

hold-queue 300 in

!

interface Port-channel2

description Unicenter01 port 33_34

no ip address

no ip directed-broadcast

bridge-group 1

bridge-group 1 spanning-disabled

hold-queue 300 in

!

interface Port-channel3

description FINSUVANTSRV01 port 31_32

no ip address

no ip directed-broadcast

bridge-group 1

bridge-group 1 spanning-disabled

hold-queue 300 in

!

interface Port-channel4

description NTSRV005 port 29_30

no ip address

no ip directed-broadcast

bridge-group 1

bridge-group 1 spanning-disabled

hold-queue 300 in

!

interface Port-channel5

description CACHE port 27_28

no ip address

no ip directed-broadcast

bridge-group 1

bridge-group 1 spanning-disabled

hold-queue 300 in

!

interface Port-channel6

description SQL Production port 25_26

no ip address

no ip directed-broadcast

bridge-group 1

bridge-group 1 spanning-disabled

hold-queue 300 in

!

interface Port-channel7

description EXCHANGE01 port 43_46

no ip address

no ip directed-broadcast

bridge-group 1

bridge-group 1 spanning-disabled

hold-queue 300 in

!

interface FastEthernet1

description 3660 Core router

no ip address

no ip directed-broadcast

bridge-group 1

!

interface FastEthernet2

description 2522 Access Router 1

no ip address

no ip directed-broadcast

bridge-group 1

!

interface FastEthernet3

description 2522 Access Router 2

no ip address

no ip directed-broadcast

bridge-group 1

!

interface FastEthernet4

description 1720 Frame Relay Host

no ip address

no ip directed-broadcast

bridge-group 1

!

interface FastEthernet5

description 2511 Dialup Router 1

no ip address

no ip directed-broadcast

duplex half

speed 10

bridge-group 1

!

interface FastEthernet6

description 2511 Dialup Router 2

no ip address

no ip directed-broadcast

duplex half

speed 10

bridge-group 1

!

interface FastEthernet7

description 2924XL Switch_87 Subnet

no ip address

no ip directed-broadcast

duplex full

!

interface FastEthernet7.1

encapsulation isl 2

no ip redirects

no ip directed-broadcast

bridge-group 2

!

interface FastEthernet8

description 2916XL Fiber Switch

no ip address

no ip directed-broadcast

duplex full

speed 100

bridge-group 1

!

interface FastEthernet9

no ip address

no ip directed-broadcast

duplex full

bridge-group 1

!

interface FastEthernet10

no ip address

no ip directed-broadcast

shutdown

!

interface FastEthernet11

no ip address

no ip directed-broadcast

shutdown

!

interface FastEthernet12

no ip address

no ip directed-broadcast

shutdown

!

interface FastEthernet13

description LNSRV010_Linux Server

no ip address

no ip directed-broadcast

duplex full

bridge-group 1

bridge-group 1 spanning-disabled

!

interface FastEthernet14

description NTSRV003

no ip address

no ip directed-broadcast

duplex full

bridge-group 1

bridge-group 1 spanning-disabled

!

interface FastEthernet15

description AHD Server

no ip address

no ip directed-broadcast

duplex full

bridge-group 1

bridge-group 1 spanning-disabled

!

interface FastEthernet16

description NTSRV001

no ip address

no ip directed-broadcast

duplex full

bridge-group 1

bridge-group 1 spanning-disabled

!

interface FastEthernet17

description UNICENTER

no ip address

no ip directed-broadcast

duplex full

bridge-group 1

bridge-group 1 spanning-disabled

!

interface FastEthernet18

description NTDC04

no ip address

no ip directed-broadcast

duplex full

bridge-group 1

bridge-group 1 spanning-disabled

!

interface FastEthernet19

description TNG02

no ip address

no ip directed-broadcast

duplex full

bridge-group 1

bridge-group 1 spanning-disabled

!

interface FastEthernet20

description QMAIL

no ip address

no ip directed-broadcast

duplex full

bridge-group 1

bridge-group 1 spanning-disabled

!

interface FastEthernet21

description NTSRV008

no ip address

no ip directed-broadcast

duplex full

bridge-group 1

bridge-group 1 spanning-disabled

!

interface FastEthernet22

description UNICENTER02

no ip address

no ip directed-broadcast

duplex full

bridge-group 1

bridge-group 1 spanning-disabled

!

interface FastEthernet23

description TEST FOR NTDC01

no ip address

no ip directed-broadcast

shutdown

duplex full

bridge-group 1

bridge-group 1 spanning-disabled

!

interface FastEthernet24

description TEST FOR EXCHANGE01

no ip address

no ip directed-broadcast

shutdown

duplex full

bridge-group 1

bridge-group 1 spanning-disabled

!

interface FastEthernet25

description SQL_PRODUCTION

no ip address

no ip directed-broadcast

duplex full

channel-group 6

!

interface FastEthernet26

description SQL_PRODUCTION

no ip address

no ip directed-broadcast

duplex full

channel-group 6

!

interface FastEthernet27

description CACHE

no ip address

no ip directed-broadcast

duplex full

channel-group 5

!

interface FastEthernet28

description CACHE

no ip address

no ip directed-broadcast

duplex full

channel-group 5

!

interface FastEthernet29

description NTSRV005

no ip address

no ip directed-broadcast

duplex full

channel-group 4

!

interface FastEthernet30

description NTSRV005

no ip address

no ip directed-broadcast

duplex full

channel-group 4

!

interface FastEthernet31

description FINSUVANTSRV01

no ip address

no ip directed-broadcast

duplex full

channel-group 3

!

interface FastEthernet32

description FINSUVANTSRV01

no ip address

no ip directed-broadcast

duplex full

channel-group 3

!

interface FastEthernet33

description UNICENTER01

no ip address

no ip directed-broadcast

duplex full

channel-group 2

!

interface FastEthernet34

description UNICENTER01

no ip address

no ip directed-broadcast

duplex full

channel-group 2

!

interface FastEthernet35

description TNG01

no ip address

no ip directed-broadcast

duplex full

bridge-group 1

bridge-group 1 spanning-disabled

!

interface FastEthernet36

description TNG03

no ip address

no ip directed-broadcast

duplex full

bridge-group 1

bridge-group 1 spanning-disabled

!

interface FastEthernet37

description ITCSUVANTSRV03

no ip address

no ip directed-broadcast

duplex full

bridge-group 1

bridge-group 1 spanning-disabled

!

interface FastEthernet38

description ITCSUVANTSRV01

no ip address

no ip directed-broadcast

duplex full

bridge-group 1

bridge-group 1 spanning-disabled

!

interface FastEthernet39

description NTDC01

no ip address

no ip directed-broadcast

duplex full

channel-group 1

!

interface FastEthernet40

description NTDC01

no ip address

no ip directed-broadcast

duplex full

channel-group 1

!

interface FastEthernet41

description IRDSUVANTSRV01

no ip address

no ip directed-broadcast

duplex full

bridge-group 1

bridge-group 1 spanning-disabled

!

interface FastEthernet42

no ip address

no ip directed-broadcast

shutdown

!

interface FastEthernet43

description EXCHANGE01

no ip address

no ip directed-broadcast

duplex full

channel-group 7

!

interface FastEthernet44

description EXCHANGE01

no ip address

no ip directed-broadcast

duplex full

channel-group 7

!

interface FastEthernet45

description EXCHANGE01

no ip address

no ip directed-broadcast

duplex full

channel-group 7

!

interface FastEthernet46

description EXCHANGE01

no ip address

no ip directed-broadcast

duplex full

channel-group 7

!

interface FastEthernet47

description LINK TO ITC BACKBONE

no ip address

no ip directed-broadcast

duplex full

bridge-group 1

!

interface FastEthernet48

no ip address

no ip directed-broadcast

shutdown

!

interface GigabitEthernet49

no ip address

no ip directed-broadcast

shutdown

!

interface GigabitEthernet50

no ip address

no ip directed-broadcast

shutdown

!

interface BVI1

description GOVNET_85 SUBNET

ip address 10.1.85.19 255.255.255.0

no ip directed-broadcast

no ip route-cache cef

!

interface BVI2

description ITC TEST_87 SUBNET

ip address 10.1.87.1 255.255.255.0

no ip directed-broadcast

no ip route-cache cef

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.1.85.22

ip route 10.1.85.0 255.255.255.0 BVI1

ip route 10.1.87.0 255.255.255.0 BVI2

!

snmp-server community pending64 RO

bridge 1 protocol ieee

bridge 1 route ip

bridge 1 priority 200

bridge 2 protocol ieee

bridge 2 route ip

!

line con 0

transport input none

line aux 0

line vty 0 4

password justdoit

login

!

end

IOS Ver

------------

GOVNET-L3#sho ver

Cisco Internetwork Operating System Software

IOS (tm) L3 Switch/Router Software (CAT2948G-IN-M), Version 12.0(7)WX5(15a) RE

Copyright (c) 1986-2000 by cisco Systems, Inc.

Compiled Thu 06-Jan-00 18:31 by integ

Image text-base: 0x60010928, data-base: 0x605A0000

ROM: System Bootstrap, Version 12.0(7)W5(15) RELEASE SOFTWARE

GOVNET-L3 uptime is 2 minutes

System restarted by power-on at 07:55:17 PST Wed Dec 18 2002

System image file is "bootflash:cat2948g-in-mz.120-7.WX5.15a.bin"

cisco Cat2948G (R5000) processor with 57344K/8192K bytes of memory.

R5000 processor, Implementation 35, Revision 2.1

Last reset from power-on

48 FastEthernet/IEEE 802.3 interface(s)

2 Gigabit Ethernet/IEEE 802.3z interface(s)

121K bytes of non-volatile configuration memory.

16384K bytes of processor board Boot flash (Read/Write)

Configuration register is 0x2101

Cisco Employee

Re: 2948G L3 switch problem

What issues are you having on this switch? Also the software you are running is very old. I suggest that you upgrade to 12.0(18)W5(22b) which has lot of bug fixes compared to 120-7.WX5.15a

http://www.cisco.com/cgi-bin/tablebuild.pl/cat2948g-l3

I suggest that you also read the release notes for any known issues

Bronze

Re: 2948G L3 switch problem

version 12.0(7)WX5(15a) RE - was the first version it was released. You def. need to upgrade to the latest 12.0(18)W5(22b). There are many memory leaks bug and other critical bugs on the version you are running.

111
Views
0
Helpful
4
Replies
CreatePlease to create content