Cisco Support Community
Community Member

[2950-24] Ports disappear from Cluster Manager Java applet

I have two Catalyst 2950-24 switches with software revision "12.1(12c)EA1". The cluster management applet works and shows both devices, but after starting the applet all the ports on the devices disappear from the cluster manager. I can still select a port, and a yellow selection line appears around it, but the port itself and its status-led are not visible.

I have tried several browser/JRE combinations:

Linux/Mozilla 1.4/Sun JDK 1.4.2

Linux/Mozilla 1.4/Sun JDK 1.4.1

Linux/Mozilla 1.4/Blackdown JRE 1.4.1

WinXP/IE 6/Sun JRE 1.4.1

WinXP/IE 6/Sun JRE 1.3.1

All show the same problem.

Also, both switches are approachable thru HTTP on their IP, but the "Web Console" link eventually leads to undefined.htm on all of the above browser/JRE combinations. The cluster management applet is still reachable at http://IP/cluster.html though.

I have not been able to find any other references to my problem (neither here or thru Google), is this a known problem? Or is something wrong with the firmware? What are the recomended actions?

If just 1 switch was showing this problem I would have assumed a bad image on the switch, but since both switches have this problem I am somewhat confused..


Re: [2950-24] Ports disappear from Cluster Manager Java applet

Has this java plugin ever worked before. Guess, you have the right version of plugin required. The following document has good tips to troubleshoot the Cluster Manager.

Troubleshooting Cisco Visual Switch Manager or Cluster Management Suite Access on the Catalyst 2900 XL/3500 XL/2950/3550 Switch


Community Member

Re: [2950-24] Ports disappear from Cluster Manager Java applet

I solved the problem! :)

Apparantly during a previous firmware upgrade, the switch image was updated properly, but the corresponding Java and HTML files where out of sync with that release. I removed the Java and HTML files and did an "archive tar /xtract" with the correct tar-archive, not just the image, and now both switches are fine again.

Thank you for your assistance.

CreatePlease to create content