Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

2950-2950 PAGP 2 port Etherchannel showing stand-alone on one of the ports

Hi. I'm running a 2 port pagp etherchannel between two 2950 switches with 12.1(20)EA1a IOS on them.

Ports 12/13 on switch A connect to 17/9 on switch B (in that order). Both ports are physically connected via UTP-Fibre transceivers.

Previously the ports were configured with separate vlans, and worked fine. The change to a (trucking) etherchannel was made to provide some resiliency in the event that one of the transceivers died.

Now things don't seem to be working as they should. When I do a 'show etherchannel summary' on switch A, it shows the following:

pa2-cisco-2#sh etherchannel summary

Flags: D - down P - in port-channel

I - stand-alone s - suspended

H - Hot-standby (LACP only)

R - Layer3 S - Layer2

u - unsuitable for bundling

U - in use f - failed to allocate aggregator

d - default port

Number of channel-groups in use: 1

Number of aggregators: 1

Group Port-channel Protocol Ports


1 Po1(SU) PAgP Fa0/12(I) Fa0/13(Pd)

The key at the top indicates that Fa0/12 is standalone, and Fa0/13 is in the port-channel and the default port.

Interface stats shows:

Fa0/12 is transmitting, but has received 0 packets

Fa0/13 is transmitting and receiving

'show CDP neighbors' shows that switch B is visible only on Fa0/13.

At the other end, on switch B, I see

CDP only sees switch A on Fa0/9.

Fa0/9 is transmitting and receiving

Fa0/17 is transmitting

etherchannel summary shows: Fa0/9(Pd) Fa0/17(I)

All four ports (ie, both ports on both switches) are configures as follows:

switchport trunk allowed vlan 100-102,225

switchport mode trunk

speed 100

duplex full

channel-group 1 mode desirable

and the portchannel1 interface on both ends is

interface Port-channel1

switchport trunk allowed vlan 100-102,225

switchport mode trunk

flowcontrol send off


I've searched and searched the cisco documentation for a reason why a port would go into standalone mode in a portchannel, but I can only find information saying that 'I' means standalone, and not why a port might be in that state.

Because this is a live environment, I'm not too keen on fiddling with it too mcch. I'm planning to reproduce the scenario with a couple of spare 2950's and see if I get the same result, but if anyone knows why this may be happening, it would certainly save me some time :)


Re: 2950-2950 PAGP 2 port Etherchannel showing stand-alone on on


In the "sh etherchannel summary", the standalone (I flag) status means the ports are UP but not making any channel. It happens due to mis-matching parameters or configuration.

PagP tries to build dynamically the channel buy has no peer "speaking" PagP on the other side. Please configure etherchanel on the other end as well.

New Member

Re: 2950-2950 PAGP 2 port Etherchannel showing stand-alone on on

Reconfigure the port-channel on both switches. Make sure the duplex, and the speed settings matches between switches.

New Member

Re: 2950-2950 PAGP 2 port Etherchannel showing stand-alone on on

It is configured on the other end, as you can see from the configuration in my first post.

In addition, I copied the configs from both switches onto two spare switches last night and connected them up with crossover cables, and it worked first time, so the configuration doesn't appear to be at fault.

I'm going to have to go out there (it's a remote site) and check the FOTs etc. The reason I don't think the FOTs are broken is because before the etherchannel was set up, those same switchports and FOTs were carrying a single VLAN each, and that worked fine. It's possible that something died at the same time that I configured the etherchannel of course.

Thanks anyway.

New Member

Re: 2950-2950 PAGP 2 port Etherchannel showing stand-alone on on

In case anyone's following this and is as confused as I was, I found out what was happening

I thougth the link was physically okay because it had previously been working, but as sherlock holmes says, once you've ruled out the improbable... well, yes, because the switch was offsite, it took a trip out there to sort this out, and once I got there it was trivial - One of the fibres at one end of the circuit wasn't twisted on, and had become disconnected. Normally that would have produced no link light on the switch, but the two FOTs in question seem to hold the link light on the UTP site up at all times. Although there is supposed to be a setting to mirror fibre link status on UTP, it doesn't seem to work.