Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

2950 AND IP PHONES-PC'S DO NOT HAVE CONNECTIVITY

Phones work...PC's don't....Any ideas? I add the PC to a static access port and I can ping everything. Same config on a 3550-24 works fine...weird....Oh, and the "switchport trunk encap dot1q" command is NOT available on this platform...even more weird....

Switch To Phone:

interface FastEthernet0/1

description IP phone and PC

switchport trunk native vlan 7

switchport mode trunk

switchport voice vlan 17

switchport priority extend cos 5

no ip address

!

Switch trunk to router:

interface FastEthernet0/12

description Trunk to 1760 router

switchport trunk native vlan 7

switchport mode trunk

no ip address

Router interface:

!

interface FastEthernet0/0

no ip address

speed auto

!

interface FastEthernet0/0.7

encapsulation dot1Q 7 native

ip address 192.168.7.254 255.255.255.0

!

interface FastEthernet0/0.17

encapsulation dot1Q 17

ip address 192.168.17.254 255.255.255.0

!

1 REPLY
Gold

Re: 2950 AND IP PHONES-PC'S DO NOT HAVE CONNECTIVITY

I have a 2950G-12 which works with IP Phones and PCs. All 10/100 ports are configured as VLAN trunk ports. IP Phones work on the voice VLAN, direct-connected PCs work on the native VLAN, and ports with IP Phones with PCs attached use both. Switch configuration was copied over from the 3524-PWR switches I have in every wiring closet. (This 2950 is the only non-powered one with IP Phones on it.)

I use the same commands as your "Switch to Phone" config on my 10/100 VLAN trunks, except I use "switchport priority extend cos 0" to make sure the inbound voice traffic on a port always gets priority over the PC's data traffic, whenever both an IP Phone and a PC are plugged into it. And I use "spanning-tree portfast" on the 10/100 trunk ports, to go straight from "no link" to forwarding.

I also have 2620 routers set up to do interVLAN routing using subinterfaces. The commands I'm using don't look any different than the ones you're using.

I don't see anything in your configs that sticks out like a sore thumb. What versions of IOS are you using on the router and switch?

As for the switchport encapsulation, if you create a VLAN trunk on a 2950 it's always going to use 802.1Q encapsulation. Cisco Catalyst 2950 Series does not support ISL trunking; and there are no plans to support it on that platform. Since encapsulation choice is not an option, there is no need for a command to specify one.

The Catalyst 3550 switches support both ISL and 802.1Q trunks, for those with a requirement to deploy ISL trunking.

Hope this helps.

93
Views
0
Helpful
1
Replies
CreatePlease to create content