Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

2950 bug spanning tree

Hi,

does anyone have a 2950 with Ios c2950-i6q4l2-mz.121-13.EA1b.bin on it ?

If i try to change the spannig tree priority accept all the value except one .

The command spanning-tree vlan 1 priority 32768 will instead set priority as 49152 !

Thanks,

Patrizio

6 REPLIES
Cisco Employee

Re: 2950 bug spanning tree

Hey there

I don't have the same problem.. I just did a lab recreate:

Switch#sh ver

Cisco Internetwork Operating System Software

IOS (tm) C2950 Software (C2950-I6Q4L2-M), Version 12.1(13)EA1b, RELEASE SOFTWARE (fc1)

Copyright (c) 1986-2003 by cisco Systems, Inc.

Compiled Tue 15-Apr-03 12:25 by yenanh

Image text-base: 0x80010000, data-base: 0x805A8000

ROM: Bootstrap program is CALHOUN boot loader

Switch uptime is 2 minutes

System returned to ROM by power-on

System image file is "flash:/c2950-i6q4l2-mz.121-13.EA1b.bin"

cisco WS-C2950G-48-EI (RC32300) processor (revision C0) with 20839K bytes of memory.

Processor board ID FHK0624W0HS

Last reset from system-reset

Running Enhanced Image

48 FastEthernet/IEEE 802.3 interface(s)

2 Gigabit Ethernet/IEEE 802.3 interface(s)

32K bytes of flash-simulated non-volatile configuration memory.

Base ethernet MAC Address: 00:09:E8:89:4A:40

Motherboard assembly number: 73-7409-08

Power supply part number: 34-0965-01

Motherboard serial number: FOxxxx

Power supply serial number: DAB062143BP

Model revision number: C0

Motherboard revision number: B0

Model number: WS-C2950G-48-EI

System serial number: Fxxxxx

Configuration register is 0xF

Switch#config t

Enter configuration commands, one per line. End with CNTL/Z.

Switch(config)#spanning-tree vlan 1 priority 32768

Switch(config)#end

Switch#sh spanning

00:02:53: %SYS-5-CONFIG_I: Configured from console by console-tree

VLAN0001

Spanning tree enabled protocol ieee

Root ID Priority 32769

Address 0005.7428.1740

Cost 19

Port 24 (FastEthernet0/24)

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)

Address 0009.e889.4a40

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Aging Time 300

Interface Role Sts Cost Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

Fa0/24 Root FWD 19 128.24 P2p

Switch#

Can you show snapshots of your output and config?

LW

Bronze

Re: 2950 bug spanning tree

I ran into a problem on a 6513 when the changes that allow for more vlans were turned on. It takes bits away from the priority field in the bpdu. See if this is turned on and try turning it off.

spanning-tree extend system-id

New Member

Re: 2950 bug spanning tree

Switch2950#show version

Cisco Internetwork Operating System Software

IOS (tm) C2950 Software (C2950-I6Q4L2-M), Version 12.1(13)EA1b, RELEASE SOFTWARE (fc1)

Copyright (c) 1986-2003 by cisco Systems, Inc.

Compiled Tue 15-Apr-03 12:25 by yenanh

Image text-base: 0x80010000, data-base: 0x805A8000

ROM: Bootstrap program is CALHOUN boot loader

Switch2950 uptime is 1 minute

System returned to ROM by power-on

System image file is "flash:c2950-i6q4l2-mz.121-13.EA1b.bin"

cisco WS-C2950-24 (RC32300) processor (revision B0) with 20839K bytes of memory.

Processor board ID FOC0534X11L

Last reset from system-reset

Running Standard Image

24 FastEthernet/IEEE 802.3 interface(s)

32K bytes of flash-simulated non-volatile configuration memory.

Base ethernet MAC Address: 00:07:50:43:EF:C0

Motherboard assembly number: 73-5781-08

Power supply part number: NONE

Motherboard serial number: FOC053400PR

Power supply serial number: DAB05320SC5

Model revision number: B0

Model number: WS-C2950-24

System serial number: FOC0534X11L

Configuration register is 0xF

Switch2950#show running-config

Building configuration...

Current configuration : 7415 bytes

!

version 12.1

no service pad

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug datetime localtime show-timezone

service timestamps log datetime localtime show-timezone

service password-encryption

!

hostname Switch2950

!

logging buffered 8192 notifications

!

clock timezone MET 1

clock summer-time METDST recurring last Sun Mar 2:00 last Sun Oct 3:00

ip subnet-zero

no ip domain-lookup

vtp domain NULL

vtp mode transparent

no cluster run

!

!

spanning-tree mode pvst

spanning-tree loopguard default

spanning-tree portfast default

spanning-tree portfast bpduguard default

spanning-tree portfast bpdufilter default

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

spanning-tree uplinkfast

spanning-tree backbonefast

!

!

vlan 1

tb-vlan1 1002

tb-vlan2 1003

!

vlan 2

name stnet-out

!

vlan 3

name dmz-nat

!

vlan 4

name test

!

vlan 20

name backbone

!

vlan 1002

tb-vlan1 1

tb-vlan2 1003

!

vlan 1003

tb-vlan1 1

tb-vlan2 1002

parent 1005

backupcrf enable

!

vlan 1004

bridge 1

stp type ibm

!

vlan 1005

bridge 1

!

interface FastEthernet0/1 to 0/8 are the same

description -

switchport access vlan 2

switchport trunk native vlan 2

switchport trunk allowed vlan 2-1005

switchport mode access

switchport nonegotiate

no ip address

spanning-tree portfast

!

!

interface FastEthernet0/9 to 0/16 are the same

description -

switchport access vlan 3

switchport trunk native vlan 3

switchport trunk allowed vlan 2-1005

switchport mode access

switchport nonegotiate

no ip address

spanning-tree portfast

!

!

interface FastEthernet0/17 to 0/23 are the same

description -

switchport access vlan 4

switchport trunk native vlan 4

switchport trunk allowed vlan 2-1005

switchport mode access

switchport nonegotiate

no ip address

spanning-tree portfast

!

!

interface FastEthernet0/24

description -

switchport access vlan 20

switchport trunk native vlan 20

switchport trunk allowed vlan 2-1005

switchport mode access

switchport nonegotiate

no ip address

spanning-tree portfast

!

interface Vlan1

no ip address

no ip route-cache

shutdown

!

interface Vlan20

description managment vlan

ip address 172.16.20.7 255.255.255.0

no ip route-cache

!

ip default-gateway 172.16.20.10

no ip http server

!

cdp timer 254

snmp-server engineID local 00000009020000075043EFC0

snmp-server community private RW 7

snmp-server community public RO 7

!

line con 0

exec-timeout 60 0

stopbits 1

line vty 0 4

login

line vty 5 15

login

!

end

Switch2950#sh spanning-tree

VLAN0020

Spanning tree enabled protocol ieee

Root ID Priority 49172

Address 0007.5043.efc0

This bridge is the root

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 49172 (priority 49152 sys-id-ext 20)

Address 0007.5043.efc0

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Aging Time 300

Uplinkfast enabled

Interface Role Sts Cost Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

Fa0/24 Desg FWD 3100 128.24 Edge Shr

Please note the below command , because its the default it does not show on the running-config , but the spanning tree gets as default 49152 .

!

spanning-tree vlan 1 priority 32768

spanning-tree vlan 2 priority 32768

spanning-tree vlan 3 priority 32768

spanning-tree vlan 20 priority 32768

!

Other note my Image is running as Standard Image .

Re: 2950 bug spanning tree

Hi,

49152 is a value which is typically set when you enable UplinkFast on a switch with default STP configuration.

Isn't that your case?

Regards,

Milan

New Member

Re: 2950 bug spanning tree

Yes , but i'm also forcing the priority .

spanning-tree vlan 1 priority 32768

spanning-tree vlan 2 priority 32768

spanning-tree vlan 3 priority 32768

spanning-tree vlan 20 priority 32768

It works for any value , except the one above !

Patrizio

Re: 2950 bug spanning tree

Hi,

are you saying that

spanning-tree vlan 1 priority 32 000 works fine

but

spanning-tree vlan 1 priority 32768

sets the STP priority to 49152?

If yes, I would try to disable UplinkFast and try

spanning-tree vlan 1 priority 32768 again.

It should work correctly.

Then enable UplinkFast. The priority should increase to 49152 (standard UplinkFast feature).

After that try

spanning-tree vlan 1 priority 32768 again.

If the priority remains 49152 I would consider this behaviour as UplinkFast bug and report it to TAC.

Regards,

Milan

234
Views
0
Helpful
6
Replies