Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

2950 IP changing randomly

This is a truly odd situation, I have a 2950 running IOS version 12.1(22)EA4 and I have set up probably hundreds of Layer 2 switches, and I set interface vlan to a static ip within 24 hours it changes itself to a dhcp ip address. I thought someone was messing with me at first so I locked it down hardcore but yet it still changes to dhcp. There are no funky service commands on the switch. Anybody got a clue on this one?

5 REPLIES
Purple

Re: 2950 IP changing randomly

Unless you have some sort of dhcp setup on the switch I don't see how thats possible without intervention . If the switch was setup to pull it address from somewhere else and you had a link go down or soemthing it might pull another address . Maybe if you post the switch config .

Community Member

Re: 2950 IP changing randomly

Sanitized Config as requested:

Current configuration : 1285 bytes

!

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname Beijing-2950

!

enable secret xxxxxxxxxxxxxxxxxxx

!

ip subnet-zero

!

!

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

!

!

!

!

interface FastEthernet0/1

!

interface FastEthernet0/2

!

interface FastEthernet0/3

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface Vlan1

ip address xxx.xx.140.250 255.255.255.0

no ip route-cache

!

ip default-gateway xxx.xx.140.249

ip http server

!

line con 0

password xxxxxxxxxxxx

login

line vty 0 4

password xxxxxxxxxxxx

login

line vty 5 15

password xxxxxxxxxxxxx

login

!

!

end

Purple

Re: 2950 IP changing randomly

Don't see anything there , don't see how it would be possible for it to change . How do you know it is changing ? Someone else would have to know the passwords and manually change it . I see you have "ip http server " enabled , if you don't need it get rid of it .

Community Member

Re: 2950 IP changing randomly

I know it's changing because I monitor it via IP

I have DHCP running on a 3560 and I can see that the IP it is getting is in the scope and bound to this switch. Very funky huh. I am going to upgrade the version of IOS and see if that fixes it. If not I am swapping that switch out. Thanks for sanity check.

-Ken

Community Member

Re: 2950 IP changing randomly

Code upgrade fixed this situation in case anyone is curious.

120
Views
0
Helpful
5
Replies
CreatePlease to create content