Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

2950 Layer 2 problem

Hello! I'm trying to replace a Windows Server using a 2821 router.

INITIAL SITUATION

Server --- 2950 --- router

- Server: 10.0.6.230/24

- Router: 10.0.6.10/24

- The router interface can be pinged from the server

FINAL SITUATION

2821 --- 2950 --- router

- 2821 int vlan200: 10.0.6.230/24

- 2821 int fa1/15: no ip address, switchport access vlan 200

- Router: 10.0.6.10/24

- The router interface can't be pinged from the 2821

WHAT I HAVE SEEN DURING THE PROBLEM

The physical layer link to the switch seems ok.

I can see the 2950 switch with a "sh cdp neighbors"

I can see the router's mac in vlan200 with a "show arp"

I think the problem could be related to the 2950 arp or mac-address table but I can't access the 2950 nor the remote router.

Any idea of what is going on? Thanks!!

4 REPLIES
Silver

Re: 2950 Layer 2 problem

Hi ,

Can you paste the config of 2821 and router..Is there anything configured on 2950 switch...

Thanks,

Satish

New Member

Re: 2950 Layer 2 problem

Hello, I don't manage the 2950 switch nor the remote router. I can only check the 2821 and I think everything is ok in my configuration.

This is the config in the 2821:

version 12.4

!

ip cef

!

interface GigabitEthernet0/0

ip address 192.168.0.1 255.255.255.0

!

interface FastEthernet1/15

switchport access vlan 200

!

interface GigabitEthernet1/0

switchport access vlan 100

!

interface Vlan100

ip address 172.16.0.3 255.255.255.192

ip virtual-reassembly

!

interface Vlan200

ip address 10.0.6.230 255.255.255.0

ip virtual-reassembly

!

ip route 0.0.0.0 0.0.0.0 172.16.0.1

ip route 10.0.0.0 255.0.0.0 10.0.6.10

New Member

Re: 2950 Layer 2 problem

Can you do an extended ping from the fa1/15 interface? For extended ping type ping on the command prompt. for Extended commands answer "y" and then give the source interface as FastEthernet1/15.example shown below. Please do tell us the result.

ping

Protocol [ip]:

Target IP address: 10.0.6.10

Repeat count [5]:

Datagram size [100]:

Timeout in seconds [2]:

Extended commands [n]: y

Source address or interface: FastEthernet1/15

Type of service [0]:

Set DF bit in IP header? [no]:

Validate reply data? [no]:

Data pattern [0xABCD]:

Loose, Strict, Record, Timestamp, Verbose[none]:

Sweep range of sizes [n]:

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.0.6.10, timeou

Packet sent with a ...

New Member

Re: 2950 Layer 2 problem

I will try the change again on monday so I will make this test then.

I'm thinking about sticky ARP in the 2950 would be likely to cause this problem... will let you know after monday.

Thanks

121
Views
0
Helpful
4
Replies