Cisco Support Community
Community Member

2950 QoS question


Colleagues, I'm trying to apply QOS features on catalyst 2950 with 12.1(6)EA2 IOS. I want to limit bandwith allocated to one PC1 to 1Mb/s.

The network is like this:

PC1 ( -- (fe0/1) 2950 (fe0/2) -- PC2 (

Switch configuration:


access-list 100 permit ip host any


class-map match-all TEST

match access-group 100


policy-map TEST

class TEST

police 1000000 4096 exceed-action frop


interface FastEthernet0/1

switchport access vlan 100

service-policy input TEST


interface FastEthernet0/2

switchport access vlan 100


After this I'm trying to upload data thought ftp from PC1 to PC2.

Without any policy on FE0/1 the data downloaded with speed around 8Mb/s.

But when I apply TEST policy to FE0/1 the speed of connection is decreased to some bytes per second. In the TEST policy I limit bandwith to 1Mb/s, not

to some bytes per second. So QOS is not working? Or I'm wrong in my configuration?

Thank you for advance.


Re: 2950 QoS question


In the command police rate-bps burst-byte [exceed-action {drop | dscp dscp-value}]. For rate-bps, specify average traffic rate in bits per second (bps). The range is 1 Mbps to 100 Mbps for 10/100 Ethernet ports and 8 Mbps to 1000 Mbps for the Gigabit-capable Ethernet ports. Since the range starts with 1 Mbps it is strange as to how the speed could be decreased to some bytes.

The command in the output is police 1000000 4096 exceed-action frop, check the spelling it is police 1000000 4096 exceed-action drop.

This doc might help:

Community Member

Re: 2950 QoS question


I'm already read this doc.

Beside this I tryed to increase traffic limit to 2 Mbps

(police 2000000 4096 exceed-action drop) and this not worked also.

Of course 'frop' is my typing error.

CreatePlease to create content