Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

2950 vlans

I have a 2950 with advanced Ip services ios. From what I hear, I cannot use any vlan routing whatsoever on this switch. I can only activate one vlan at a time and that it is only for management. What I want to do is have all workstations on 10.1.2.0 addresses, all phones on 10.1.3.0, and all servers one 10.1.4.0. I have my two DNS servers as 10.1.4.5 and .6. All of my ports are currently on VLAN1 and VLAN1 is configured with 10.1.2.2 255.255.255.0 The only other thing specified for the VLAN is no ip-route cache. If I give my workstation a 10.1.4 address, I can ping my router, the 10.1.4. dns servers, etc. If I give it a 10.1.2.0 or 10.1.3.0 address, I cannot hit anything. Is there a way that I can make this work? My configs are

1841 ROUTER

interface FastEthernet0/1

description Workstation IP

ip address 10.1.2.1 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1.1

description Voice IP

encapsulation dot1Q 2

ip address 10.1.3.1 255.255.255.0

no snmp trap link-status

!

interface FastEthernet0/1.2

description Server IP

encapsulation dot1Q 1 native

ip address 10.1.4.1 255.255.255.0

no snmp trap link-status

!

ip classless

2950 SWITCH

interface Vlan1

ip address 10.1.2.2 255.255.255.0

no ip route-cache

!

ip http server

1 ACCEPTED SOLUTION

Accepted Solutions
Purple

Re: 2950 vlans

The first thing is to change is the switch default gateway , that has to be pointed to 10.1.2.1 not 10.1.4 . That is for management of the switch only. On the 2950 on f0/48 add "switchport trunk native vlan 1" . Once you do this check the trunk status on the 2950 with the "show int trunk" command and make sure it is up . If not then you won't be able to route anywhere . See if you can ping your addresses. Start with pinging your router interfaces for vlan 1 ,2 and 3 . On your router make sure you have routes with the show ip route" command , should all show as connected routes. When pinging from your workstation on vlan 3 make sure your address matches the vlan 3 address range and your default gateway is pointed at the vlan3 "router address" .

10 REPLIES
Purple

Re: 2950 vlans

This should help you out , short of me typing it all out . Pay attention to the trunking on the 2950 , looks like you don't have any of the trunking parameters on the 2950 setup.

http://www.cisco.com/en/US/tech/tk389/tk390/technologies_configuration_example09186a00800949fd.shtml

New Member

Re: 2950 vlans

Actually - I did... I still read over that manual and made a few small changes in accordance to native vlan. I think both are on native vlan1 now. I still cannot ping any 10.1.4 servers if I have a 10.1.2 address :(

Here is my trunk config on the switch:

interface FastEthernet0/48

Description TRUNK

switchport mode trunk

spanning-tree portfast

What am I missing?

Thanks again!

New Member

Re: 2950 vlans

Also, in the guide near the top of the configs it shows us adding items to VLAN1 (which is default) and then to VLAN2??? Where did that come from? I just thought I finished reading that the 2950 could only have 1 VLAN active at a time. Read below:

!-- The following set of commands will place FastEthernet 0/2

!-- into VLAN2 and enable portfast on the interface.

3512xl(config)#int fastEthernet 0/2

3512xl(config-if)#switchport access vlan 2

3512xl(config-if)#spanning-tree portfast

3512xl(config-if)#exit

Purple

Re: 2950 vlans

Your confusion comes from that you can add up to 64 vlans on a 2950 , these are layer2 vlans that are applied to the ports . You can only have 1 layer 3 SVI with an ip address on it to manage the switch " interface vlan XX" . Do a show vlan on 2950 and make sure all your vlans show up and active and your ports are in the vlans you want them in . Also on the router try putting your ip address 10.1.2.1 255.255.255.0 on its own subinterface on f0/0 and determine what vlan you want this address in . You need to define each of your interfaces on the router as what vlan you want those address ranges to be in with the encapsulation dot1q X where "X" is the vlan number. If the 10.1.2 range is supposed to be vlan 1 then you'll have to assign the 10.1.4 range to a different vlan .

New Member

Re: 2950 vlans

I agree with Glen. Probably the best way to approach this is to place 10.1.2.1/24 into its own sub int and encap dot1q. You won't be able to route between 10.1.2.x and 10.1.4.x as long as one of them is encap dot1q to vlan 1 and the other is on the same vlan 1 (at least on the switch).

New Member

Re: 2950 vlans

1841 ROUTER

interface FastEthernet0/1.1

description Workstation IP

encapsulation dot1Q 1

ip address 10.1.2.1 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1.2

description Voice IP

encapsulation dot1Q 2

ip address 10.1.3.1 255.255.255.0

no snmp trap link-status

!

interface FastEthernet0/1.3

description Server IP

encapsulation dot1Q 3

ip address 10.1.4.1 255.255.255.0

no snmp trap link-status

2950 SWITCH

switch#config t

switch(config)#vlan 2

switch(config)#vlan 3

in workstation ports.. dont do any changes.

in voice ip switchports

interface FastEthernet0/x

switchport mode access

switchport access vlan 2

in server ports

interface FastEthernet0/x

switchport mode access

switchport access vlan 3

This should help...

Regards,

Naveen B

New Member

Re: 2950 vlans

Alright, here's the skinny.. still cannot ping 10.1.4 addresses (my two dns servers or anything else) if I am plugged into the switch in eth0/30 that I have configured for vlan 1, 2, and 3 and given the corresponding IP address depending on what vlan I had port 30 on... still nothing. I am attaching the new configs: Thanks again for all of your expert advice!

Purple

Re: 2950 vlans

The first thing is to change is the switch default gateway , that has to be pointed to 10.1.2.1 not 10.1.4 . That is for management of the switch only. On the 2950 on f0/48 add "switchport trunk native vlan 1" . Once you do this check the trunk status on the 2950 with the "show int trunk" command and make sure it is up . If not then you won't be able to route anywhere . See if you can ping your addresses. Start with pinging your router interfaces for vlan 1 ,2 and 3 . On your router make sure you have routes with the show ip route" command , should all show as connected routes. When pinging from your workstation on vlan 3 make sure your address matches the vlan 3 address range and your default gateway is pointed at the vlan3 "router address" .

New Member

Re: 2950 vlans

That worked perfectly! As soon as I hooked up a workstation in vlan 2 (created all new vlans aside from the default management 1 vlan) and put the dns servers into vlan 4, they came right up and was able to ping everything! I have been adding other items to different vlans and all seems well. One last question... the only svi that is configured on the switch is 10.1.2.2 255.255.255.0 and it is not shutdown. I cannot ping or telnet to it anymore and used to be able to. Please keep in mind that the vlan 2 is the 10.1.2.0 workstation range with the router interface being 10.1.2.1 Thanks again for your great help!

Purple

Re: 2950 vlans

On your 2950 make sure your SVI is in vlan 2 , in your previous config you had it in vlan 1 and your default gateway is pointed at the vlan 2 "router" address , in your previos config you had the gateway pointed at 10.1.4 not 10.1.2 . It has to be in vlan 2 now because it is your uplink is a trunked link .

300
Views
0
Helpful
10
Replies