Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

3524xl only vlan 1 ports work

Hello,

I have a 3524xl switch (IOS 12.0-5WC5) which worked well until today.

All ports belong to a vlan (switchport access vlan xx) except port number 8 which uses just vlan 1.

All the non vlan 1 stopped working (leds off),

sh interfaces says:

FastEthernet0/4 is down, line protocol is down

Port config sample:

interface FastEthernet0/1

description xxx

switchport access vlan 200

spanning-tree portfast

Any help would be appreciated

3 REPLIES
New Member

Re: 3524xl only vlan 1 ports work

I am assuming you have tried reloading? And are you sure that you don't have some other problem (like all of the devices plugged into it are turned off because someone tripped a breaker or something!)

New Member

Re: 3524xl only vlan 1 ports work

have you recently plugged any of those ports into another switch, because if portfast was enabled then it would bring the Vlan down.

below an extract to look out for:

BPDU port-guard: Version 5.4(1) of CatOS software can monitor whether portfast is enabled on a port. A port using portfast should be connected to an end station, not to devices that generate STP packets called bridge port data units (BPDUs). If the switch notices a BPDU coming into a port that has portfast enabled, it will put the port in errDisable mode.

New Member

Re: 3524xl only vlan 1 ports work

Thanks for your answers,

I've solved it!

The problem was at the Layer3 device to which this switch is connected to.

It's a 3550 Multilayer Switch. Somehow (if you have any clues about this please let me know) this switch lost some entries at its vlan database.

Restoring these entries using this commands:

vlan database

vlan 1

vlan 2

vlan 4

vlan 6

....

solved the problem.

Thanks again

86
Views
5
Helpful
3
Replies
CreatePlease to create content