Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

3550 -> 3750 problem. Fiber type or configuration?

I'm having trouble with a link that was working with a 3600 as an end device, but won't work when replaced with a stack of 3750 switches. A couple of co-workers in our group has looked at it, but can't find anything obvious.

The path is from a 6500 on multimode trunked fiber to a converter to single mode fiber, (then under the street) to a 3550 Long Haul Gbic. Then we took copper from the 3550 to a 3660 10/half(?). To this point it used to work. We pulled the 3600 and put in a 3750 stack, and configured the copper port on the 3550 to 100/full, and the same on the 3750. The problem is that we can go to the middle device and then ping and telnet both ways from there. But we cannot go from the 6513 through the 3550 to the 3750. I turned debug icmp on the 3550, and it's not seeing anything from the 3750 when I try to go to the gateway.

Both swiches have the default gateway pointing back to the HSRP Vlan VIP of the 6513. CDP is seeing its neighbors. All interfaces seem to be up/up. Here are the snippets of configs for all ports. Maybe someone can see something I'm missing? The only thing I can think could be a mismatch somewhere between the switches, or the multimode to single mode fiber is not translating.

6513:

interface GigabitEthernet1/23

description To Building E

no ip address

udld port aggressive

switchport

switchport trunk encapsulation dot1q

3550 from 6500

interface GigabitEthernet0/1

switchport mode dynamic desirable

3550 out to 3750:

interface FastEthernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

speed 100

duplex full

3750 stack:

interface FastEthernet5/0/1

switchport trunk encapsulation dot1q

switchport mode trunk

duplex full

speed 100

Any direction would be most appreciated.

Thanks,

Jim

2 REPLIES
Silver

Re: 3550 -> 3750 problem. Fiber type or configuration?

Does the IP addresses configured on the device belong to same vlan? If not, you will have to enable inter vlan routing. This is the common reason why intermediate devices are not pinging.

Re: 3550 -> 3750 problem. Fiber type or configuration?

I can't say the configuration is eithre good or not as it does not really show a lot. As far as L2 configuration they seem okay as all the ports are configured for trunking, however, the trunk port between 3550 and 3750 looks like the are "forced" to turnk with the mode trunk. are the vlans in forwarding mode in both sides (show int trunk). What happens when the port between 3550 and 3750 are in desirable mode, does it build the trunk? More important questions is what ip address are you pinging on the 3750? What vlan should it belong to?

Maybe you can post the following:

1. ping from 6513 to the 3550.

2. ping from 6513 to the 3750.

I want to keep it short so might have some question after seeing the above outputs.

129
Views
0
Helpful
2
Replies