Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

3550<->26xx Comm problems

I've got a 3550 connected directly to a 2610, a 2611 and many PC servers. The routers direct traffic from two different ISP's to my servers. The servers each have a default route to one of the routers, and each router NATs the internal addresses to the appropriate ISP's public IPs.

The servers provide streaming data to the logged in users via consistent TCP connections, i.e. these are not WWW servers which have many opening and closing connections. These are proprietary servers that have a constant connection via a single TCP port to any particular user until that user logs off. The traffic to any given user may not be as constant as an FTP transfer, but it is steady.

Lately we're seeing a lot more "lost" connections, and I suspect the switch-router links because those port LEDs are flashing alternating green-amber which, according to the switch's manual, is an indication of a "Link fault", i.e excessive collisions, CRC errors, etc.

Here is some of the pertinent info:

3550# show run

interface FastEthernet0/32

switchport access vlan 2

switchport mode access

no ip address

duplex half

speed 10

spanning-tree portfast

interface FastEthernet0/48

switchport access vlan 2

switchport mode access

no ip address

spanning-tree portfast

!

interface Vlan2

ip address 192.168.2.1 255.255.255.0

3550# show int f0/32

FastEthernet0/32 is up, line protocol is up (connected)

Hardware is Fast Ethernet, address is 000c.3018.1da0 (bia 000c.3018.1da0)

MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,

reliability 255/255, txload 2/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Half-duplex, 10Mb/s

input flow-control is off, output flow-control is off

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:54, output 00:00:00, output hang never

Last clearing of "show interface" counters 01:17:11

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue :0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 105000 bits/sec, 49 packets/sec

560233 packets input, 39244907 bytes, 0 no buffer

Received 1087 broadcasts, 16044 runts, 0 giants, 0 throttles

16044 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 1087 multicast, 0 pause input

0 input packets with dribble condition detected

709506 packets output, 186026478 bytes, 57 underruns

0 output errors, 11040 collisions, 0 interface resets

0 babbles, 0 late collision, 9401 deferred

0 lost carrier, 0 no carrier, 0 PAUSE output

57 output buffer failures, 0 output buffers swapped out

2610# sh run

interface Ethernet0/0

description Connected to Aspen LAN

ip address 192.168.2.2 255.255.255.0

no ip directed-broadcast

ip nat inside

!

2610#sh int e0/0

Ethernet0/0 is up, line protocol is up

Hardware is AmdP2, address is 0003.6b7d.d1e0 (bia 0003.6b7d.d1e0)

Description: Connected to Aspen LAN

Internet address is 192.168.2.2/24

MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,

reliability 255/255, txload 1/255, rxload 3/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:00, output 00:00:00, output hang never

Last clearing of "show interface" counters 01:18:05

Queueing strategy: fifo

Output queue 0/40, 0 drops; input queue 0/75, 0 drops

5 minute input rate 128000 bits/sec, 71 packets/sec

5 minute output rate 34000 bits/sec, 70 packets/sec

709291 packets input, 183629749 bytes, 0 no buffer

Received 1957 broadcasts, 0 runts, 0 giants, 0 throttles

290 input errors, 0 CRC, 0 frame, 0 overrun, 290 ignored

0 input packets with dribble condition detected

564230 packets output, 34548558 bytes, 0 underruns

0 output errors, 16110 collisions, 0 interface resets

0 babbles, 0 late collision, 18958 deferred

0 lost carrier, 0 no carrier

0 output buffer failures, 0 output buffers swapped out

As you can see, this info is about 1:20 after clearing the interface counters. Prior to that, I had "25351 underruns" and "25351 output buffer failures" on the 3550, which was several weeks worth of data. In the 15 minutes of composing this message, the underruns have not increased.

I'm also concerned about the 3550's 5 minute input rate "0 bits/sec, 0 packets/sec". This link is never supposed to be not receiving data, especially since the 2610 shows "5 minute output rate 34000 bits/sec, 70 packets/sec" at essentially the same time.

The 2610 and 2611 are not 10/100 capable, so they are permanently 10/half. There do not seem to be any speed/duplex conflicts, but the speeds indicated are far below the 10Mbps threshold, and are ususally less than 1Mbps.

Are there any obvious errors with my config?

Can some one tell me why there are/were so many 3550 underruns?

I'm wondering if the 3550 is overwhelming the two routers or their links, and would a new 26xxXM relieve the symptoms.

Any other help appreciated.

Tim

2 REPLIES

Re: 3550<->26xx Comm problems

Hi,

A few options popped up reading your description.

1- Amber LEDs can also indicate that a port is spantree-blocking. Is that possible in your configuration? Do a -sh spanning-tree-

2- You might have a routing loop over your two Internet links.

A 26xx-XM will not resolve these issues. It must be something else.

3- The most secure way to prevent speed/duplex mismatches is to use auto-config on all 10/100-capable ports. You do not need to fix these settings.

Regards,

Leo

New Member

Re: 3550<->26xx Comm problems

According to the docs,

"Alternating green-amber - Link fault." i.e. errors, etc

"flashing amber - Port is blocked by STP"

I'm definately alternating gree-amber, so I don't think that's it. Also, isn't spanning tree blocked by a router (unless, perhaps, the router is specifically configured to pass it through)?

Also, the network architecture shouldn't present a possibility of a loop. But, since you asked:

3550-GWS-ARG# sh span

VLAN0001

Spanning tree enabled protocol ieee

Root ID Priority 32768

Address 0003.e359.a780

Cost 19

Port 1 (FastEthernet0/1)

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)

Address 000c.3018.1d80

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Aging Time 300

Interface Role Sts Cost Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

Fa0/1 Root FWD 19 128.1 P2p

VLAN0002

Spanning tree enabled protocol ieee

Root ID Priority 32770

Address 000c.3018.1d80

This bridge is the root

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32770 (priority 32768 sys-id-ext 2)

Address 000c.3018.1d80

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Aging Time 300

Interface Role Sts Cost Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

Fa0/1 Desg FWD 19 128.1 P2p

Fa0/17 Desg FWD 19 128.17 Edge P2p

Fa0/18 Desg FWD 19 128.18 Edge P2p

Fa0/19 Desg FWD 19 128.19 Edge P2p

Fa0/20 Desg FWD 19 128.20 Edge P2p

Fa0/21 Desg FWD 19 128.21 Edge P2p

Fa0/22 Desg FWD 19 128.22 Edge P2p

Fa0/23 Desg FWD 19 128.23 Edge P2p

Fa0/25 Desg FWD 19 128.25 Edge P2p

Fa0/26 Desg FWD 19 128.26 Edge P2p

Fa0/27 Desg FWD 100 128.27 Edge Shr

Fa0/28 Desg FWD 100 128.28 Edge Shr

Fa0/29 Desg FWD 19 128.29 Edge P2p

Fa0/32 Desg FWD 100 128.32 Edge Shr

Fa0/33 Desg FWD 19 128.33 Edge P2p

Fa0/34 Desg FWD 19 128.34 Edge P2p

Fa0/35 Desg FWD 19 128.35 Edge P2p

Fa0/36 Desg FWD 19 128.36 Edge P2p

Fa0/37 Desg FWD 19 128.37 Edge P2p

Fa0/38 Desg FWD 19 128.38 Edge P2p

Fa0/39 Desg FWD 19 128.39 Edge P2p

Fa0/41 Desg FWD 19 128.41 Edge P2p

Fa0/42 Desg FWD 19 128.42 Edge P2p

Fa0/43 Desg FWD 19 128.43 Edge P2p

Fa0/45 Desg FWD 19 128.45 Edge P2p

Fa0/48 Desg FWD 100 128.48 Edge Shr

VLAN0050

Spanning tree enabled protocol ieee

Root ID Priority 32768

Address 0003.e359.a781

Cost 19

Port 1 (FastEthernet0/1)

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32818 (priority 32768 sys-id-ext 50)

Address 000c.3018.1d80

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Aging Time 300

Interface Role Sts Cost Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

Fa0/1 Root FWD 19 128.1 P2p

Fa0/2 Desg FWD 19 128.2 P2p

I'll have to do some reading to figure out what it's telling me.

Tim

95
Views
5
Helpful
2
Replies
CreatePlease to create content