Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

3550 QoS, no remarking of packets down to DSCP 8

Hi,

I have created a QoS policy on a 100Mbps FE interface for an IP Phone and PC which will police traffic to cetain thresholds, any traffic over the configured limits will be marked down to scavenger class (DSCP 8).

How can I best load the interface so that it becomes congested so that I can verify that the excess traffic which has violated my policed limits has been marked down? I have managed to load the interface to 90Mbps by downloading 40Gb from a file server but don't wish to break anything as this test is on a live network.

When looking at the relevant interface mls qos statistics I don't see any traffic within the

DSCP 8 queue which would suggest that the excess traffic has been marked down to scavenger class.

Please see the relevant config below.

Thanks,

mls qos map policed-dscp 0 10 18 24 25 34 to 8

mls qos map cos-dscp 0 8 16 24 32 46 48 56

class-map match-all VOICE

match ip dscp ef

class-map match-any CALL-SIGNALING

match ip dscp cs3

class-map match-all MISSION-CRITICAL-DATA

match access-group name MISSION-CRITICAL-DATA

class-map match-all TRANSACTIONAL-DATA

match access-group name TRANSACTIONAL-DATA

class-map match-all BULK-DATA

match access-group name BULK-DATA

class-map match-all ANY

match access-group name ANY

class-map match-all VVLAN-VOICE

match vlan 10

match class-map VOICE

class-map match-all VVLAN-CALL-SIGNALING

match vlan 10

match class-map CALL-SIGNALING

class-map match-all VVLAN-ANY

match vlan 10

match class-map ANY

class-map match-all DVLAN-MISSION-CRITICAL-DATA

match vlan 3

match class-map MISSION-CRITICAL-DATA

class-map match-all DVLAN-TRANSACTIONAL-DATA

match vlan 3

match class-map TRANSACTIONAL-DATA

class-map match-all DVLAN-BULK-DATA

match vlan 3

match class-map BULK-DATA

class-map match-all DVLAN-ANY

match vlan 3

match class-map ANY

policy-map IPPHONE+PC-ADVANCED

class VVLAN-VOICE

set dscp ef

police 128000 8000 exceed-action drop

class VVLAN-CALL-SIGNALING

set dscp cs3

police 32000 8000 exceed-action policed-dscp-transmit

class VVLAN-ANY

set dscp default

police 32000 8000 exceed-action policed-dscp-transmit

class DVLAN-MISSION-CRITICAL-DATA

set dscp 25

police 5000000 8000 exceed-action policed-dscp-transmit

class DVLAN-TRANSACTIONAL-DATA

set dscp af21

police 5000000 8000 exceed-action policed-dscp-transmit

class DVLAN-BULK-DATA

set dscp af11

police 5000000 8000 exceed-action policed-dscp-transmit

class DVLAN-ANY

set dscp default

police 5000000 8000 exceed-action policed-dscp-transmit

interface FastEthernet0/1

description ****** IP PHONE

switchport access vlan 3

switchport mode access

switchport voice vlan 10

switchport port-security maximum 3

service-policy input IPPHONE+PC-ADVANCED

load-interval 30

mls qos trust device cisco-phone

mls qos monitor dscp 0 8 16 24 32 46 48 56

auto qos voip cisco-phone

wrr-queue bandwidth 5 25 70 1

wrr-queue min-reserve 1 5

wrr-queue min-reserve 2 6

wrr-queue min-reserve 3 7

wrr-queue min-reserve 4 8

wrr-queue cos-map 1 1

wrr-queue cos-map 2 0

wrr-queue cos-map 3 2 3 4 6 7

wrr-queue cos-map 4 5

priority-queue out

2 REPLIES

Re: 3550 QoS, no remarking of packets down to DSCP 8

Why would you see it here when the policy is applied to ingress on this interface. Would it not get policed and marked after it has gone through the policy? so, the re-marked should be on egress, correct?

New Member

Re: 3550 QoS, no remarking of packets down to DSCP 8

Bosalaza,

You are correct in your statement as classification takes places prior to any marking and then the policing of packets, if any has been defined. My thought process is that I would expect to see any traffic outside of the policed limits to be remarked down accordingly to the specified dscp, that of DSCP 8 (Scavenger) Please see below

3550-009#sh mls qos int f0/1 statistics

FastEthernet0/1

Ingress

dscp: incoming no_change classified policed dropped (in bytes)

0 : 805383534 803023977 0 354313304 0

8 : 0 0 0 0 0

16: 0 0 0 0 0

24: 469504 469504 0 0 0

32: 0 0 0 0 0

46: 3541846 3541846 0 0 0

48: 0 0 0 0 0

56: 0 0 0 0 0

Others: 0 1308 2358249 11862 0

Egress

dscp: incoming no_change classified policed dropped (in bytes)

0 : 1746735339 n/a n/a 0 0

8 : 0 n/a n/a 0 0

16: 0 n/a n/a 0 0

24: 318728 n/a n/a 0 0

32: 0 n/a n/a 0 0

46: 3541846 n/a n/a 0 0

48: 13353894 n/a n/a 0 0

56: 10506653 n/a n/a 0 0

Others: 0 n/a n/a 0 0

As can be seen from above traffic has been policed at DSCP 0, default but not remarked to DSCP 8?

Any ideas? anybody!! : o )

265
Views
0
Helpful
2
Replies