Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

Hall of Fame Super Silver

3560 QoS Issues

I have 5 3560 switches for which I've applied the same configuration, I noticed that 2 of the 5 switches accepted "service-policy input VoIP" to the switchports. I compared the IOS version and config and it's exaclty the same. Below is the config. Any ideas?

hostname OAG_FabShop_S01

!

clock timezone EST -5

clock summer-time EDT recurring

ip subnet-zero

!

no ip domain-lookup

mls qos map policed-dscp 0 24 to 8

mls qos map cos-dscp 0 8 16 24 32 46 48 56

mls qos srr-queue output cos-map queue 1 threshold 3 5

mls qos srr-queue output cos-map queue 2 threshold 1 2 4

mls qos srr-queue output cos-map queue 2 threshold 2 3

mls qos srr-queue output cos-map queue 2 threshold 3 6 7

mls qos srr-queue output cos-map queue 3 threshold 3 0

mls qos srr-queue output cos-map queue 4 threshold 3 1

mls qos srr-queue output dscp-map queue 1 threshold 3 46

mls qos srr-queue output dscp-map queue 2 threshold 1 16 18 20 22 25 32 34 36

mls qos srr-queue output dscp-map queue 2 threshold 1 38

mls qos srr-queue output dscp-map queue 2 threshold 2 24 26

mls qos srr-queue output dscp-map queue 2 threshold 3 48 56

mls qos srr-queue output dscp-map queue 3 threshold 3 0

mls qos srr-queue output dscp-map queue 4 threshold 1 8

mls qos srr-queue output dscp-map queue 4 threshold 3 10 12 14

mls qos queue-set output 1 threshold 2 400 400 100 400

mls qos queue-set output 1 buffers 15 45 20 20

mls qos

!

class-map match-any VVLAN-CALL-SIGNALING

match access-group name VVLAN-CALL-SIGNALING

match access-group name VVLAN-CTI

class-map match-all VVLAN-VOICE

match access-group name VVLAN-VOICE

class-map match-all VVLAN-ANY

match access-group name VVLAN-ANY

!

!

policy-map VoIP

class VVLAN-VOICE

set ip dscp 46

police 128000 8000 exceed-action drop

class VVLAN-CALL-SIGNALING

set ip dscp 24

police 128000 8000 exceed-action policed-dscp-transmit

class VVLAN-ANY

set ip dscp 0

police 32000 8000 exceed-action policed-dscp-transmit

class class-default

set ip dscp 0

police 5000000 8000 exceed-action policed-dscp-transmit

!

!

!

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

spanning-tree vlan 1-4094 priority 24576

!

!

interface FastEthernet0/1

description Host Port

switchport access vlan 17

switchport mode access

switchport voice vlan 7

no ip address

srr-queue bandwidth share 1 25 70 5

srr-queue bandwidth shape 3 0 0 0

priority-queue out

no mdix auto

spanning-tree portfast

!

interface FastEthernet0/2

description Host Port

switchport access vlan 17

switchport mode access

switchport voice vlan 7

no ip address

srr-queue bandwidth share 1 25 70 5

srr-queue bandwidth shape 3 0 0 0

priority-queue out

no mdix auto

spanning-tree portfast

!

interface Vlan1

no ip address

!

interface Vlan16

ip address 10.x.x.x 255.255.255.128

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.x.x.x

no ip http server

!

ip access-list extended VVLAN-ANY

permit ip 10.31.55.0 0.0.0.255 any

ip access-list extended VVLAN-CALL-SIGNALING

permit tcp 10.31.55.0 0.0.0.255 any range 2000 2002

ip access-list extended VVLAN-CTI

permit tcp any host 10.50.140.71 eq 42027

permit tcp any host 10.150.140.71 eq 43027

ip access-list extended VVLAN-VOICE

permit udp 10.31.55.0 0.0.0.255 any range 16384 32767

!

Chris

3 REPLIES
Purple

Re: 3560 QoS Issues

Hi Chris,

What error does the switch give when you enter the command ?

Thanks,

Paresh

Hall of Fame Super Silver

Re: 3560 QoS Issues

I get no errors, the command appears to be going through, but when I do sh run it is not applied.

Chris

Re: 3560 QoS Issues

The only time I have seen similar behaviour is with the Catalyst 3550 and applying both the 'mls qos trust device' command and an inbound service-policy. The CLI would accept both commands but the service-policy was removed when the switch was reloaded.

Obviously both commands shouldn't be applied at the same time as they are sort of mutually exclusive.

I would suggest updating to the latest IOS code, if this doesn't help try a write erase (delete the vlan.data as well), reload and paste the config back in.

HTH

Andy

108
Views
0
Helpful
3
Replies