Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

3560 switchport amber/green alternating

Just wanted to through this out there to see if anyone else had experienced this. I have a switchport on a 3560 connected to a 2651XM router via dot1q trunk protocal. The switchport is alternating back and forth between green and amber. I have turned off online power to the switch port and the port went to green for about 10 seconds and then resumed the green/amber alternating state. If anyone has run accross this and could shed any light that would be great. Thanks

7 REPLIES
Hall of Fame Super Bronze

Re: 3560 switchport amber/green alternating

Jason,

The port is showing any errors ?

Can we see the config from both devices ?

New Member

Re: 3560 switchport amber/green alternating

Here is the router's switch port.

interface FastEthernet0/0

no ip address

speed 100

full-duplex

!

interface FastEthernet0/0.1

description Charles Barker Data VLAN

encapsulation dot1Q 1 native

ip address 198.42.110.240 255.255.255.0

ip pim sparse-dense-mode

!

interface FastEthernet0/0.2

description Charles Barker CCM VLAN

encapsulation dot1Q 2

ip address 206.95.149.114 255.255.255.248

ip pim sparse-dense-mode

no cdp enable

!

interface FastEthernet0/0.3

description Connection to IPT Phone VLAN

encapsulation dot1Q 3

ip address 1.5.145.254 255.255.255.0

ip helper-address 206.95.149.115

ip pim sparse-dense-mode

*******************************

Switchport

interface FastEthernet0/3

description Connection to r2.vabeach-toy.charlesbarker fa00 (VLAN 1 VLAN 2 and VLAN 3) (Cisco 2651)

switchport trunk encapsulation dot1q

switchport mode trunk

no ip address

duplex full

speed 100

priority-queue out

no mdix auto

power inline never

end

s3.vabeach-toy.charlesbarker#sho int fa0/3

FastEthernet0/3 is up, line protocol is up (connected)

Hardware is Fast Ethernet, address is 0011.2122.9985 (bia 0011.2122.9985)

Description: Connection to r2.vabeach-toy.charlesbarker fa00 (VLAN 1 VLAN 2 and VLAN 3) (Cisco 2651)

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 100Mb/s

input flow-control is off, output flow-control is off

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:39, output 00:00:01, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 295000 bits/sec, 232 packets/sec

5 minute output rate 307000 bits/sec, 253 packets/sec

733200638 packets input, 1532289110 bytes, 0 no buffer

Received 437630462 broadcasts (0 multicast)

13 runts, 0 giants, 0 throttles

13 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 437629992 multicast, 0 pause input

0 input packets with dribble condition detected

698508387 packets output, 4108603362 bytes, 0 underruns

0 output errors, 0 collisions, 1 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier, 0 PAUSE output

0 output buffer failures, 0 output buffers swapped out

If you need anything else just let me know. I'd be more than happy to share info. Thanks in advance

New Member

Re: 3560 switchport amber/green alternating

I have had the same problem with a 2950T on one of the gig ports which was connected to a server.

sh int g0/1 showed me that the port has input/crc errors. I'm still running the switch but as far as I know I have to replace it.

Re: 3560 switchport amber/green alternating

looks like problem is with speed/duplex settings at both end. It's better to lock down speed/duplex setting at switch and router as well

New Member

Re: 3560 switchport amber/green alternating

They have been locked down from the start to 100/full. There is something else I'm missing

New Member

Re: 3560 switchport amber/green alternating

On this interface there has been only 13 input errors all being runts. The switch has been up for over 3 weeks and the errors are not increasing.

uptime is 3 weeks, 3 days, 2 hours, 52 minutes

Hall of Fame Super Bronze

Re: 3560 switchport amber/green alternating

If the errors aren't increasing and you don't have connectivity issues, I wouldn't be too concerned. I wonder if the light indicator has to do with the fact that you disabled mdix on the switch interface. I usually leave the mdix setting default, I wonder why you decided to turn it off.

1915
Views
0
Helpful
7
Replies
CreatePlease to create content