Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

3620 modems do not respond to incoming calls

Hi,

I have a 3620 with the following hardware configuration:

Cisco Internetwork Operating System Software

IOS (tm) 3600 Software (C3620-IK9O3S-M), Version 12.2(8)T5, RELEASE SOFTWARE (fc1)

TAC Support: http://www.cisco.com/tac

Copyright (c) 1986-2002 by cisco Systems, Inc.

Compiled Sun 23-Jun-02 22:08 by ccai

Image text-base: 0x60008930, data-base: 0x61670000

ROM: System Bootstrap, Version 11.1(20)AA2, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)

racsca01 uptime is 5 days, 4 hours, 5 minutes

System returned to ROM by power-on

System image file is "flash:c3620-ik9o3s-mz.122-8.T5.bin"

cisco 3620 (R4700) processor (revision 0x81) with 60416K/5120K bytes of memory.

Processor board ID 26863746

R4700 CPU at 80Mhz, Implementation 33, Rev 1.0

MICA-6DM Firmware: CP ver 2730 - 5/23/2001, SP ver 2730 - 5/23/2001.

Channelized E1, Version 1.0.

Bridging software.

X.25 software, Version 3.0.0.

Primary Rate ISDN software, Version 1.1.

1 FastEthernet/IEEE 802.3 interface(s)

12 terminal line(s)

1 Channelized E1/PRI port(s)

DRAM configuration is 32 bits wide with parity disabled.

29K bytes of non-volatile configuration memory.

32768K bytes of processor board System flash (Read/Write)

Configuration register is 0x3922

The modem module is inserted in Slot 0 while the FE & E1 module is inserted in Slot 1

The router has the following config:

version 12.2

service nagle

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug datetime msec localtime show-timezone

service timestamps log datetime msec localtime show-timezone

service password-encryption

!

hostname racsca01

!

boot system flash c3620-ik9o3s-mz.122-8.T5.bin

logging buffered 16384 debugging

aaa new-model

!

!

aaa authentication login default group tacacs+ local

aaa authentication ppp default group tacacs+

aaa authorization exec default group tacacs+

aaa authorization commands 15 default group tacacs+

aaa authorization network default group tacacs+

aaa accounting exec default start-stop group tacacs+

aaa accounting commands 15 default start-stop group tacacs+

aaa accounting network default start-stop group tacacs+

aaa session-id common

enable secret 5 xxxxxxxxxx

!

username victor.s password 7 xxxxxxxxx

clock timezone GMT-4 -4

modem country mica e1-default

ip subnet-zero

!

!

no ip domain-lookup

ip domain-name yyy.yyyy.yyy

!

no ip bootp server

ip audit notify log

ip audit po max-events 100

async-bootp dns-server 172.30.32.24

async-bootp nbns-server 172.30.32.29

!

!

!

!

!

!

!

!

fax interface-type fax-mail

mta receive maximum-recipients 0

!

controller E1 1/0

framing NO-CRC4

ds0-group 0 timeslots 1 type r2-digital r2-compelled ani

cas-custom 0

country venezuela use-defaults

!

!

!

!

interface FastEthernet1/0

description To ACS

ip address 172.30.32.17 255.255.254.0

duplex auto

speed auto

!

interface Group-Async1

no ip address

encapsulation ppp

dialer in-band

dialer idle-timeout 10

dialer-group 1

async mode dedicated

peer default ip address pool dialin

ppp callback accept

ppp authentication chap pap

group-range 1 12

!

ip local pool dialin 10.98.1.15 10.98.1.39

ip classless

ip route 0.0.0.0 0.0.0.0 172.30.32.1

no ip http server

ip pim bidir-enable

!

!

access-list 100 permit tcp any host 172.30.32.16 eq tacacs

dialer-list 1 protocol ip permit

!

tacacs-server host 172.30.32.16 key xxxxx

tacacs-server timeout 20

radius-server host 172.30.32.16 auth-port 1645 acct-port 1646 key 7 xxxxxxxxx

radius-server retransmit 3

radius-server key 7 xxxxxxxxx

call rsvp-sync

!

!

mgcp profile default

!

dial-peer cor custom

!

!

!

!

!

line con 0

speed 115200

line 1 12

modem Dialin

transport input all

flowcontrol hardware

line aux 0

line vty 0 4

transport input ssh

!

!

end

It will answer incoming calls but it will not give a modem tone, this is the result from a debug in this situation:

*Mar 6 00:13:01.505 GMT-4: Modem 0/3 Mica: configured for Answer mode, with Lower R2 signaling, 0x0 tone detection.

*Mar 6 00:13:01.505 GMT-4: TDM: Begin slot/port:channel 1/0:0 allocation for Modem use

*Mar 6 00:13:01.505 GMT-4: M32 AR - channel 0

*Mar 6 00:13:01.509 GMT-4: TDM: Enabling modem no 3

*Mar 6 00:13:01.509 GMT-4: TDM: No Errors in channel allocation for modem, rc is 0x0

End of slot/port:channel 1/0:0 allocation for Modem

*Mar 6 00:13:01.617 GMT-4: Modem 0/3 Mica: in modem state CALL_SETUP

*Mar 6 00:13:31.617 GMT-4: Modem 0/3 Mica: dialing number '#'

*Mar 6 00:13:31.621 GMT-4: TDM: Begin deletion of slot/port:channel 1/0:0 used by Modem

*Mar 6 00:13:31.621 GMT-4: TDM: Disabling modem no 3

*Mar 6 00:13:31.621 GMT-4: M32 AR for Modem - channel 0

*Mar 6 00:13:31.633 GMT-4: M32 AR for Modem - channel 0

*Mar 6 00:13:31.641 GMT-4: TDM: End of slot/port:channel 1/0:0 deletion

*Mar 6 00:13:31.661 GMT-4: Modem 0/3 Mica: in modem state TERMINATING

*Mar 6 00:13:31.681 GMT-4: Modem 0/3 Mica: in modem state IDLE

*Mar 6 00:13:31.681 GMT-4: TDM: Begin deletion of slot/port:channel 1/0:0 used by Modem

*Mar 6 00:13:31.681 GMT-4: TDM: Disabling modem no 3

*Mar 6 00:13:31.693 GMT-4: TDM: End of slot/port:channel 1/0:0 deletion

*Mar 6 00:13:31.697 GMT-4: Modem 0/3 Mica: DISCONNECT after 00:00:00, due to reason (0x7F00) Host Disconnect.

*Mar 6 00:13:31.697 GMT-4: %MODEM_HIST-3-END_CALL: Mica Modem 0/3

Connect Protocol - Unkn, Compression - Unkn, Connected Standard - Unkn

Tx/Rx bit rate - 0/0

Call Time - 00:00:00, Disconnect Reason (0x7F00) - Host Disconnect

0 retrains and/or speed shifts, 0 ec retransmissions requested

0 chars tx, 0 chars rx, 0 chars rx bad

0 ppp packets tx, 0 ppp packets rx, 0 ppp packets rx bad

0 ec packets tx, 0 ec packets rx, 0 ec packets rx bad

0 v110 packets tx, 0 v110 packets rx, 0 v110 packets rx bad, 0 v110 sync loss

Any ideas on what might be happening?.

Regards,

VS

15 REPLIES

Re: 3620 modems do not respond to incoming calls

Hi,

For modem dial-in, your ISDN line must be working.

At that point I am missing a few things in your config.

I am missing the definition of the PRI interface.

On euro-isdn this looks like this:

interface Serial1/0:15

no ip address

no ip directed-broadcast

encapsulation ppp

no logging event link-status

dialer rotary-group 1

isdn switch-type primary-net5

isdn incoming-voice modem < your modems don't work without it

no fair-queue

no cdp enable

!

To make this interface pop-up in the config, you need to enter something like this in the controller description:

controller E1 1/0

framing NO-CRC4

pri-group timeslots 1-31 < designates your B channels to the pri-group

and creates the interface in IOS config.

This might not all apply for your ISDN provider but you might get a hint towards discovering the proper settings.

Goodluck!

New Member

Re: 3620 modems do not respond to incoming calls

Hi,

In our case the E1 circuit is not for ISDN service but for POTS. Any idea for this?. Thanks for your help.

Best Regards,

VS

Re: 3620 modems do not respond to incoming calls

Allright, can you give us the following info:

sh contr e1

sh modem

sh flash

New Member

Re: 3620 modems do not respond to incoming calls

Hi,

Here are the commands:

sh contr e1

E1 1/0 is up.

Applique type is Channelized E1 - balanced

No alarms detected.

alarm-trigger is not set

Framing is NO-CRC4, Line Code is HDB3, Clock Source is Line.

Data in current interval (667 seconds elapsed):

0 Line Code Violations, 0 Path Code Violations

0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

Total Data (last 24 hours)

0 Line Code Violations, 0 Path Code Violations,

0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,

0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

racsca01#sh modem

Codes:

* - Modem has an active call

R - Modem is being Reset

D - Download in progress

B - Modem is marked bad and cannot be used for taking calls

b - Modem is either busied out or shut-down

Avg Hold Inc calls Out calls Busied Failed No Succ

Mdm Time Succ Fail Succ Fail Out Dial Answer Pct.

0/0 00:00:29 0 4 0 14 0 0 0 0%

0/1 00:00:28 0 6 0 0 0 0 0 0%

0/2 00:00:26 0 6 0 0 0 0 0 0%

0/3 00:00:21 0 5 0 0 0 0 0 0%

0/4 00:00:29 0 4 0 0 0 0 0 0%

0/5 00:00:34 0 3 0 0 0 0 0 0%

0/6 03:48:18 0 4 0 0 0 0 0 0%

0/7 00:00:32 0 4 0 0 0 0 0 0%

0/8 00:00:41 0 4 0 0 0 0 0 0%

0/9 00:01:30 0 4 0 0 0 0 1 0%

0/10 00:00:35 0 4 0 0 0 0 0 0%

0/11 01:12:47 0 4 0 0 0 0 0 0%

Total: 00:18:45 0 52 0 14 0 0 1 0%

racsca01#sh flash

System flash directory:

File Length Name/status

1 12039480 c3620-ik8o3s-mz.122-10b.bin

2 14538772 c3620-ik9o3s-mz.122-8.T5.bin

[26578380 bytes used, 6976052 available, 33554432 total]

32768K bytes of processor board System flash (Read/Write)

Re: 3620 modems do not respond to incoming calls

On your flash, a file is missing. With a 3620 you will need something like this: mica-modem-pw.2.7.1.0.bin to control the modems. It can be dowloaded from Cisco. Just do a search for mica-modem.

This may very well be the cause of your problem. When it is not there your modems will fail to give answer tones.

Goodluck

New Member

Re: 3620 modems do not respond to incoming calls

Hi,

Now these are the contents of the flash on the 3620:

System flash directory:

File Length Name/status

1 12039480 c3620-ik8o3s-mz.122-10b.bin

2 14538772 c3620-ik9o3s-mz.122-8.T5.bin

3 464286 mica-modem-pw.2.9.1.0.bin

[27042732 bytes used, 6511700 available, 33554432 total]

32768K bytes of processor board System flash (Read/Write)

But still there is no response from the modems.

Best Regards,

VS

Re: 3620 modems do not respond to incoming calls

Ok VS,

Did you check whether ver 2.9.1.0 is suitable for the 3620?

Appearently not because when I checked it myself, the highest release where it states that it can be used on the 3600 series is 2.7.4.0

The higher releases are only for use with the AS5300 series.

Cheers!

New Member

Re: 3620 modems do not respond to incoming calls

Hi,

From this page:

http://www.cisco.com/univercd/cc/td/doc/product/access/acs_serv/5300/sw_conf/sw_ports/compmat/mca12prt.htm#xtocid6

one can assume that, from this quote: "..but only Version 2.9.1.0 contains the bundled firmware for the Cisco 3600 series", that version would run on a 3620.

Anyway, I followed your advice and now the flash looks like this:

System flash directory:

File Length Name/status

1 12039480 c3620-ik8o3s-mz.122-10b.bin

2 14538772 c3620-ik9o3s-mz.122-8.T5.bin

3 464286 mica-modem-pw.2.9.1.0.bin [deleted]

4 476630 mica-modem-pw.2.7.4.0.bin

[27519428 bytes used, 6035004 available, 33554432 total]

32768K bytes of processor board System flash (Read/Write)

But still I don't get a tone and the debug shows that the modem reaches up to the CALL_SETUP state and then dials "#" (where does this come from?).

The good part is once I uploaded the firmware into the router the R2 signaling bits ABCD work accordingly with their expected behavior.

Thanks very much for your time and your quick responses,

Best Regards,

VS

Re: 3620 modems do not respond to incoming calls

When looking a bit further, 2.9.2.0 should be working as well with the latest IOS. So that was a misstake on my side as well, but 2.9.1.0 will not work for you. btw: You know that you have to reload the router to make this change effective?

I have seen many strange things happening when people try to run the latest versions. I would go for 2.7.4.0 initially.

Something else is that you could clean up your flash, which now contains two different IOS images. When it still does not work you can consider to delete the unused IOS version. Normally my flash on an access router contains just the required IOS and the mica-modem file.

New Member

Re: 3620 modems do not respond to incoming calls

Leo:

I cleaned up the flash and now it looks like this:

System flash directory:

File Length Name/status

1 14538772 c3620-ik9o3s-mz.122-8.T5.bin

2 476630 mica-modem-pw.2.7.4.0.bin

[15015532 bytes used, 18014612 available, 33030144 total]

32768K bytes of processor board System flash (Read/Write)

It's been reloaded with these files on the config but the modems still stay on the CALL_SETUP state. What else do you suggest?. As always, thank you very much.

BR,

VS

Re: 3620 modems do not respond to incoming calls

Dear VS,

This is a tough one! I am convinced that we tackled one issue but appearently there are more. This is how it works in Europe:

interface Serial1/0:15 > ISDN30 PRI

no ip address

no ip directed-broadcast

encapsulation ppp

no logging event link-status

dialer rotary-group 1

isdn switch-type primary-net5

isdn incoming-voice modem

no fair-queue

no cdp enable

!

On my modem lines, there is a line stating: rotary 1

line 65 88

session-timeout 60

exec-timeout 60 0

autoselect during-login

autoselect ppp

modem InOut

modem autoconfigure discovery

rotary 1

transport preferred telnet

transport input all

stopbits 1

flowcontrol hardware

line aux 0

I assumed that this refers to the dialer rotary-group command on interface s1/0:15 (ISDN) which is not there in your config. How does the software make the link between the interface and the modem pool?

I also found a table giving an explanation for the disconnect reasons on this URL:

http://www.cisco.com/en/US/tech/tk13/tk426/technologies_tech_note09186a0080094ebd.shtml#MICA_DISCONNECT

Your code was 0x7f00 (0x1f00 and 0x6.

It says that the condition occurred during call setup and might be related to tacacs/radius authentication. So that might be the next thing to check. Either the disconnect is due to the fact that the system does not know what to do with the call, or your ACS commands to drop the link. The first one is the most likely explanation.

Keep your spirit up and keep me posted!

Re: 3620 modems do not respond to incoming calls

What is the output of the following command: ?

sh modem ver

New Member

Re: 3620 modems do not respond to incoming calls

Leo,

Thos is the output:

racsca01#sh modem ver

Slot 0:MICA-6DM Firmware, Source - flash:/mica-modem-pw.2.7.4.0.bin

CP ver 2740 - 4/10/2002, CheckSum 5D24D4C6.

SP ver 2740 - 4/10/2002.

MICA 0: HW Version 1.0, Serial Number 25000787.

MICA 1: HW Version 1.0, Serial Number 14098012.

MICA 2: Not Installed.

MICA 3: Not Installed.

MICA 4: Not Installed.

Regards,

VS

Re: 3620 modems do not respond to incoming calls

Ok VS,

Thats what should be there. Your modems use ver 2.7.4.0 from flash.

So the IOS and mica FW work together as we expect.

Did you get something from the disconnect codes?

The most likely is that the system drops the call because if it were tacacs, it would be dropped after authentication.

New Member

Re: 3620 modems do not respond to incoming calls

Leo,

Thanks very much for your help.

Turns out the problem was due to a configuration parameter on the Siemens PBX. The PBX was expecting a dial-tone from the router trunk, the router was unable to provide it so the PBX kept dropping the calls.

After changing this, we were able to receive calls but had to change the IOS from 12.2(8)T5 to 12.2(6h) because callback was not working.

I will post to see if one can tune the digital modems to force that the upstream speed (in a callback case, from the RAS to the dial-up client) be higher than the downstream speed. I've been only to reach high speeds (>50kbps) without callback. Any tips?

BR,

VS

192
Views
0
Helpful
15
Replies
作成コンテンツを作成するには してください