Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

3640 ADSL & Active Serial (WAN) to be used as Backup interface also

I would like to know how to setup the router that if the ADSL goes down traffic will automatically be directed to the active serial 1/1 interface.

Config currently

version 12.3

service nagle

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname abc

!

boot system flash

enable secret 5 xxxxxxxxxxxxxxxxxxxxxx

enable password 7 xxxxxxxxxxxxxxxxxxxxxx

!

clock timezone GMT 2

ip subnet-zero

!

ip cef

ip name-server x.x.x.x

!

no voice hpi capture buffer

no voice hpi capture destination

!

interface ATM0/0

no ip address

no atm ilmi-keepalive

bundle-enable

dsl operating-mode auto

!

interface ATM0/0.1 point-to-point

pvc 8/35

pppoe-client dial-pool-number 5

!

!

interface FastEthernet0/0

ip address x.x.x.x 255.255.255.224

ip route-cache policy

ip policy route-map abcz

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 10.10.10.1 255.255.255.0

ip nat inside

duplex auto

speed auto

!

interface Serial1/1

description ISP#1

ip address x.y.z.z 255.255.255.252

no ip redirects

no ip unreachables

ip nat outside

no ip mroute-cache

serial restart_delay 0

!

interface Serial1/3

no ip address

shutdown

serial restart_delay 0

!

interface Serial2/1

description CCCC

bandwidth 64

ip address 10.10.30.1 255.255.255.252

ip nat inside

encapsulation ppp

fair-queue 64 32 0

no cdp enable

!

interface Dialer1

description ADSL connection

mtu 1492

ip address negotiated

ip nat outside

encapsulation ppp

ip route-cache policy

no ip mroute-cache

ip policy route-map abcz

dialer pool 5

dialer-group 1

no cdp enable

ppp chap hostname login_name

ppp chap password 7 login_password

ppp pap sent-username login_name password 7 login_password

!

ip default-gateway x.x.x.x

ip nat pool net-1 x.x.x.x y.y.y.y.y netmask 255.255.255.240

ip nat inside source route-map adsl interface Dialer1 overload

ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

ip route 0.0.0.0 0.0.0.0 Serial1/1 5

ip route 10.10.31.0 255.255.255.0 10.10.30.2

!

access-list 5 permit any

access-list 114 deny ip d.x.y.z 0.0.0.31 any

access-list 114 permit ip 10.0.0.0 0.255.255.255 any

access-list 115 deny ip d.x.y.z 0.0.0.31 any

access-list 115 permit ip 10.0.0.0 0.255.255.255 any

access-list 116 deny ip d.x.y.z 0.0.0.31 10.0.0.0 0.255.255.255

access-list 116 permit ip d.x.y.z 0.0.0.31 any

dialer-list 1 protocol ip permit

!

route-map abcz permit 10

match ip address 116

set interface Serial1/1

!

route-map adsl permit 10

match ip address 115

!

route-map nat permit 10

match ip address 114

!

line con 0

speed 115200

line aux 0

line vty 0 4

password 7 password

login

!

end

6 REPLIES
New Member

Re: 3640 ADSL & Active Serial (WAN) to be used as Backup interfa

Hi There,

You could put a backup interface command on the ATM interface to point to the Serial1/1 interface. That way when the ATM interface goes down, the Serial 1/1 interface will take over the routing.

Hope that helps

Andrew

Anonymous
N/A

Re: 3640 ADSL & Active Serial (WAN) to be used as Backup interfa

Hi

When you add backup interface serial1/1 to the atm interface, serial1/1 goes into standby mode and is not active. Needs to be active for fixed ip used on email.

Thanks and any other suggestions PLEASE !

Re: 3640 ADSL & Active Serial (WAN) to be used as Backup interfa

Thus the ADSL and Serial link terminate at the same router on the other end? if so, why waste the precious bandwidth? Use Load Balancing.

1. OSPF Equal Load Balancing

Use OSPF Equal Cost Load Balancing - if both bandwidth are the same.

2. EIGRP/IGRP Un-Equal Load Balancing

Use EIGRP Un-Equal Cost Load Balancing if ADSL and Serial are in different bandwidth.

3. How to do it cause ADSL is not direct link? Well use IP GRE Tunnel.

Anonymous
N/A

Re: 3640 ADSL & Active Serial (WAN) to be used as Backup interfa

No, they do not both terminate at the same router on the other end

Thanks

Re: 3640 ADSL & Active Serial (WAN) to be used as Backup interfa

Your default routes indicate the following.

ip route 0.0.0.0 0.0.0.0 Dialer1

ip route 0.0.0.0 0.0.0.0 Serial1/1 5

You have 2 WAN interfaces on your router.

1 ATM - for ADSL.

1 s1/1 - serial wan.

The default routes are already configured as floating static, so that if the dialer interface goes down, the serial interface kicks in.

Are you experiencing any issues, where the ADSL WAN is down, but the dialer interface is not down ??

Anonymous
N/A

Re: 3640 ADSL & Active Serial (WAN) to be used as Backup interfa

The serial1/1 is up all the time but when the ADSL goes down, the http (www) traffic stops flowing. I think it has to do with the route-map - but I am naive.

Please see what other solutions you can come up with

thanks

105
Views
0
Helpful
6
Replies
CreatePlease to create content