Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

3640 isdn + async problem

I have the following:

cisco 3640, fe-pri 1fe-2ce1, mica digital modems

IOS 12.2(2)XB7

This ios version works ok for our voip. With other (not tried all versions) router crashes if using

"voice service voip

h323

session transport tcp calls-per-connection 1"

The problem with dialin:

users can't get ip address from ip pool. Connection ok, authentication ok, but ppp doesn't provide peer ip address in IPCP and after 20-30 seconds user disconnects.

After reloading all works for some time, but:

if no users connected, ISDN call can connect and negotiate ip address

if 1 async user connected, ISDN connects but can't negotiate ip address

if more than 1 async user connected, ISDN can connect

Very strange...

Here is debug outputs:

# deb ppp neg

May 8 11:57:21.895 MSD: Se1/0:0 CCP: Packet buffered while building Virtual

+Profile interface

May 8 11:57:21.899 MSD: Se1/0:0 IPCP: Packet buffered while building Virtual

+Profile interface

May 8 11:57:25.899 MSD: Se1/0:0 IPCP: Packet buffered while building Virtual

+Profile interface

May 8 11:57:25.903 MSD: Se1/0:0 CCP: Packet buffered while building Virtual

+Profile interface

Virtual Profile debugging is on

Virtual Profile packet debugging is on

Virtual Profile subblock debugging is on

Virtual Template debugging is on

May 8 12:05:52.981 MSD: %LINK-3-UPDOWN: Interface Serial1/0:0, changed state

+to up

May 8 12:05:56.569 MSD: Se1/0:0 VP: Request to create VA, clone VT 1, and

+clone AAA

May 8 12:05:56.569 MSD: VTEMPLATE: Sending vaccess request, id 0x62FA4C74

May 8 12:05:56.569 MSD: VTEMPLATE: Processing vaccess requests, 1 outstanding> May 8 12:05:56.569 MSD: Vt1 VTEMPLATE: (Pre)cloning vaccess from recycle

+queue

May 8 12:05:56.573 MSD: Vi5 VTEMPLATE: Has a new cloneblk vtemplate, now it

+has vtemplate

May 8 12:05:56.573 MSD: Vi5 VTEMPLATE: ************* CLONE VACCESS5

+*****************

May 8 12:05:56.573 MSD: Vi5 VTEMPLATE: Clone from Virtual-Template1

default ip address

encap ppp

ip unnumbered FastEthernet1/0

ip tcp header-compression

ip unnumbered fastEthernet 1/0

no ip directed-broadcast

no cdp e

encapsulation ppp

ip unnumbered fa1/0

encap ppp

end

May 8 12:05:56.657 MSD: Vi5 VTEMPLATE: Has a new cloneblk AAA, now it has

+vtemplate/AAA

May 8 12:05:56.661 MSD: Vi5 VTEMPLATE: ************* CLONE VACCESS5

****************

May 8 12:05:56.661 MSD: Vi5 VTEMPLATE: Clone from AAA

ip tcp header-compression

ppp timeout idle 600 aaa

timeout absolute 1440 0

end

May 8 12:05:56.681 MSD: VTEMPLATE: Receiving vaccess request, id 0x62FA4C74,

+result 1

May 8 12:05:56.681 MSD: Vi5 VP: Cancel request successfully Se1/0:0

May 8 12:05:56.681 MSD: Vi5 VTEMPLATE: Free vaccess

May 8 12:05:56.681 MSD: VTEMPLATE: Clean up dirty vaccess queue, size 1

May 8 12:05:56.681 MSD: Vi5 VTEMPLATE: Found a dirty vaccess clone with

+vtemplate/AAA

May 8 12:05:56.681 MSD: Vi5 VTEMPLATE: ************ UNCLONE VACCESS5

+**************

May 8 12:05:56.681 MSD: Vi5 VTEMPLATE: Unclone to-be-freed command#3

default timeout absolute 1440 0

default ppp timeout idle 600 aaa

default ip tcp header-compression

end

May 8 12:05:56.713 MSD: Vi5 VTEMPLATE: Remove cloneblk AAA with vtemplate/AAA> May 8 12:05:56.713 MSD: VTEMPLATE: Found a AAA buf for AAA clone blk.

May 8 12:05:56.717 MSD: Vi5 VTEMPLATE: ************ UNCLONE VACCESS5

+**************

May 8 12:05:56.717 MSD: Vi5 VTEMPLATE: Unclone to-be-freed command#9

default encap ppp

default ip unnumbered fa1/0

default encapsulation ppp

default cdp e

default ip directed-broadcast

default ip unnumbered fastEthernet 1/0

default ip tcp header-compression

default ip unnumbered FastEthernet1/0

default encap ppp

end

May 8 12:05:56.797 MSD: Vi5 VTEMPLATE: Remove cloneblk vtemplate with

+vtemplateMay 8 12:05:56.805 MSD: Vi5 VTEMPLATE: Set default settings with no

+ip address

May 8 12:05:56.809 MSD: Vi5 VTEMPLATE: Add vaccess to recycle queue, queue

+size 33

current config (some parts belongs to voip):

aaa new-model

!

!

aaa group server radius voipaaa

server xx.xx.40.5 auth-port 1645 acct-port 1646

!

aaa group server radius dialin

server xx.xx.42.2 auth-port 1645 acct-port 1646

!

aaa authentication login default local

aaa authentication login h323 group voipaaa

aaa authentication ppp default group dialin

aaa authorization exec default local

aaa authorization exec h323 group voipaaa

aaa authorization network default group dialin

aaa accounting delay-start

aaa accounting network default start-stop group dialin

aaa accounting connection default start-stop group dialin

aaa accounting connection h323 start-stop group voipaaa

aaa nas port extended

aaa nas port voip

aaa session-id common

!

no ip bootp server

virtual-profile if-needed

virtual-profile virtual-template 1

virtual-profile aaa

async-bootp dns-server xx.xx.40.2

isdn switch-type primary-net5

!

controller E1 1/0

pri-group timeslots 1-31

!

interface Serial1/0:15

no ip address

encapsulation ppp

no logging event link-status

dialer rotary-group 0

dialer-group 1

isdn switch-type primary-net5

isdn incoming-voice modem

no fair-queue

no cdp enable

!

interface Virtual-Template1

ip unnumbered FastEthernet1/0

ip tcp header-compression

peer default ip address pool dialin

ppp authentication pap

ppp multilink

multilink max-links 2

!

interface Group-Async1

ip unnumbered FastEthernet1/0

encapsulation ppp

no logging event link-status

async mode dedicated

peer default ip address pool dialin

ppp authentication pap

group-range 65 94

!

interface Dialer0

ip unnumbered FastEthernet1/0

encapsulation ppp

no ip mroute-cache

dialer in-band

dialer-group 1

peer default ip address pool dialin

no fair-queue

no cdp enable

ppp authentication pap

ppp multilink

!

ip local pool dialin xx.xx.42.32 xx.xx.42.63

!

dialer-list 1 protocol ip permit

radius-server host xx.xx.40.5 auth-port 1645 acct-port 1646 non-standard key 7 ***

radius-server host xx.xx.42.2 auth-port 1645 acct-port 1646 non-standard key 7 ***

radius-server retransmit 3

radius-server attribute 6 on-for-login-auth

radius-server attribute 6 voice 1

radius-server attribute 44 include-in-access-req

radius-server authorization permit missing Service-Type

radius-server vsa send accounting

radius-server vsa send authentication

!

line 65 94

modem InOut

transport input all

1 REPLY
Silver

Re: 3640 isdn + async problem

"Packet buffered while building Virtual Profile interface" is known issue CSCdy08176 "vaccess is cloned, then immediately unclones" / CSCdy22040

This bug was resolved in 12.2(2)XB8 / 12.2(13.4)T1, would suggest moving to either 12.2(2)XB10 or 12.2(15)T2.

Thanks, Mak

98
Views
0
Helpful
1
Replies
CreatePlease to create content