Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

3640 ISDN BRI and second B channels flag

I've been trying for the logest time to fix a problem with both my 3640's.

I've configured them using legacy ddr and snapshot routing but they suffer from the same syptom. Everytime I check the isdn history of the router that is initiating the call it shows me that its trying to dial the same number its already connected to. There are three other dialer maps in the bundle but for some reason it keeps trying to dial the same dialer map.

Im currently running CISCO IOS Version 12.2(13), RELEASE SOFTWARE (fc1) on them.

You will also notice that on my Central router I have one dialer map defined and on my Remote router I have 4 defined. Ultimately I would prefer that only my remote router dial to the central router but it seems that when that one dialer map on the central router is not present then the remote router does not do anything.

My setup is really weird sometimes I monitor the routers and all 4 channels are up, most of the time only 2 are up and every other time the second b channels of each bri keep flagging.

If anybody can help it would be much appreciated. I've lost my mind and sleep trying to get this to work.

Thanks in advance,

Here are my configs

Central Router

======================================

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname "Central"

!

enable secret 5 $1$sDjL$Rt4fFteXxFK5PTHHKSnHp0

enable password xxxx

!

ip subnet-zero

!

!

ip domain-name something.com

ip name-server 172.20.200.5

!

isdn switch-type basic-ni

!

!

!

interface Ethernet0/0

ip address 192.192.192.250 255.255.255.248

half-duplex

!

interface Serial0/0

no ip address

no ip mroute-cache

shutdown

!

interface Ethernet0/1

no ip address

shutdown

half-duplex

!

interface Serial0/1

no ip address

shutdown

!

interface BRI2/0

no ip address

encapsulation ppp

dialer rotary-group 0

isdn switch-type basic-ni

isdn spid1 514xxx206300 9352063

isdn spid2 514xxx206400 9352064

isdn fast-rollover-delay 5

no cdp enable

ppp multilink

!

interface BRI2/1

no ip address

encapsulation ppp

dialer rotary-group 0

isdn switch-type basic-ni

isdn spid1 514xxx206500 9352065

isdn spid2 514xxx461600 9354616

isdn fast-rollover-delay 5

no cdp enable

ppp multilink

!

interface BRI2/2

no ip address

encapsulation hdlc

shutdown

isdn switch-type basic-ni

!

interface BRI2/3

no ip address

encapsulation hdlc

shutdown

isdn switch-type basic-ni

!

interface Dialer0

ip address 192.168.30.2 255.255.255.252

encapsulation ppp

dialer in-band

dialer idle-timeout 300

dialer map ip 192.168.30.1 name Remote broadcast

dialer hold-queue 10

dialer load-threshold 1 either

dialer-group 1

ppp multilink

!

interface Dialer1

no ip address

shutdown

no cdp enable

!

router rip

network 192.168.20.0

network 192.168.30.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.192.192.254

ip route 192.168.20.0 255.255.255.0 192.168.30.1

ip http server

!

access-list 1 permit any

dialer-list 1 protocol ip permit

no cdp run

!

line con 0

password xxxx

login

line aux 0

line vty 0 4

password xxxx

login

!

end

======================================

Remote Router

======================================

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname "Remote"

!

enable secret 5 $1$sDjL$Rt4fFteXxFK5PTHHKSnHp0

enable password xxxx

!

ip subnet-zero

!

!

ip domain-name something.com

ip name-server 172.20.200.5

ip dhcp excluded-address 192.168.20.1 192.168.20.5

!

ip dhcp pool Remote

network 192.168.20.0 255.255.255.0

domain-name something.com

dns-server 172.20.200.5

netbios-name-server 172.20.200.11 172.20.200.13

default-router 192.168.20.1

lease 5

!

isdn switch-type basic-ni

!

!

!

interface Ethernet0/0

ip address 192.168.20.1 255.255.255.0

half-duplex

!

interface Serial0/0

no ip address

no ip mroute-cache

shutdown

!

interface Ethernet0/1

no ip address

shutdown

half-duplex

!

interface Serial0/1

no ip address

shutdown

!

interface BRI2/0

no ip address

encapsulation ppp

dialer rotary-group 0

isdn switch-type basic-ni

isdn spid1 514xxx625300 4826253

isdn spid2 514xxx156300 4821563

isdn fast-rollover-delay 5

no cdp enable

ppp multilink

!

interface BRI2/1

no ip address

encapsulation ppp

dialer rotary-group 0

isdn switch-type basic-ni

isdn spid1 514xxx756100 4827561

isdn spid2 514xxx436100 4824361

isdn fast-rollover-delay 5

no cdp enable

ppp multilink

!

interface BRI2/2

no ip address

encapsulation hdlc

shutdown

isdn switch-type basic-ni

!

interface BRI2/3

no ip address

encapsulation hdlc

shutdown

isdn switch-type basic-ni

!

interface Dialer0

ip address 192.168.30.1 255.255.255.252

encapsulation ppp

dialer in-band

dialer idle-timeout 300

dialer map ip 192.168.30.2 name Central broadcast 95149352063

dialer map ip 192.168.30.2 name Central broadcast 95149352064

dialer map ip 192.168.30.2 name Central broadcast 95149352065

dialer map ip 192.168.30.2 name Central broadcast 95149354616

dialer hold-queue 10

dialer load-threshold 1 either

dialer-group 1

ppp multilink

ppp timeout multilink link add 1

!

interface Dialer1

no ip address

no cdp enable

!

router rip

network 192.168.20.0

network 192.168.30.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.30.2

ip http server

!

access-list 1 permit any

dialer-list 1 protocol ip permit

no cdp run

!

line con 0

password xxxx

login

line aux 0

password xxxx

login

modem InOut

transport input all

speed 115200

flowcontrol hardware

line vty 0 4

password xxxx

login

!

end

5 REPLIES
Cisco Employee

Re: 3640 ISDN BRI and second B channels flag

You need to change the hostname of Remote router from "Remote" to Remote because the dialer-map is defined for Remote and not for "Remote"

Same is for Central router too.

Now about the same number, router will follow the top down approach when it comes to dialout. It will try to dial using first dialer map always and follow down. If it diden't get CONNECT message it will go for the next one.

You can ask telco at Central site to put the bri lines in to hunt group of numbers so that all the remote routers have to dial just one number. You can use "dialer string xxxx" instead of dialer map after that.

Now to resolve the issue, i don't know whay you need "ppp timeout multilink link add 1". I would remove that and adjust the dialer load-threshold on remote site rather then central site to have a better control of calls.

New Member

Re: 3640 ISDN BRI and second B channels flag

Thanks for your reply.

But let me go over your response quickly.

"You need to change the hostname of Remote router from "Remote" to Remote because the dialer-map is defined for Remote and not for "Remote"

Same is for Central router too. "

I changed my config for this posting. my Central Router is called "InveraCentral" and my remote router is called "InveraRemote". The dialer maps are good aswell. I even used the Cisco Config maker to make sure my statements where correct.

Next,

"Now about the same number, router will follow the top down approach when it comes to dialout. It will try to dial using first dialer map always and follow down. If it diden't get CONNECT message it will go for the next one.

You can ask telco at Central site to put the bri lines in to hunt group of numbers so that all the remote routers have to dial just one number. You can use "dialer string xxxx" instead of dialer map after that."

My Remote router always tries the first number and it gets a busy. Then it keeps trying that same number, it never tries the next dialer map. As far as Hunt group goes I had asked about the possibility of this to our telco and they said that there would be an extra cost. Also, if my BRi's are in a hunt group what is the difference between using "dialer string" or "dialer map"?

Next,

"Now to resolve the issue, i don't know whay you need "ppp timeout multilink link add 1". I would remove that and adjust the dialer load-threshold on remote site rather then central site to have a better control of calls."

The only reason I put "ppp timeout multilink link add 1" is so my second b channels come up quicker then the default of 30 seconds. I really just put it to speed up things. I don't know if I need it though because my dialer load-threshold is at 1either on both Routers.

As you can see im still stuck after your response. I will try and investigate further on the hunt group stuff you mentioned and see what happens with that for now.

If you have any other ideas please help.

Thanks,

Cisco Employee

Re: 3640 ISDN BRI and second B channels flag

Well i suggest you to open a case on this issue by logging at www.cisco.com/tac

New Member

Re: 3640 ISDN BRI and second B channels flag

Well the problems with that is we bought these routers in 98 and we no longer have support contracts for them.

They told me it would cost 420$ for CISCO to troubleshoot my configs.

For now I've decided it would be cheaper to ask my telco to setup my BRI's in a hunt group and then we can see what happens after that.

Some CISCO stuff I read says that if the telco has not setup hunt groups then I can put the following statements to correct it on my end.

isdn fast-rollover-delay 5

or

dialer redial interval 5 attemps 3

This had fixed the problem last week but now only two or three channels work at a time.

My debug shows that the dialer keeps trying to dial a number its already connected to (Busy).

New Member

Re: 3640 ISDN BRI and second B channels flag

I was testing tonight and something interresting happened which I can't explain.

On my Central router I have 1 dialer map defined to dial to my Remote router and it does just that.

On my Remote router I have 4 dialer maps trying to dial to my Central router and for some reason the first dialer map gets abusy signal because it tries to dial the Central routers BRI which is already connected to it. Normally it should try to dial the next dialer map in the list but it doesn't. What I did then is I remove one Dialer map at a time from my Remote router and everytime I did a "show isdn ac" I saw an extra channel go up. I did this until one map was left defined on my Remote router and everything was fine all 4 channels had come up. So as a final test I decided to reload my Central router to see if all 4 channels come up again and no luck. This sorta makes me think that there is a bug somewhere. For now I will try doing my trick and hope that I don't need to reload my router. I will do this until my telco finishes setting up a hunt group for my BRI's.

Do this help anyone in assessing what the problem could be?

124
Views
0
Helpful
5
Replies