Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

3640 : PBL with 2 differents IP LOCAL POOL

hi,

we have two (2) different groups of dialin users (DIALIN & TEST)

these two groups have a specific peer default ip address pool (DIALIN or TEST)

these two groups call a different phone number

regarding int BRI 1/6 (dedicating to group TEST), i am not able to allocate ip 192.168.8.250 or 192.168.8.251 which in turn should raise in asyn 81 or 82 ONLY

any hint or links would be truly appreciated

below is the current conf

thx

stef.Novo

=================================

CISCO 3640 + Modem MICA

============================

Current configuration:

!

version 12.1

!

hostname TEST

!

logging buffered 4096 debugging

logging console errors

!

!

memory-size iomem 25

modem call-record terse

modem country mica france

ip subnet-zero

no ip domain-lookup

!

isdn switch-type basic-net3

!

interface Ethernet0/0

ip address x.x.x.x x.x.x.x

!

interface BRI1/0

description Port 0 DIAL-IN

ip unnumbered Ethernet0/0

encapsulation ppp

no ip route-cache

no ip mroute-cache

dialer pool-member 1

isdn switch-type basic-net3

isdn incoming-voice modem

ppp authentication pap

!

interface BRI1/1

description Port 1 DIAL-IN

ip unnumbered Ethernet0/0

encapsulation ppp

no ip route-cache

no ip mroute-cache

dialer pool-member 1

isdn switch-type basic-net3

isdn incoming-voice modem

ppp authentication pap

!

interface BRI1/2

description Port 2 DIAL-IN

ip unnumbered Ethernet0/0

encapsulation ppp

no ip route-cache

no ip mroute-cache

dialer pool-member 1

isdn switch-type basic-net3

isdn incoming-voice modem

ppp authentication pap

!

interface BRI1/3

description Port 3 DIAL-IN

ip unnumbered Ethernet0/0

encapsulation ppp

no ip route-cache

no ip mroute-cache

dialer pool-member 1

isdn switch-type basic-net3

isdn incoming-voice modem

ppp authentication pap

!

interface BRI1/4

description Port 4 DIAL-IN

ip unnumbered Ethernet0/0

encapsulation ppp

no ip route-cache

no ip mroute-cache

shutdown

dialer pool-member 1

isdn switch-type basic-net3

isdn incoming-voice modem

ppp authentication pap

!

interface BRI1/5

description Port 5 DIAL-IN

ip unnumbered Ethernet0/0

encapsulation ppp

no ip route-cache

no ip mroute-cache

shutdown

dialer pool-member 1

isdn switch-type basic-net3

isdn incoming-voice modem

ppp authentication pap

!

interface BRI1/6

description Connexion TEST

ip unnumbered Ethernet0/0

encapsulation ppp

no ip route-cache

no ip mroute-cache

dialer pool-member 3

isdn switch-type basic-net3

isdn incoming-voice modem

peer default ip address pool TEST

ppp authentication pap

!

interface BRI1/7

description Port 5 DIAL-IN

ip unnumbered Ethernet0/0

encapsulation ppp

no ip route-cache

no ip mroute-cache

shutdown

dialer pool-member 1

isdn switch-type basic-net3

isdn incoming-voice modem

ppp authentication pap

!

!

interface Group-Async0

description DIALIN

ip unnumbered Ethernet0/0

encapsulation ppp

ip tcp header-compression

no ip mroute-cache

async mode interactive

peer default ip address pool DIALIN

compress mppc ignore-pfc

ppp authentication pap

group-range 65 80

!

interface Group-Async1

description TEST

ip unnumbered Ethernet0/0

encapsulation ppp

ip tcp header-compression

no ip mroute-cache

async mode interactive

peer default ip address pool TEST

compress mppc ignore-pfc

ppp authentication pap

group-range 81 82

!

interface Dialer0

description DIALIN

ip unnumbered Ethernet0/0

encapsulation ppp

dialer pool 1

dialer-group 1

peer default ip address pool DIALIN

ppp authentication pap

!

!

interface Dialer3

description TEST

ip unnumbered Ethernet0/0

encapsulation ppp

dialer pool 3

dialer-group 3

peer default ip address pool TEST

ppp authentication pap

!

ip local pool DIALIN 192.168.8.1 192.168.8.249

ip local pool TEST 192.168.8.250 192.168.8.251

ip classless

ip route 0.0.0.0 0.0.0.0 x.x.x.x

ip route 192.168.8.0 255.255.255.0 Dialer0

ip route 192.168.8.250 255.255.255.255 Dialer3

ip route 192.168.8.251 255.255.255.255 Dialer3

ip http server

!

dialer-list 1 protocol ip permit

dialer-list 3 protocol ip permit

!

line con 0

transport input none

line 65 80

autoselect ppp

modem Dialin

transport input all

line 81 82

autoselect ppp

modem Dialin

transport preferred none

transport input all

!

end

3 REPLIES
Bronze

Re: 3640 : PBL with 2 differents IP LOCAL POOL

Your problem is that calls come into BRI lines based upon the number dialed, but when analog calls come into one of these lines, they can be switched to any modem in the router. Part of your confusion seems to be your belief that the lines 81 and 82 are somehow associated with BRI1/6, but line numbers here are referring to modem lines, not BRI interfaces. So, in your config, you have no way of assuring that a call to a specific BRI gets switched to a modem in the group-async interface that you want.

You can rectify this by setting up modem pools and assigning modems to the modem pools. In your case, put lines 65-80 in modem pool PAT, and lines 81 and 82 into modem pool MIKE (of course, you can pick your own names for the modem pools).

Here is a link that should help you with your modem pool config.

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fdial_c/fnsprt2/dcdmodmg.htm#1042662

Good luck.

Mark

Community Member

Re: 3640 : PBL with 2 differents IP LOCAL POOL

hi,

that was great until i found out there is no MODEM-POOL command on our current IOS version :

IOS (tm) 3600 Software (C3640-I-M), Version 12.1(3a)T1, RELEASE SOFTWARE (fc1)

mica-modem-pw.2.7.3.0.bin

i'm calling our cisco reseller to confirm

thx anyway mark

stef.novo

Cisco Employee

Re: 3640 : PBL with 2 differents IP LOCAL POOL

Modem pooling using "modem-pool" is not supported on 3600 related platforms. So There is no way to link isdn interface with the perticualr modem or group of modems.

So in 3600, the incoming modem call will be terminated on the any modem which is free on round robin basis.

Now you can alloate the ip's from different ip address pool for ISDN users only but not the modem users.

Only AS53xx boxes support that modem-pooling.

99
Views
0
Helpful
3
Replies
CreatePlease to create content