Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

3745 and IPXCP Problems

Hello All,

I was hoping one you you could help me with the following problem.

I have just configured a 3745 with a NM30DM and E1/PRI for accepting incoming async dialup users.

IP is working fine for dialup users, works a treat. However, I cannot say the same for IPX. When I dialin (Windows XP) I get an "Error 773"

Here's a "debug ppp negotiation" from the 3745:

03:40:22: As52 PPP: Phase is UP

03:40:22: As52 IPCP: O CONFREQ [Closed] id 1 len 10

03:40:22: As52 IPCP: Address 10.27.66.1 (0x03060A1B4201)

03:40:22: As52 IPXCP: I CONFREQ [Not negotiated] id 5 len 18

03:40:22: As52 IPXCP: Network 0x00000000 (0x010600000000)

03:40:22: As52 IPXCP: Node 02ee.0ef0.bdc7 (0x020802EE0EF0BDC7)

03:40:22: As52 LCP: O PROTREJ [Open] id 202 len 24 protocol IPXCP

03:40:22: As52 LCP: (0x802B01050012010600000000020802EE)

03:40:22: As52 LCP: (0x0EF0BDC7)

03:40:22: As52 CCP: I CONFREQ [Not negotiated] id 6 len 10

03:40:22: As52 CCP: MS-PPC supported bits 0x00000001 (0x120600000001)

03:40:22: As52 LCP: O PROTREJ [Open] id 203 len 16 protocol CCP (0x80FD0106000A120600000001)

And here's a snapshot of the 3745 config:

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname CISCO-RAS1

!

aaa new-model

!

!

aaa authentication login default group radius

aaa authentication ppp default if-needed group radius

aaa session-id common

enable secret yadayadayada

!

ip subnet-zero

!

!

no ip domain-lookup

!

ipx routing 0009.7ce3.a050

isdn switch-type primary-net5

!

!

!

!

!

!

!

fax interface-type fax-mail

mta receive maximum-recipients 0

!

controller E1 2/0

framing CRC4 Australia

pri-group timeslots 1-31

!

!

!

!

interface Loopback0

ip address 10.27.66.1 255.255.255.0

!

interface FastEthernet0/0

ip address 10.27.88.1 255.255.255.0

duplex full

speed 100

ipx network 102788D

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial2/0:15

no ip address

encapsulation ppp

isdn switch-type primary-net5

isdn incoming-voice modem

no cdp enable

!

interface Group-Async1

ip unnumbered Loopback0

encapsulation ppp

dialer in-band

dialer-group 1

async mode dedicated

ipx network 102766D

peer default ip address pool dialin

ppp authentication pap chap

group-range 33 62

!

ip local pool dialin 10.27.66.100 10.27.66.200

ip classless

ip route 0.0.0.0 0.0.0.0 10.27.88.254

no ip http server

ip pim bidir-enable

!

!

dialer-list 1 protocol ip permit

dialer-list 1 protocol ipx permit

!

!

!

!

!

!

radius-server host 10.27.1.1 auth-port 1645 acct-port 1646 key cisco

radius-server retransmit 3

call rsvp-sync

!

!

mgcp profile default

!

dial-peer cor custom

!

!

!

!

line con 0

line 33 62

modem InOut

line aux 0

line vty 0 4

password cisco

!

end

--------------------------------------------------------

Any help would be greatly appreciated.

1 REPLY
Bronze

Re: 3745 and IPXCP Problems

Hi Paul,

I'm not an IPX expert, but is the fifth line of the debug output indicating that the user is dialing in with a network number of 0? If so, this does not match the network number of 102766D on the Group-Async interface, and these will have to match in order to have a successful connection. Of course, this change will have to be made on the client. Unfortunately, Cisco's documentation has very little on configuring dial access with anything other than IP.

Please feel free to correct me.

Good luck.

Mark

109
Views
0
Helpful
1
Replies