Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

3750 and 3550 Flapping

We have the 3750 and 3550 switches installed at our site and we are getting the following errors.

%LINK-3-UPDOWN: Interface GigabitEthernet2/0/13, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet2/0/13, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/7, changed state to down

%LINK-3-UPDOWN: Interface FastEthernet0/7, changed state to down

%LINK-3-UPDOWN: Interface FastEthernet0/7, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/7, changed state to up

%LINK-3-UPDOWN: Interface GigabitEthernet2/0/11, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet2/0/11, changed state to up

%LINK-3-UPDOWN: Interface GigabitEthernet1/0/18, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/18, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet2/0/11, changed state to down

%LINK-3-UPDOWN: Interface GigabitEthernet2/0/11, changed state to down

%LINK-3-UPDOWN: Interface GigabitEthernet2/0/11, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet2/0/11, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/18, changed state to down

What might be causing these errors and what can we do to fix them. Also is there some software out there that can tell us what might be causing the errors, ie... excessive collisions or the such

Thanks

Steve

6 REPLIES
Hall of Fame Super Bronze

Re: 3750 and 3550 Flapping

You could have a spanning-tree loop problem.

Can you post configs ?

Thanks

New Member

Re: 3750 and 3550 Flapping

Here is most of the configuration for the 3750, it won't allow me to post all of it

show running

Building configuration...

Current configuration : 5733 bytes

!

! Last configuration change at 10:02:01 UTC Fri Sep 29 2006 by enable

! NVRAM config last updated at 10:02:01 UTC Fri Sep 29 2006 by enable

!

version 12.2

no service pad

service timestamps debug datetime

service timestamps log datetime

service password-encryption

service sequence-numbers

!

hostname CLO511204

!

no logging console

enable secret 5 $1$FQBc$HnhMngh.vj1ShB8AclhsX0

!

aaa new-model

aaa authentication login default local

!

aaa session-id common

clock timezone UTC -7

clock summer-time UTC recurring

ip subnet-zero

ip domain-name clovisprd

ip name-server 10.17.150.1

ip name-server 10.17.150.11

!

vtp mode transparent

!

!

!

no file verify auto

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

vlan 150

name SWC-CONTROL

!

interface FastEthernet0/1

description PLC WS00-00

switchport access vlan 150

switchport mode access

duplex full

spanning-tree portfast

!

interface FastEthernet0/2

description PLC BC00-00

switchport access vlan 150

switchport mode access

duplex full

spanning-tree portfast

!

interface FastEthernet0/3

description PLC U300-00

switchport access vlan 150

switchport mode access

duplex full

spanning-tree portfast

!

interface FastEthernet0/4

description PLC P100-00

switchport access vlan 150

switchport mode access

duplex full

spanning-tree portfast

!

interface FastEthernet0/5

description PLC DRY1-00 NuCon

switchport access vlan 150

switchport mode access

duplex full

spanning-tree portfast

!

interface FastEthernet0/6

description PLC EVP1-00

switchport access vlan 150

switchport mode access

duplex full

spanning-tree portfast

!

interface FastEthernet0/7

description PLC DRY1-00

switchport access vlan 150

switchport mode access

duplex full

spanning-tree portfast

!

interface FastEthernet0/8

description PLC DRY1-10

switchport access vlan 150

switchport mode access

duplex full

spanning-tree portfast

!

interface FastEthernet0/9

description PLC DRY1-15

switchport access vlan 150

switchport mode access

duplex full

spanning-tree portfast

!

interface FastEthernet0/10

description SW PFR1-03

switchport access vlan 150

switchport mode access

duplex full

spanning-tree portfast

!

interface FastEthernet0/11

description PV+ PFR1-03 NotUse

switchport access vlan 150

switchport mode access

duplex full

spanning-tree portfast

!

interface FastEthernet0/12

description SW PFR1-02

switchport access vlan 150

switchport mode access

duplex full

spanning-tree portfast

!

interface FastEthernet0/13

description PLC PL20-01

switchport access vlan 150

switchport mode access

duplex full

spanning-tree portfast

!

interface FastEthernet0/14

description PV+ PFR1-02

switchport access vlan 150

switchport mode access

duplex full

spanning-tree portfast

!

interface FastEthernet0/15

description PLC IIC

switchport access vlan 150

switchport mode access

duplex full

spanning-tree portfast

!

interface FastEthernet0/16

description PLC angle

switchport access vlan 150

switchport mode access

duplex full

spanning-tree portfast

!

interface FastEthernet0/17

description Spare

switchport access vlan 150

switchport mode access

duplex full

spanning-tree portfast

Thanks in advance for any help you can provide

New Member

Re: 3750 and 3550 Flapping

purpose of Port Fast is to minimize the time interfaces must wait for spanning-tree to converge, it is effective only when used on interfaces connected to end stations. If you enable Port Fast on an interface connecting to another switch, you risk creating a spanning-tree loop.

New Member

Re: 3750 and 3550 Flapping

We have not changed the port fast option just yet but will be doing so, in the mean time we have gotten a couple other different messages and so I thought I would post them to see if they gave you other ideas on what might be wrong.

1053: 001051: .Oct 2 14:58:01: %ETHCNTR-3-LOOP_BACK_DETECTED: Keepalive packet loop-back detected on FastEthernet0/13.

1054: 001052: .Oct 2 14:58:01: %PM-4-ERR_DISABLE: loopback error detected on Fa0/13, putting Fa0/13 in err-disable state

This message has come up a couple of times, again any help you can give us will be greatly appreciated.

New Member

Re: 3750 and 3550 Flapping

From your last post , it does seem like you have a spanning tree loop. Can you provide how these two switches are connected and what else they are connected to? Also, you did not include any delta times in the output of your original post. How often are these ports bouncing?

Purple

Re: 3750 and 3550 Flapping

Why do you think this is a problem , these are just normal messages you would see when users turn their pc's on and off . Also it is not wise just to hardcode the duplex on ports, set the speed and duplex or leave both as auto . You will see these messages if you have snmp traps turned on , on each user port you need to add "no snmp trap-link status" to the ports if you don't want to see these messages everytime . If you think you might have a loop do a show cdp neighbor on the switches and see if have any ports where the switch sees itself as a neighbor , if so then someone has looped a port somewhere , you can also use show spanning tree blockedports command.

207
Views
0
Helpful
6
Replies