Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

3750 loses config when unplugged

I've got a 3750 that loses it's config when unplugged. Is there a battery that needs to be replaced or what is the cause of this?

6 REPLIES
Hall of Fame Super Silver

Re: 3750 loses config when unplugged

Does it also lose its config if you reboot it? Or is it just the loss of power that produces the problem?

Probably the issue is the setting of the config register. You can check the config register with the show version command. If the config register value is 0x2142 then it is ignoring the startup config when booting. If the config register is 0x2102 then there is some other issue.

HTH

Rick

New Member

Re: 3750 loses config when unplugged

I get 0xF as the value for the config register... Not sure about rebooting it, we moved the switch stack (3 3750s) and all the configs were gone when they came back up...

Cisco Employee

Re: 3750 loses config when unplugged

Can you paste an output of sh ver and sh run? If you have "service compress-config" configured, I can see that being an issue since it is not supported in 3750.

New Member

Re: 3750 loses config when unplugged

Not enough space for the sh run, I don't have service-compress configured.

#sh ver

Cisco Internetwork Operating System Software

IOS (tm) C3750 Software (C3750-I9-M), Version 12.1(19)EA1c, RELEASE SOFTWARE (fc

2)

Copyright (c) 1986-2004 by cisco Systems, Inc.

Compiled Tue 03-Feb-04 09:20 by yenanh

Image text-base: 0x00003000, data-base: 0x007C887C

ROM: Bootstrap program is C3750 boot loader

BOOTLDR: C3750 Boot Loader (C3750-HBOOT-M) Version 12.1(14r)EA1a, RELEASE SOFTWA

RE (fc1)

Switch uptime is 2 days, 15 hours, 40 minutes

System returned to ROM by power-on

System image file is "flash:c3750-i9-mz.121-19.EA1c/c3750-i9-mz.121-19.EA1c.bin"

cisco WS-C3750G-24TS (PowerPC405) processor (revision D0) with 118776K/12288K by

tes of memory.

Processor board ID CAT0811X0UA

Last reset from power-on

7 Virtual Ethernet/IEEE 802.3 interface(s)

72 FastEthernet/IEEE 802.3 interface(s)

34 Gigabit Ethernet/IEEE 802.3 interface(s)

The password-recovery mechanism is enabled.

512K bytes of flash-simulated non-volatile configuration memory.

Base ethernet MAC Address : 00:0F:8F:2A:CD:80

Motherboard assembly number : 73-7058-10

Power supply part number : 341-0045-01

Motherboard serial number : CAT081002ZT

Power supply serial number : LIT08070BFF

Model revision number : D0

Motherboard revision number : A0

Model number : WS-C3750G-24TS-S

System serial number : CAT0811X0UA

Hardware Board Revision Number : 0x09

Switch Ports Model SW Version SW Image

------ ----- ----- ---------- ----------

* 1 28 WS-C3750G-24TS 12.1(19)EA1c C3750-I9-M

2 52 WS-C3750-48TS 12.1(19)EA1c C3750-I9-M

3 26 WS-C3750-24P 12.1(19)EA1c C3750-I9-M

Switch 02

---------

Switch Uptime : 2 days, 15 hours, 27 minutes

Base ethernet MAC Address : 00:11:93:85:38:80

Motherboard assembly number : 73-7056-12

Power supply part number : 341-0028-01

Motherboard serial number : CAT08290N3S

Power supply serial number : DTH08290JXZ

Model revision number : G0

Motherboard revision number : A0

Model number : WS-C3750-48TS-S

System serial number : CAT0829N2QY

SFP Module assembly part number : 73-7757-02

SFP Module revision number : A0

SFP Module serial number : CAT08280WMP

Switch 03

---------

Switch Uptime : 2 days, 2 hours, 37 minutes

Base ethernet MAC Address : 00:12:80:A2:77:00

Motherboard assembly number : 73-8312-05

Power supply part number : 341-0029-03

Motherboard serial number : CAT08470DF1

Power supply serial number : LIT0838002H

Model revision number : D0

Motherboard revision number : A0

Model number : WS-C3750-24PS-S

System serial number : CAT0847N1TP

Top assembly part number : 800-21982-02

Top assembly revision number : B0

Version ID : N/A

Configuration register is 0xF

New Member

Re: 3750 loses config when unplugged

sh run (minus interfaces and vlans)

Building configuration...

Current configuration : 23059 bytes

!

version 12.1

no service pad

service timestamps debug uptime

service timestamps log datetime

service password-encryption

service sequence-numbers

!

enable secret

enable password

!

clock timezone UTC -8

ip subnet-zero

ip routing

!

mls qos map cos-dscp 0 8 16 26 32 46 48 56

mls qos srr-queue input bandwidth 90 10

mls qos srr-queue input threshold 1 8 16

mls qos srr-queue input threshold 2 34 66

mls qos srr-queue input cos-map queue 1 threshold 2 1

mls qos srr-queue input cos-map queue 1 threshold 3 0

mls qos srr-queue input cos-map queue 2 threshold 1 2

mls qos srr-queue input cos-map queue 2 threshold 2 4 6 7

mls qos srr-queue input cos-map queue 2 threshold 3 3 5

mls qos srr-queue input dscp-map queue 1 threshold 2 9 10 11 12 13 14 15

mls qos srr-queue input dscp-map queue 1 threshold 3 0 1 2 3 4 5 6 7

mls qos srr-queue input dscp-map queue 1 threshold 3 32

mls qos srr-queue input dscp-map queue 2 threshold 1 16 17 18 19 20 21 22 23

mls qos srr-queue input dscp-map queue 2 threshold 2 26 33 34 35 36 37 38 39

mls qos srr-queue input dscp-map queue 2 threshold 2 48 49 50 51 52 53 54 55

mls qos srr-queue input dscp-map queue 2 threshold 2 56 57 58 59 60 61 62 63

mls qos srr-queue input dscp-map queue 2 threshold 3 24 25 27 28 29 30 31 40

mls qos srr-queue input dscp-map queue 2 threshold 3 41 42 43 44 45 46 47

mls qos srr-queue output cos-map queue 1 threshold 3 5

mls qos srr-queue output cos-map queue 2 threshold 3 3 6 7

mls qos srr-queue output cos-map queue 3 threshold 3 2 4

mls qos srr-queue output cos-map queue 4 threshold 2 1

mls qos srr-queue output cos-map queue 4 threshold 3 0

mls qos srr-queue output dscp-map queue 1 threshold 3 40 41 42 43 44 45 46 47

mls qos srr-queue output dscp-map queue 2 threshold 3 24 25 26 27 28 29 30 31

mls qos srr-queue output dscp-map queue 2 threshold 3 48 49 50 51 52 53 54 55

mls qos srr-queue output dscp-map queue 2 threshold 3 56 57 58 59 60 61 62 63

mls qos srr-queue output dscp-map queue 3 threshold 3 16 17 18 19 20 21 22 23

mls qos srr-queue output dscp-map queue 3 threshold 3 32 33 34 35 36 37 38 39

mls qos srr-queue output dscp-map queue 4 threshold 1 8

mls qos srr-queue output dscp-map queue 4 threshold 2 9 10 11 12 13 14 15

mls qos srr-queue output dscp-map queue 4 threshold 3 0 1 2 3 4 5 6 7

mls qos queue-set output 1 threshold 1 138 138 92 138

mls qos queue-set output 1 threshold 2 400 400 100 400

mls qos queue-set output 1 threshold 3 36 77 100 318

mls qos queue-set output 1 threshold 4 20 50 67 400

mls qos queue-set output 2 threshold 1 149 149 100 149

mls qos queue-set output 2 threshold 2 118 118 100 235

mls qos queue-set output 2 threshold 3 41 68 100 272

mls qos queue-set output 2 threshold 4 42 72 100 242

mls qos queue-set output 1 buffers 20 20 20 40

mls qos queue-set output 2 buffers 16 6 17 61

mls qos

cluster enable SNet 0

cluster member 1 mac-address 0012.4328.f080

!

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

router rip

network 172.30.0.0

network 192.168.20.0

network 192.168.35.0

network 192.168.75.0

network 192.168.85.0

network 192.168.95.0

network 192.168.100.0

!

ip default-gateway 192.168.35.1

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.35.1

!

ip access-list extended CMP-NAT-ACL

dynamic Cluster-HSRP deny ip any any

dynamic Cluster-NAT permit ip any any

!

arp 192.168.85.233 03bf.c0a8.55e9 ARPA

arp 192.168.85.226 03bf.c0a8.55e2 ARPA

arp 192.168.85.220 03bf.c0a8.55db ARPA

arp 192.168.85.219 03bf.c0a8.55db ARPA

arp 192.168.85.209 03bf.c0a8.55db ARPA

!

line con 0

line vty 0 4

password 7

login

length 0

line vty 5 15

password 7

login

!

!

monitor session 1 source vlan 1 - 4094

monitor session 1 destination interface Fa2/0/2

end

Cisco Employee

Re: 3750 loses config when unplugged

One other thing.. Watch for the bootup sequence and see if you see any EXPRESS_SETUP-6-CONFIG_IS_RESET: messages as documented in the following bug

http://www.cisco.com/cgi-bin/bugtool/onebug.pl?bugid=CSCee75743

You could also try the workaround listed in the above bug.

415
Views
0
Helpful
6
Replies
CreatePlease to create content