Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

3Com adapters & errors in Cat 3550

I have been doing some testing using IPERF and have come across a strange issue with a 3Com PCMCIA adapter. The IPERF test is a simple two-way test where the client opens a TCP connection to the server and the server opens an equivilent TCP connection back to the client. After running for 10-seconds a report is generated showing how much data was transferred in each direction and what the throughput was. I was actually testing that my QoS Policy-Map was working correctly but this happened...

I have the PC piggy-backed off a Cisco 7960 IP Phone and port-security is enabled on the port allowing 3-MAC addresses and aging to be 3-minutes of inactivity:

interface FastEthernet0/1

switchport access vlan 20

switchport mode access

switchport voice vlan 500

switchport port-security maximum 3

switchport port-security

switchport port-security aging time 3

switchport port-security violation restrict

switchport port-security aging type inactivity

service-policy input IPPHONE+PC

wrr-queue bandwidth 5 25 70 1

wrr-queue cos-map 1 1

wrr-queue cos-map 2 0

wrr-queue cos-map 3 2 3 4 6 7

wrr-queue cos-map 4 5

priority-queue out

With the 3Com adapter the test starts to run and then I get a port-security violation on the port due to too many MAC addresses. I have disabled port-security to see how many MAC addresses appear:

cat-3550#sho mac-address-table interface fastEthernet 0/4

Mac Address Table

-------------------------------------------

Vlan Mac Address Type Ports

---- ----------- -------- -----

20 000a.5e07.0e04 DYNAMIC Fa0/4

20 0011.21f1.0c6e DYNAMIC Fa0/4

20 0800.4500.05dc DYNAMIC Fa0/4

20 0800.4500.0028 DYNAMIC Fa0/4

20 3435.3637.3839 DYNAMIC Fa0/4

20 3637.3839.3031 DYNAMIC Fa0/4

500 0011.21f1.0c6e DYNAMIC Fa0/4

Total Mac Addresses for this criterion: 6

cat-3550#

Only the MAC address 000a.5e07.0e04 (3Com card) and 0011.21f1.0c6e (IP Phone) are real the others are only generated when IPERF is run and timeout when the aging timer expires.

I have checked the interfaces are negotiating duplex correctly and they are. I have tried with a different NIC (notebook built-in adapter) and this only ever shows 3-MAC addresses:

cat-3550#sho mac-address-table interface fastEthernet 0/4

Mac Address Table

-------------------------------------------

Vlan Mac Address Type Ports

---- ----------- -------- -----

20 000d.9d90.fbe5 DYNAMIC Fa0/4

20 0011.21f1.0c6e DYNAMIC Fa0/4

500 0011.21f1.0c6e DYNAMIC Fa0/4

Total Mac Addresses for this criterion: 3

cat-3550#

Outtbound throughput with the 3Com card is about 10% less than the other card (49Mbps/63Mbps), inbound is similar (64Mbps/62Mbps).

Obviously this is something to do with the 3Com card (or drivers?). Has anyone seen anything similar with 3Com or other cards? Is there any solution or is it just the 3Com cards/drivers are not up to the job? It is a 3Com 3C3FEM656C 10/100 Cardbus PC Card with the latest drivers available from 3Com's website.

Thanks

Andy

169
Views
0
Helpful
0
Replies
CreatePlease login to create content